mouhsineelachbi
Posts: 3
Joined: Thu Jun 13, 2019 1:11 pm

Structure Needs cleaning Raspbian

Thu Jun 13, 2019 1:19 pm

Good morning
I just want to ask a question about an error message I got all the time is that my system Raspbian said that the structure needs cleaning everytime I want to install a package using apt install
and when I clean It using another installed Linux(Ubuntu) I got a message that I lost libraries
So How can I clean the structure everytime raspbian boot up if It possible as a normal one do before It mount the system partition like (ubuntu for exemple)
if It's not possible I just need how to clean It manually and in a safe mode please

DirkS
Posts: 9806
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Structure Needs cleaning Raspbian

Thu Jun 13, 2019 5:00 pm

Please post the *full* message you get.


DirkS
Posts: 9806
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Structure Needs cleaning Raspbian

Thu Jun 13, 2019 11:26 pm

Please post text instead of a screenshot...

I can't see the connection between your first post (that's about errors when using 'apt') and your screenshot which seems to be while building from source
Please clarify the exact command(s) you're executing *and* full messages as text.

mouhsineelachbi
Posts: 3
Joined: Thu Jun 13, 2019 1:11 pm

Re: Structure Needs cleaning Raspbian

Fri Jun 14, 2019 8:50 am

I was compiling opencv the version 3.4.1 and the message "Structure needs cleaning " shows up

DirkS
Posts: 9806
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Structure Needs cleaning Raspbian

Fri Jun 14, 2019 5:31 pm

mouhsineelachbi wrote:
Fri Jun 14, 2019 8:50 am
I was compiling opencv the version 3.4.1 and the message "Structure needs cleaning " shows up
So it has nothing to do with using 'apt' to install a program.
No experience with compiling opencv, so I cannot help you with that...

hippy
Posts: 5178
Joined: Fri Sep 09, 2011 10:34 pm
Location: UK

Re: Structure Needs cleaning Raspbian

Fri Jun 14, 2019 6:06 pm

mouhsineelachbi wrote:
Fri Jun 14, 2019 8:50 am
I was compiling opencv the version 3.4.1 and the message "Structure needs cleaning " shows up
The exact error is "make[2]: execvp: /bin/sh: Structure needs cleaning" so maybe lookup what 'execvp' and maybe Google search on that plus "Structure needs cleaning" to see if that gives an indication of why, what's gone wrong, and what the fix is.

Maybe ask the author of the package or tutorial you are following if they know.

Return to “Beginners”