Doub
Posts: 19
Joined: Fri Apr 07, 2017 9:48 pm

Disabling lens shading

Tue Apr 16, 2019 7:12 am

My project puts a naked IMX219 sensor in a focal plane of a scavenged telescopic lens. I noticed I get some unexpected red tint near the edges of the image, and some greenish gray tint near the middle. I'm wondering if that comes from the lens shading step of the camera pipeline. I see the MMAL_PARAMETER_LENS_SHADING_OVERRIDE but the data to pass to it looks a bit obscure to me.

Is there a way to disable the lens shading entirely? Otherwise what would be the easiest way to override it so as to make it a no-op?

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6626
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: Disabling lens shading

Tue Apr 16, 2019 8:59 am

Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6626
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: Disabling lens shading

Tue Apr 16, 2019 9:00 am

Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

Doub
Posts: 19
Joined: Fri Apr 07, 2017 9:48 pm

Re: Disabling lens shading

Tue Apr 16, 2019 11:56 am

I did find the second link but not the first. Thanks.

Interestingly (at least to me), the red tint on the edges is even worse without lens shading. So I probably need to customize it instead of turning it off. But that's work for a later stage of the project.

Return to “Camera board”