Posts: 7
Joined: Tue Oct 04, 2016 3:49 pm


Tue Mar 26, 2019 6:19 pm

So I am using a Raspberry Pi to run my security camera and it works just great. It has been running for several years with no problems (I use ZoneMinder to do all the control and recording).
So this week I thought about using the Pi as a Plex client. I have a client running on my Ubuntu box and it works really well. My research led me to RasPlex. Sounded and looked pretty good. So I downloaded the GetRasPlex-debian and tried to run it on my Ubuntu Box. Missing a few dependancies. After some installations and workarounds got it to work. Unfortunately it will not recognize the microSD card partition and so will not write to it.
Ok, tried new SDcard, reformatted card etc, etc still no luck.
So I decided to try my Windows 10 machine. Again downloaded GetRasPlex and ran it. Now it finds the SDcard, but errors out anywhere from 25% to 98% complete.
Needless to say I have about given up on trying to get RasPlex running.
That brings me to my real question. Is there any other Plex Client that will run on the Pi. I know I can use the web and connect, but I would like to have a standalone (imbedded) app on the PI so when I want to use plex all I do is change the input on my TV.
So what is everyone else using to get Plex to their TVs. (I should add, my TV does not support the Plex App natively.
Thanks in advance.


Re: RasPlex

Tue Mar 26, 2019 8:16 pm

Looking at the legacy install instructions it seems the image is a full OS image put together with the programs installed / configured so I’m a bit baffled at to why your cards / installs fail.

It may be worth checking everything from the download, SD card interface etc. and persevering if no one comes back :?:

Posts: 7
Joined: Tue Oct 04, 2016 3:49 pm

Re: RasPlex

Tue Mar 26, 2019 8:56 pm

Believe me I have tried just about everything.
First I downloaded two different versions of the SDcard installer GetRasPlex for two different OS, Linux and Windows. Neither worked.
Next I bought new SDcards thinking that there may have been an issue there.
Still GetRasPlex on both my Ubuntu installation and Windows 10 failed to write to the SDcard.
I used one of the cards to write a Rasbian image and it boots and runs just fine.
I also used the Ubuntu Disk Image Writer to write the image directly to the SDcard. Now I only get the Rainbow boot screen and my power light blinks 4 slow 4 fast. (This behavior has been reported last year right after the 3B+ was released.
I also tried to install the PlexMediaPlayer image and got the same indications when I tried to boot the PI, rainbow screen and flashing red light.

I just don't know what else to try right now. One suggestion was to change power supply. The one I have I purchased with the PI, but I need to check the power rating on it just to make sure.

There is a yellow lightning bolt on the top right of the screen when I boot RasPlex. If my research is correct, that means low power. But if I boot Rasbain no lightning bolt. My power supply is brand new 5V 2.5A. So I should have plenty of power.

So if anyone has any suggestions I would really really appreciate them.

Posts: 234
Joined: Fri Oct 03, 2014 3:03 pm

Re: RasPlex

Wed Mar 27, 2019 11:26 am

Kodi (via LibreElec, OSMC, Xbian or just a straight install under Raspbian) has an official Plex add-on available in its official repo.

Posts: 7
Joined: Tue Oct 04, 2016 3:49 pm

Re: RasPlex

Wed Mar 27, 2019 2:08 pm

Thank you. I installed OSMC and it works just fine. I also found (on the box my pi came in) a notice that says if you see rainbow screen and lightning bolt it means the software is incompatible with the Pi 3 B+. So I guess I will just have to wait for the update to RasPlex. In the mean time I can use what I have and it seems to be working really well.

Return to “Media centres”