tinker2much
Posts: 21
Joined: Wed Jun 20, 2018 12:38 am

warning in recent wpa_supplicant update

Wed Mar 06, 2019 12:55 am

I just upgraded a bunch of my pi's and got this warning (pardon any typos - I'm retyping this from a screenshot):

"wpasupplicant (2:2.6-19) unstable; urgency=medium

With this release, wpasupplicant no longer responds to the system
default minimum TLS version, defaulting to TLSv1.0, not TLSv1.2. If
you're sure you will never connect to EAP networks requiring anything less
than 1.2, add this to your wpasupplicant configuration:

tls_disable_tlsv1_0=1
xls_disable_tlsv1_1=1

wpasupplicant also defaults to a security level 1, instead of the system
default 2. Should you need to change that, change this setting in your
wpasupplicant configuration:

openssl_c[email protected]=2

Unlike wpasupplicant, hosted still respects system defaults.

-- Andrej Shadura <[email protected]> Sat, 15 Dec 2018 "

>>> DO I need to worry about this?

As a test, I added the following lines to /etc/wpa_supplicant/wpa_supplicant.conf, before the network= block.

tls_disable_tlsv1_0=1
tls_disable_tlsv1_1=1
[email protected]=2

And found that wireless wouldn't connect, removed them, and I could connect again.

Assuming that was the correct place and way to change those settings.

>>> Comments?

NOTE my current version is now:
sudo apt show wpasupplicant
Package: wpasupplicant
Version: 2:2.6-21~bpo9~rpt1

bls
Posts: 69
Joined: Mon Oct 22, 2018 11:25 pm

Re: warning in recent wpa_supplicant update

Wed Mar 06, 2019 3:27 am

Interesting...I installed it as well, with the same message. However, the tls_disable_... generate warnings from wpa_supplicant, which is why it didn't connect for you.

The good news is that this updated version appears to correct the problem I was having in https://www.raspberrypi.org/forums/view ... 6&t=234058.

Return to “Networking and servers”