bedtime
Posts: 69
Joined: Thu Dec 13, 2018 6:02 pm

[SOLVED] kworker hogging cpu

Wed Feb 27, 2019 12:35 pm

I am extremely mindful of how much cpu my RPI 3b+ uses. It consistently idles between 99.2% and 99.5%. It took a lot of work to get it there... Last night all was working fine. I woke up and turned the RPI on and the idle was 95%. It seems that these root processes are the hoggers:

Code: Select all

  323 root      20           4.3   0:01.56 kworker/u8:3                     
   65 root     -51           3.0   0:10.44 irq/92-mmc1                      
pi user seems to use regular amount of cpu.

I was monkeying around with shells and the chsh command and also mksh-static. I have returned the default shell to mksh, and the problem persists, though it was working perfectly, even with a reboot, before I went to bed. As I said, I am anal about cpu usage.

I have my keyboard and mouse plugged into the USB as usual—no other devices. Raspian is running on the regular sd card.

I tried installing perf to solve the issue, and upon running, I get:

Code: Select all

$ perf
/usr/bin/perf: line 13: exec: perf_4.14: not found
E: linux-perf-4.14 is not installed.
$ sudo apt-get install linux-perf-4.14                                  
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-perf-4.14
E: Couldn't find any package by glob 'linux-perf-4.14'
E: Couldn't find any package by regex 'linux-perf-4.14'
$ sudo apt-get install linux-perf-4*                                    
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-perf-4*
E: Couldn't find any package by glob 'linux-perf-4*'
E: Couldn't find any package by regex 'linux-perf-4*'
$ sudo perf
/usr/bin/perf: line 13: exec: perf_4.14: not found
E: linux-perf-4.14 is not installed
/boot/config.txt:

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

disable_splash=1


# uncomment if you get no picture on HDMI for a default "safe" mode
hdmi_safe=0

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=800
#framebuffer_height=480

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=9

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
gpu_mem=256
#dtoverlay=vc4-kms-v3d
#scaling_kernel=8
#dtoverlay=vc4-fkms-v3d

/boot/cmdline.txt:

Code: Select all

dwc_otg.lpm_enable=0 dwc_otg.fiq_fix_enable=1 console=serial0,115200 console=tty1 root=PARTUUID=a4b62e48-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash loglevel=3 rd.udev.log_priority=0 vt.global_cursor_default=0
Any ideas on how to investigate this?

Thanks.


*** EDIT ***

Progress! I've found out that the issue is something to do with the wireless; I turned it off and the issue went away. I have to go out now, but I'll be back. Thought I'd quickly add this info before I go. :)

*** EDIT 2 ***

FIXED! Reset the modem and all good. Gotta go or will be late! :D

Return to “Troubleshooting”