picandies
Posts: 186
Joined: Wed Nov 26, 2014 5:13 pm

can't upgrade Geany?

Sun Jan 20, 2019 12:45 am

According to geany.org, the latest version is 1.34...
I noticed my rpi with stretch is running 1.29, which is from way back in 2016!!!

What is the geany upgrade command?

I tried the following, but was told 1.29 is the newest version ...A LIE...1.29 is about 3 years old.

[email protected]:~ $ sudo apt-get install geany
Reading package lists... Done
Building dependency tree
Reading state information... Done
geany is already the newest version (1.29-1+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

klricks
Posts: 6495
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: can't upgrade Geany?

Sun Jan 20, 2019 4:21 am

picandies wrote:
Sun Jan 20, 2019 12:45 am
According to geany.org, the latest version is 1.34...
I noticed my rpi with stretch is running 1.29, which is from way back in 2016!!!

What is the geany upgrade command?

I tried the following, but was told 1.29 is the newest version ...A LIE...1.29 is about 3 years old.

[email protected]:~ $ sudo apt-get install geany
Reading package lists... Done
Building dependency tree
Reading state information... Done
geany is already the newest version (1.29-1+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Debian, which Raspbian is based on, uses a tested and stable philosophy. Debian releases a new version about every 2 years. Once a new OS version is released the package versions are frozen until the next release. Therefore all packages can be several versions older than what may be available elsewhere. Only security updates are let through.

The RPF does update and/or modify a handful of packages in Raspbian.

If you want later versions of whatever package then you would need to obtain source code and compile yourself or wait for the next major OS release 'Buster' which is due out in a few months. (Raspbian will then be updated to 'Buster' sometime after the Debian 'Buster' release).

A quick Google shows that 'Buster' will have Geany 1.33
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

fruitoftheloom
Posts: 20123
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: can't upgrade Geany?

Sun Jan 20, 2019 12:27 pm

picandies wrote:
Sun Jan 20, 2019 12:45 am
According to geany.org, the latest version is 1.34...
I noticed my rpi with stretch is running 1.29, which is from way back in 2016!!!

What is the geany upgrade command?

I tried the following, but was told 1.29 is the newest version ...A LIE...1.29 is about 3 years old.

[email protected]:~ $ sudo apt-get install geany
Reading package lists... Done
Building dependency tree
Reading state information... Done
geany is already the newest version (1.29-1+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Create a Backup.

Change your sources from Stretch to Buster run:

Code: Select all

sudo apt update
sudo apt install geany

Then change you sources back to Stretch and hope and pray it works...


By the by is their a reason you need a newer version of geany ?

https://www.geany.org/Download/Releases
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

picandies
Posts: 186
Joined: Wed Nov 26, 2014 5:13 pm

Re: can't upgrade Geany?

Mon Jan 21, 2019 1:25 am

Change your sources from Stretch to Buster run:
what do you refer to? Do you need to download these files?

By the by is their a reason you need a newer version of geany ?

Seems like if the version is 3 years old, there would be a fair number of fixes & improvements now (of course that might be unfounded).

Return to “General discussion”