hvdkooij
Posts: 3
Joined: Fri Jan 04, 2019 4:04 pm

LG TV with HDMI-CEC not working for KODI

Sat Jan 19, 2019 2:48 pm

Hi,

I have been digging around a bit but couldn't find a solution yet.

I have my PI (3B) attached to my LG TV and installed KODI on top of Rasbian. It shows just find and it connects the CEC to my TV.
But my TV remote seems to have no impact at all. It seems as if is claimed by the PI as I can't even switch input to another HDMI port for example. The only ones that still have an effect on the TV itself are the Power button and the brightness control.

None of the other ones shown anything.

The TV is a LG 32LC51

Code: Select all

[email protected]:~$ cec-client -l
libCEC version: 4.0.2, git revision: libcec-4.0.2+30-8adc786~dirty, compiled on Mon Aug 21 09:41:41 UTC 2017 by [email protected]: Name or service not known on Linux 4.4.0-92-generic (armv7l), features: P8_USB, DRM, P8_detect, randr, RPi
Found devices: 1

device:              1
com port:            RPI
vendor id:           2708
product id:          1001
firmware version:    1
type:                Raspberry Pi
This is a rather new terrain for me so I am still struggling on how to debug this.
I am not particularly shy around Linux, bash or vi, so if someone can guide me on how to debug this issue I will dive in with a couple of SSH session and see what I can dig up.

What I would like is to use the remote to control the basics of KODI. And for the other functions to use the remote for the TV.
This is a big issue in regard to the W.A.F. (Wife Acceptance Factor)

klricks
Posts: 7031
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: LG TV with HDMI-CEC not working for KODI

Sat Jan 19, 2019 5:24 pm

Have you enabled CEC in the TV OSD?
On most brands of TV the CEC is not enabled by default.
Each brand has their own name for CEC. LG is SIMPLINK per Google.
Unless specified otherwise my response is based on the latest and fully updated RPiOS Buster w/ Desktop OS.

patel8786
Posts: 1
Joined: Fri Feb 14, 2020 6:46 pm

Re: LG TV with HDMI-CEC not working for KODI

Fri Feb 14, 2020 6:48 pm

Hi

Did you manage to figure this one out?

I've got simplink switched on but nothing.
Also my rpi3 works perfectly on my older Samsung smart tv.

Any help would be appreciated.

Amorimleandro
Posts: 1
Joined: Sat Apr 04, 2020 7:05 pm

Re: LG TV with HDMI-CEC not working for KODI

Sat Apr 04, 2020 11:30 pm

Yesterday I got my new TV and faced the same problem. With my olders TVs, LG and Samsung, the HDMI-CEC always worked very well. But, with that new one, was not so easy to get the raspberry working with TV's control. The TV model is 55SM8600 and webOS version 04.71.25.

Ok, first, when I connected the HDMI cable to the TV, the raspberry was identified like a Roku and categorized in the Set-Top Box/OTT group. The remote control was not able to interact with raspberry. Simplink (HDMI-CEC) was ON in the connection settings options.

Some time later, after several attempts, and after a new try removing and reconnecting the raspberry HDMI cable in another port, I realized in just one of the categories listed in the Device Connector page, where you can find: Set-Top Box/OTT, Game Console, Home Theater etc, exactly in the Set-Top Box/OTT, an interesting button, the reset device button. So, I just clicked on it and got out that page and returned to Raspberry input to check if I had success, and for my happiness, yes, remote control working.

After that, just edited the icon and name of the HDMI port and that's the possible solution to other people.

Greetings from Brazil!

joaquimparis
Posts: 3
Joined: Tue Sep 11, 2018 12:38 pm

Re: LG TV with HDMI-CEC not working for KODI

Tue Apr 14, 2020 1:31 am

Hi.
I'm using a LG UM7520PSB with WebOS 04.71.30

It was working fine, but now not anymore.
I've tryed several things to the best of my knowledge.
The reset option is not available under the OTT device option.
I'm so frustrated. I don't know what happened. Tryed to reset back to default params under the cec in Kodi.
Tryed to turn on/off the simplylink feature.

Once in Kodi, when I use the LG remote it only shows the banner showing up the hdmi1 input that is active (and the name I use "Kodi") no matter what buttons I press.

Before, when using the arrows, middle-center and back buttons it worked perfect as the esc/backspace/arrows/enter of a keyboard which is fine to me.

Feeling like in a dead loop. Any ideas?

gevillanueva
Posts: 1
Joined: Mon May 04, 2020 11:12 pm

Re: LG TV with HDMI-CEC not working for KODI

Mon May 04, 2020 11:20 pm

Amorimleandro wrote:
Sat Apr 04, 2020 11:30 pm
Yesterday I got my new TV and faced the same problem. With my olders TVs, LG and Samsung, the HDMI-CEC always worked very well. But, with that new one, was not so easy to get the raspberry working with TV's control. The TV model is 55SM8600 and webOS version 04.71.25.

Ok, first, when I connected the HDMI cable to the TV, the raspberry was identified like a Roku and categorized in the Set-Top Box/OTT group. The remote control was not able to interact with raspberry. Simplink (HDMI-CEC) was ON in the connection settings options.

Some time later, after several attempts, and after a new try removing and reconnecting the raspberry HDMI cable in another port, I realized in just one of the categories listed in the Device Connector page, where you can find: Set-Top Box/OTT, Game Console, Home Theater etc, exactly in the Set-Top Box/OTT, an interesting button, the reset device button. So, I just clicked on it and got out that page and returned to Raspberry input to check if I had success, and for my happiness, yes, remote control working.

After that, just edited the icon and name of the HDMI port and that's the possible solution to other people.

Greetings from Brazil!
I've tried look for it and I couldn't find the reset device button.
I have a 49UM71 , I've been using the raspberry in a Samsung until this morning and it was working properly ( Anynet+).
Could anyone fix this problem between LG smart tv remote control and Raspberry Pi3?

Return to “Troubleshooting”