mjean_noel
Posts: 6
Joined: Thu Apr 05, 2018 8:44 am

crontab

Fri Dec 07, 2018 2:48 pm

Bonjour,

j'ai créé une tâche planifié pour télécharger une image avec "sudo crontab -e"
Tout fonctionne bien, sauf que maintenant j'aimerais la supprimer.
Mon problème est que après un redémarrage la tâche est de nouveau présente.
Et pourtant, je fais bien Ctrl+O pour écrire puis Ctrl + X pour quitter.
Quelqu'un a une idée?

jeanluc
Posts: 280
Joined: Thu Apr 11, 2013 9:44 am

Re: crontab

Fri Dec 07, 2018 2:58 pm

Salut,

Un petit :

Code: Select all

sudo service cron restart
Après la suppression de la tâche sans doute...

mjean_noel
Posts: 6
Joined: Thu Apr 05, 2018 8:44 am

Re: crontab

Fri Dec 07, 2018 3:19 pm

Je viens d'essayer, mais ça ne fonctionne pas.
Merci quand même.

jeanluc
Posts: 280
Joined: Thu Apr 11, 2013 9:44 am

Re: crontab

Sat Dec 08, 2018 8:59 am

mjean_noel wrote:
Fri Dec 07, 2018 3:19 pm
Je viens d'essayer, mais ça ne fonctionne pas.
Merci quand même.
Salut,

Es tu certain de ne pas avoir créé cette tâche ailleurs en plus ?

-Dans le fichier /etc/rc.local par exemple, dans systemd , dans /etc/cron.xxx, ...

La génération spontanée, il ne me semble pas que ça existe sous Linux, certains font part de miracles comme @Osika91 dans ce topic:

viewtopic.php?p=1400565#p1400565

Mais, je n'y crois pas du tout ... :o

jelopo
Posts: 1425
Joined: Wed Oct 17, 2012 7:53 pm

Re: crontab

Sat Dec 08, 2018 9:32 am

Bonjour,

En complément, passer la commande

Code: Select all

sudo crontab -l
pour visualiser si la ligne relative est bien supprimée.

N.B. : Si et seulement si aucune autre tâche cron n'est présente dans le fichier de crontab, il est possible de tout supprimer de la crontab de root avec

Code: Select all

sudo crontab -r
A+

mjean_noel
Posts: 6
Joined: Thu Apr 05, 2018 8:44 am

Re: crontab

Mon Dec 10, 2018 1:06 pm

Avant le reboot , la ligne bien disparu avec crontab -l , mais après reboot elle est de nouveau la.
Idem avec crontab -r
On dirais que le fichier n'est pas sauvegardé et qu'il reste dans /tmp/crontab.XXXXXX/crontab
Existe t'il un autre moyen de modifier ce fichier?

jelopo
Posts: 1425
Joined: Wed Oct 17, 2012 7:53 pm

Re: crontab

Mon Dec 10, 2018 9:37 pm

Bonjour,

C'est un phénomène fort surprenant. Je suppose que le problème ne doit pas être seulement lié à la crontab. Le disque est-il en lecture seule ?
Est-il possible d'écrire un nouveau fichier ? Celui-ci est-il présent après un reboot ? Est-il possible de modifier un fichier ? La modification est-elle présente après un reboot ?

Personnellement pour modifier une crontab, j'opère de la façon suivante:

Code: Select all

sudo crontab -l > /tmp/root.cron
nano /tmp/root.cron
sudo crontab /tmp/root.cron
* Vérifier avec

Code: Select all

sudo crontab -l 
A+

mjean_noel
Posts: 6
Joined: Thu Apr 05, 2018 8:44 am

Re: crontab

Tue Dec 11, 2018 8:14 am

Bonjour,

en effet peu importe la modification que je fais, rien n'est sauvegardé après un reboot.
Il est possible d'écrire sur le disque, j'ai créé un dossier, copier des photos et modifié un fichier samba, mais après un reboot plus rien.
Une idée de quoi ça pourrait provenir?

jelopo
Posts: 1425
Joined: Wed Oct 17, 2012 7:53 pm

Re: crontab

Tue Dec 11, 2018 12:35 pm

Bonjour,

* Essayer de créer un tout petit fichier dans /boot qui est sur une autre partition, rebooter, vérifier l'existance du fichier.
* Vérifier que la carte SD n'est pas en lecture seule. (bouton sur les cartes SD au format standard).
* Vérifier si les systèmes de fichiers de la carte SD ne sont pas en lecture seule (ro)

Code: Select all

sudo mount | grep /dev/mmcblk
* Consulter les logs de démarrage de l'OS rechercher les logs relatives au

Code: Select all

sudo dmesg
* Consulter /etc/fstab pour vérifier qu'il n'est pas demandé de montage en read-only (ro) dans les options.

* Il est possible que la carte SD n'accepte plus d'écriture aussi. Dans ce cas, il faut soit réinstaller sur une autre carte, soit migrer toute cette carte vers une autre.

Si d'autre forumeurs ont d'autre pistes, je passe la plume...


A+

Return to “Français”