XBMC - Vidoe doesn't show, command line visible

5 posts
by asprinwizard » Tue Nov 13, 2012 2:06 pm
Hi there,

I have just upgraded my Raspberry Pi to run the latest Raspbian with XBMC. I followed the simple tutorial here http://michael.gorven.za.net/raspberrypi/xbmc and everything seemed to install fine.

I ran into problems running XBMC as the pi user. The keyboard wouldn't work when I was prompted to enter username and password. I found that I could overcome this by running XBMC as root (not sure if this is a good idea), but then I found that when I tried to play a video all I got was the command line terminal from where I came. The video was 'playing' in that the remote still worked, time ticked by but there was no image at all. If you go back to the XBMC main menu it appears over the command line.

I thought this might be an issue with running from root so I tried again as the pi user but still the same issue occurs. Has anyone else got this issue. The only threads I could find on here were several months old and didn't offer a direct solution so if anyone has any advice I'd be most grateful if you could post it here.

Incidentally I am not automatically booting into XBMC. I run it from the command line.

Posts: 6
Joined: Tue Nov 13, 2012 1:54 pm
by fozzy bear » Wed Nov 14, 2012 3:52 pm
hello asprinwizard

I don't use xbmc myself and so I don't know that much about it

Australian Personal Computer magazine recently ran
some articles on the Pi ( September 2012 issue
under Make a $ 50 PC - Your Next Home Theatre System etc )

and you can download a special image of xbmc
and load it onto it's own SD card
and you boot it like any Pi Linux distro.

tinyurl.com/bnhymrs gets you the image

which you dl, unzip and write to your SD card ( win32imager
I guess ).

This runs like a stand alone xbmc system on the Pi
and lets you run videos from USB hard drives etc..
( thumbdrive etc).

I don't know if this will help you any (hope so).

Then there is Omxplayer which I think is under
Pi Linux etc..

APC magazine have also made up their own
Linux distro for the Pi ( Pi Linux )
( same procedure to set up on an SD card ).

The image for Pi Linux is at :


Pi Linux has two logins : root / apc (admin) and apc / magazine (user)

Hope something here helps.

Posts: 100
Joined: Sat Sep 22, 2012 11:30 am
by asprinwizard » Thu Nov 15, 2012 10:00 am
Thanks for your reply. Unfortunately that solution will not work for me as I use the Pi for various other things - webserver, torrent downloader, backup machine, etc. Hence why I don't boot directly to XBMC.

I'm lead to believe XBMC is running fine on the new Raspbian version so it should be possible to get it up and running for what I need.

Can anyone advise what the likely cause of the no video issue is. Is it just a focus issue or perhaps a video driver issue? My setup is pretty standard so I would hope it would be a simple solution. Unfortunately I just don't know where to begin!

Thanks again.
Posts: 6
Joined: Tue Nov 13, 2012 1:54 pm
by mgorven » Thu Jan 10, 2013 6:19 am
asprinwizard wrote:I ran into problems running XBMC as the pi user. The keyboard wouldn't work when I was prompted to enter username and password.

Non-root users don't have access to input devices. To address this, create a new group, add the pi user to it, and setup some udev rules to grant the appropriate ownership:

Code: Select all
# addgroup --system input
# adduser pi input
# echo 'SUBSYSTEM=="input", GROUP="input", MODE="0660"' > /etc/udev/rules.d/99-input.rules

Reboot to effect the changes.
User avatar
Posts: 7
Joined: Sat Aug 04, 2012 7:06 am
Location: Sunnyvale, CA, USA
by RedRedKrovy » Thu Jan 10, 2013 12:44 pm
Don't forget you can also use BerryBoot to run Raspbian and OpenElec from the same card. It works by making a partition with the Kernel on it and then making a separate partition for each OS' system files.
Posts: 9
Joined: Fri Dec 07, 2012 5:01 pm