jplelievre
Posts: 1
Joined: Fri Oct 12, 2018 10:28 pm

Plus d’accès en ssh !

Fri Oct 12, 2018 10:37 pm

Bonjour,

j'ai un raspberry pi3 et j'ai voulu désactiver le Bluetooth en rentrant la commande : sudo echo "dtoverlay=pi3-disable-bt" >> /boot/config.txt
Mais j'ai eu en retour :
-bash: /boot/config.txt: Permission non accordée

Suite à une recherche, je me suis connecte en super-utilisateur en tapant :
sudo passwd root

Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully

Je me reconnecte à mon raspberry en ssh mais plus possible de taper une ligne de commande, plus aucune ligne ne s'affiche.
Pour info, c'est le logiciel jeedom qui est installé dessus. Et il fonctionne quand meme !

Que dois-je faire ?
Merci d'avance pour votre aide.

jelopo
Posts: 1411
Joined: Wed Oct 17, 2012 7:53 pm

Re: Plus d’accès en ssh !

Sat Oct 13, 2018 1:04 pm

Bonjour,

Tenter de rebooter pour voir si vous avez la main à nouveau. Si ssh ne fonctionne pas essayer de se connecter avec un écran/clavier.

A+

totoharibo
Posts: 3925
Joined: Thu Jan 24, 2013 8:43 am

Re: Plus d’accès en ssh !

Sat Oct 13, 2018 7:07 pm

tu te connectes comment en ssh ?
ssh [email protected]
Normalement c'est pas autorisé
chez moi pas de mot de passe root donc c'est impossible
AMHA : Il faut revoir /etc/ssh/sshd.conf (en root bien entendu)

Plus courammement il faut se connecter en [email protected]
puis un sudo su.

Je ne vois pas pourquoi tu as besoin d'un mot de passe root.

JumpZero
Posts: 858
Joined: Thu Mar 28, 2013 7:35 pm
Location: 127.0.0.1

Re: Plus d’accès en ssh !

Thu Oct 18, 2018 11:57 am

Bonjour,

- mauvaise utilisation de sudo :
sudo permet de passer super-utilisateur ("root") pour la commande qui suit sudo, mais pas s'il y a 2 commandes sur la même ligne ou s'il y a une redirection (ce qui est le cas dans ta commande: la redirection est: >> )
pour vérifier celà essaies:

Code: Select all

sudo echo coco
pas d'erreur, le texte "coco" s'affiche sur la console.

Code: Select all

sudo echo coco >> /bin/coco.txt
Erreur seul root a le droit d’écrire dans /bin/ (comme dans /boot/ dans ton cas)
Si tu as bien compris les redirections cette deuxième commande, si elle avait fonctionnée, aurait ajoutée une ligne contenant "coco" au fichier /bin/coco.txt. En fait ici elle aurait aussi crée le fichier puisqu'il n'existait pas.
Donc pour contourner ça il existe plusieurs solutions par exemple celle-ci

Code: Select all

sudo sh -c "echo coco >> /bin/coco.txt"
Ici la commande sh lance un shell qui execute la commande (option -c) entre les guillemets
Autrement ce que je fais toujours

Code: Select all

sudo bash
lance un shell bash dans lequel tu es root, là tu fais tout ce que tu as à faire, et Ctrl-D pour sortir quand tu as fini.

- Ensuite tu dis que pour te connecter en super-utilisateur tu as fait: sudo passwd root
mais ce n'est pas ça là tu as modifié le mot de passe root!
Si tu arrives à taper cette commande

Code: Select all

sudo passwd -d root
tu effaceras le mot de passe root que tu as crée.
Autrement il suffit d'effacer dans le fichier /etc/shadow ce qui suit le mot root et qui est entre les 2 premiers 2 points. Exemple

Code: Select all

root:$z$yxxxx....xxxx:12345:0...
à changer en

Code: Select all

root::12345:0...
le mot de passe crypté a été effacé.
Mais pour cette manip le plus simple est d'utiliser une autre machine sur laquelle tu montes la carte SD qui contient ton système.

@+
--
Jmp0

Return to “Français”

Who is online

Users browsing this forum: No registered users and 2 guests