Mathias_Va
Posts: 5
Joined: Fri Sep 28, 2018 3:50 pm

Pi3 B+ cannot boot with jessie

Mon Oct 01, 2018 8:38 am

I am trying to use Pi3 B+ with Jessie software but it always show rainbow in display and never boot up!! however it works with stretch !

is it not combat-able?, is it work only with stretch ?

Any advice?

drgeoff
Posts: 10319
Joined: Wed Jan 25, 2012 6:39 pm

Re: Pi3 B+ cannot boot with jessie

Mon Oct 01, 2018 8:52 am

The boot files in the Raspbian Jessie downloads do not support the slightly different hardware of the 3B+ compared to previous models of RPi.

Either use Stretch or search for how to update the requisite files. (The former is strongly recommended.)
Last edited by drgeoff on Mon Oct 01, 2018 8:53 am, edited 1 time in total.

User avatar
procount
Posts: 2035
Joined: Thu Jun 27, 2013 12:32 pm
Location: UK

Re: Pi3 B+ cannot boot with jessie

Mon Oct 01, 2018 8:53 am

Ditto.
The firmware in Jessie was released before the 3B+ even existed. It does not know how to boot it up properly. So you need the latest firmware.
The 3B+ also has different peripherals (USB, Ethernet, Wifi...) so it also needs new kernel drivers that are not present in Jessie.
Jessie is no longer supported.
You are probably much better to address any issues you have with Stretch, rather than trying to get Jessie working on a 3B+.
PINN - NOOBS with the extras... https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=142574

Mathias_Va
Posts: 5
Joined: Fri Sep 28, 2018 3:50 pm

Re: Pi3 B+ cannot boot with jessie

Mon Oct 01, 2018 9:16 am

thanks for your answers, My problem is:

I am trying to cross compile it using Qt, but every time I use stretch I receive this error; however it works only with Jessie



I use this toolchain:
[https://github.com/raspberrypi/tools.git]

and this configure script:

[*/configure -opengl es2 -device linux-rasp-pi3-g++ -device-option CROSS_COMPILE=$RPI_TOOLCHAIN -sysroot $RPI_SYSROOT -opensource -confirm-license -optimized-qmake -reduce-exports -release -make libs -prefix /usr/local/qt5pi]

I got this Error;

[*]Note: Also available for Linux: linux-clang linux-icc

Note: PKG_CONFIG_LIBDIR automatically set to /mnt/rasp-pi-rootfs/usr/lib/pkgconfig:/mnt/rasp-pi-rootfs/usr/share/pkgconfig:/mnt/rasp-pi-rootfs/usr/lib/arm-linux-gnueabihf/pkgconfig

Note: PKG_CONFIG_SYSROOT_DIR automatically set to /mnt/rasp-pi-rootfs

Note: -optimized-tools is not useful in -release mode.

Note: No wayland-egl support detected. Cross-toolkit compatibility disabled.

ERROR: Feature 'opengles2' was enabled, but the pre-condition 'config.win32 || (!config.watchos && !features.opengl-desktop && libs.opengl_es2)' failed.

ERROR: The OpenGL functionality tests failed!
You might need to modify the include and library search paths by editing QMAKE_INCDIR_OPENGL[_ES2],
QMAKE_LIBDIR_OPENGL[_ES2] and QMAKE_LIBS_OPENGL[_ES2] in the mkspec for your platform.

User avatar
procount
Posts: 2035
Joined: Thu Jun 27, 2013 12:32 pm
Location: UK

Re: Pi3 B+ cannot boot with jessie

Tue Oct 02, 2018 12:31 pm

I suggest you change the title of this post, or post your last question as a new post to reflect your real issue. That way you might attract the right kind of audience to answer your real question about compiling with Qt. ;)
PINN - NOOBS with the extras... https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=142574

Return to “Troubleshooting”