Rapata
Posts: 1
Joined: Sun Sep 09, 2018 1:14 pm

Retropie not starting after changing memory split (following a tutorial)

Sun Sep 09, 2018 1:23 pm

Hi, i have been using a dual boot retropie/librelec build and it was doing great. But today i was messing around following this tutorial https://www.youtube.com/watch?v=EvA_Wfa8Bh0 and when i changed the memory split (in the video around minute 6) it prompted to restart, so i did. But at the moment of the reboot it got stuck on black screen with one raspberry and the white bar like i could write but nothing happens, can't write and doesn't move past this point. SD seems to be fine but i don't know what can i do to solve this problem and hope someone could help.

k-pi
Posts: 632
Joined: Sun Feb 12, 2017 1:46 pm
Location: Upper Hale, Surrey, UK.

Re: Retropie not starting after changing memory split (following a tutorial)

Sun Sep 09, 2018 6:25 pm

Can't see/make out what the video is showing, but Menu > Preferences > Raspberry Pi Configuration > Performance > GPU Memory is the way to increase video memory allocation, then reboot to activate it.

(However, when I tried it for VLC, it didn't seem to make any difference.)

User avatar
bensimmo
Posts: 3329
Joined: Sun Dec 28, 2014 3:02 pm
Location: East Yorkshire

Re: Retropie not starting after changing memory split (following a tutorial)

Sun Sep 09, 2018 7:30 pm

Try holding shift down during boot to get into safe mode.
Or
Put the card in something else (e.g. pc) and edit the /boot/confirm.txt file from there .

P.s. I can't read any of the text in that video and no info in the comments.

User avatar
bensimmo
Posts: 3329
Joined: Sun Dec 28, 2014 3:02 pm
Location: East Yorkshire

Re: Retropie not starting after changing memory split (following a tutorial)

Sun Sep 09, 2018 7:46 pm

Ok I read the text in that document (shame that's not in the video info)
You mentioned 1 raspberry on boot.
So you have a Pi1 series (B(+)/A(+)/Zero's) so have 256 or 512MB memory, so you cannot set it to 512MB.

Remove that line from config.txt (~ gpu_mem)

Return to “Gaming”