rickyh89
Posts: 55
Joined: Mon Jun 18, 2018 11:01 pm

[SOLVED] Re: help with bluetooth (hcitool), RPI 3B+

Fri Sep 07, 2018 10:19 pm

so i have a bluetooth sensor i am trying to pair with my PI, i am having trouble doing so though.
I am using 'hcitool'... here is some read outs :

Code: Select all

[email protected]:~ $ dmesg | grep -i bluetooth
[   21.263855] Bluetooth: Core ver 2.22
[   21.263916] Bluetooth: HCI device and connection manager initialized
[   21.263932] Bluetooth: HCI socket layer initialized
[   21.263939] Bluetooth: L2CAP socket layer initialized
[   21.263959] Bluetooth: SCO socket layer initialized
[   21.279626] Bluetooth: HCI UART driver ver 2.3
[   21.279639] Bluetooth: HCI UART protocol H4 registered
[   21.279642] Bluetooth: HCI UART protocol Three-wire (H5) registered
[   21.279804] Bluetooth: HCI UART protocol Broadcom registered
[   21.445064] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   21.445073] Bluetooth: BNEP filters: protocol multicast
[   21.445090] Bluetooth: BNEP socket layer initialized
[   21.495609] Bluetooth: RFCOMM TTY layer initialized
[   21.495639] Bluetooth: RFCOMM socket layer initialized
[   21.495661] Bluetooth: RFCOMM ver 1.11

Code: Select all

[email protected]:~ $ hcitool scan
Device is not available: No such device

[email protected]:~ $ hcitool dev
Devices:

[email protected]:~ $ hciconfig -a
hci0:	Type: Primary  Bus: UART
	BD Address: B8:27:EB:C2:95:A6  ACL MTU: 1021:8  SCO MTU: 64:1
	DOWN 
	RX bytes:668 acl:0 sco:0 events:34 errors:0
	TX bytes:423 acl:0 sco:0 commands:34 errors:0
	Features: 0xbf 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH SNIFF 
	Link mode: SLAVE ACCEPT 

[email protected]:~ $ sudo hciconfig hci0 up
Can't init device hci0: Operation not possible due to RF-kill (132)

[email protected]:~ $ hciconfig hci0 version
Can't read version info hci0: Network is down (100)

[email protected]:~ $ systemctl status hciuart.service
● hciuart.service - Configure Bluetooth Modems connected by UART
   Loaded: loaded (/lib/systemd/system/hciuart.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2018-09-01 17:59:24 UTC; 6 days ago
  Process: 334 ExecStart=/usr/bin/btuart (code=exited, status=0/SUCCESS)
 Main PID: 707 (hciattach)
   CGroup: /system.slice/hciuart.service
           └─707 /usr/bin/hciattach /dev/serial1 bcm43xx 3000000 flow - b8:27:eb:c2:95:a6

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

I do not have experience using bluetooth with RPI before and much of this i got because reading google. however i cannot find what the network is down is or what RF-Kill(132) is... honestly not sure if those have to do with my issue anyways. thanks for taking some time to help out!
Last edited by rickyh89 on Fri Sep 07, 2018 10:29 pm, edited 1 time in total.

rickyh89
Posts: 55
Joined: Mon Jun 18, 2018 11:01 pm

[SOLVED] Re: help with bluetooth (hcitool), RPI 3B+

Fri Sep 07, 2018 10:25 pm

well that was short lived post... incase anyone has issue

https://discourse.osmc.tv/t/enabling-bluetooth/711

this worked perfect.

Code: Select all

[email protected]:~ $ rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
[email protected]:~ $ rfkill unblock all
[email protected]:~ $ rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
[email protected]:~ $ hciconfig hci0 up
Can't init device hci0: Operation not permitted (1)
[email protected]:~ $ sudo hciconfig hci0 up
[email protected]:~ $ hcitool dev
Devices:
	hci0	B8:27:EB:C2:95:A6

Return to “General discussion”