martinrowan
Posts: 44
Joined: Wed Aug 26, 2015 11:00 am
Location: Berkshire, UK
Contact: Website Twitter

Re: PoE HAT - USB Ports not working - over-current

Fri Nov 23, 2018 6:43 pm

I'm not aware of this being exposed on the Pi, however it is likely available via the interface on your PoE switch.

sammaye
Posts: 4
Joined: Sun Sep 23, 2018 6:30 pm

Re: PoE HAT - USB Ports not working - over-current

Mon Nov 26, 2018 2:31 pm

Dos this mean:

a. The issue is fixed?
b. The new boards being distributed?

If yes to (b), are they on amazon.co.uk at all?

martinrowan
Posts: 44
Joined: Wed Aug 26, 2015 11:00 am
Location: Berkshire, UK
Contact: Website Twitter

Re: PoE HAT - USB Ports not working - over-current

Mon Nov 26, 2018 2:44 pm

sammaye wrote:
Mon Nov 26, 2018 2:31 pm
Dos this mean:

a. The issue is fixed?
b. The new boards being distributed?

If yes to (b), are they on amazon.co.uk at all?
a. The issue is fixed as per: https://www.raspberrypi.org/blog/poe-hat-revision/
b. The new boards are in the channel, I can't say if Amazon sellers are selling the new or old boards, in theory they should have returned all the old boards, but there's no guarantee. You might need to contact the seller. The PiHut (UK) are clear on their page that it's the modified version: https://thepihut.com/products/raspberry ... et-poe-hat
I'd expect other major distributors such as RS and Pimoroni to be selling the updated fixed version.
Last edited by martinrowan on Mon Nov 26, 2018 4:15 pm, edited 1 time in total.

pantner
Posts: 12
Joined: Mon Oct 08, 2012 5:47 am

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Mon Nov 26, 2018 2:48 pm

The HAT I received today (which is the new revision) is so far working well.
Definitely better than it did before.

Even my RF Receiver for my wireless keyboard would kill the USB after a couple of seconds of use and it would show constant voltage warnings with the first version.

Nothing like that so far :D

sammaye
Posts: 4
Joined: Sun Sep 23, 2018 6:30 pm

Re: PoE HAT - USB Ports not working - over-current

Mon Nov 26, 2018 3:48 pm

martinrowan wrote:
Mon Nov 26, 2018 2:44 pm
sammaye wrote:
Mon Nov 26, 2018 2:31 pm
Dos this mean:

a. The issue is fixed?
b. The new boards being distributed?

If yes to (b), are they on amazon.co.uk at all?
a. The i1ssue is fixed as per: https://www.raspberrypi.org/blog/poe-hat-revision/
b. The new boards are in the channel, I can't say if Amazon sellers are selling the new or old boards, in theory they should have returned all the old boards, but there's no guarantee. You might need to contact the seller. The PiHut (UK) are clear on their page that it's the modified version: https://thepihut.com/products/raspberry ... et-poe-hat
I'd expect other major distributors such as RS and Pimoroni to be selling the updated fixed version.
I should have checked that first, right up at he top it says in bold they are the new ones with the new filter hah, thanks

douglas5962
Posts: 21
Joined: Thu Mar 29, 2018 2:22 pm

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Mon Nov 26, 2018 6:23 pm

Has anyone been able to purchase the modified POE Hats in the US? Newark has pulled them off there website again for some reason.

raymate
Posts: 63
Joined: Sat Sep 28, 2013 3:56 pm
Location: Canada / UK
Contact: Website

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Tue Nov 27, 2018 12:04 am

Don't help you but I got mine, in Canada, from BuyaPi

So some have made it across the pond, they did tell me the revised is very limited stock when I got mine.
douglas5962 wrote:
Mon Nov 26, 2018 6:23 pm
Has anyone been able to purchase the modified POE Hats in the US? Newark has pulled them off there website again for some reason.
__________________________________
Pi model B / Pi 2 / Pi 3 / Pi Zero W

douglas5962
Posts: 21
Joined: Thu Mar 29, 2018 2:22 pm

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Tue Nov 27, 2018 5:01 pm

Excuse me, I need to go start smuggling POE HATs across the Canadian border...

The_Raven
Posts: 23
Joined: Mon Sep 03, 2018 9:56 am
Location: Switzerland

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Fri Nov 30, 2018 9:08 am

Nice Job, the modded PoE-Hat works great! 8-)
Is it possible to buy/get the mod (daughter) board?

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 21120
Joined: Sat Jul 30, 2011 7:41 pm

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Fri Nov 30, 2018 9:47 am

The_Raven wrote:
Fri Nov 30, 2018 9:08 am
Nice Job, the modded PoE-Hat works great! 8-)
Is it possible to buy/get the mod (daughter) board?
I don't believe so. Best to return the original board for a replacement.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

The_Raven
Posts: 23
Joined: Mon Sep 03, 2018 9:56 am
Location: Switzerland

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Fri Nov 30, 2018 1:53 pm

Ok thx, problem solved. Self-Repaired ;)

DaPeace
Posts: 3
Joined: Tue Sep 18, 2018 7:41 am

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Mon Dec 03, 2018 6:44 am

Ive ordered the new revision of this board after i had problems with the ir-tsop with the old revision.
I want to use a rpi3b+ with poe-hat and ir-tsop as a sat-ip-receiver.
Unfortunately this is not working with the new revision as well.
Every time when the fan starts, it seems to induct some spikes into the 5v-line and the remote/ir-diode stops working.
It seems that the ir-tsop is a little sensitive to those spikes. When the fan stops, the remote starts working again.
Another problem is, that the poe-hat seems to heat up the rpi so the fan is really necessary. Ive tried without the fan an the rpi heated up and showed the thermometer-icon in the top right corner.
The tsop is connected to 5V, Ground and GPIO18.

Any hint how to solve that?

drgeoff
Posts: 8862
Joined: Wed Jan 25, 2012 6:39 pm

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Mon Dec 03, 2018 10:48 am

DaPeace wrote:
Mon Dec 03, 2018 6:44 am
Ive ordered the new revision of this board after i had problems with the ir-tsop with the old revision.
I want to use a rpi3b+ with poe-hat and ir-tsop as a sat-ip-receiver.
Unfortunately this is not working with the new revision as well.
Every time when the fan starts, it seems to induct some spikes into the 5v-line and the remote/ir-diode stops working.
It seems that the ir-tsop is a little sensitive to those spikes. When the fan stops, the remote starts working again.
Another problem is, that the poe-hat seems to heat up the rpi so the fan is really necessary. Ive tried without the fan an the rpi heated up and showed the thermometer-icon in the top right corner.
The tsop is connected to 5V, Ground and GPIO18.

Any hint how to solve that?
First thing I would try is a 100 ohm resistor between 5 vols and TSOP and a 10uF capacitor from junction of resistor and TSOP to ground.

The_Raven
Posts: 23
Joined: Mon Sep 03, 2018 9:56 am
Location: Switzerland

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Mon Dec 03, 2018 2:58 pm

Edit:
Deleted. Never write things before testing! :roll:

DjoeC
Posts: 9
Joined: Tue Dec 23, 2014 8:47 pm

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Fri Dec 07, 2018 10:46 am

I've got mine with Black Friday discount. It's running nicely with 2TB HDD & RTL-SDR stick so power budget appears to be good. Happy user - thanks!

BennyE
Posts: 3
Joined: Sun Sep 16, 2018 11:30 am

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Sat Dec 15, 2018 9:54 am

I received my revised PoE HAT last week and am very happy with the result, it works flawless now! No more messages in the "dmesg" and the system is stable when powered via my ALE OmniSwitch 6450-P10.

Code: Select all

OS6450-P10-> show system 
System:
  Description:  Alcatel-Lucent Enterprise OS6450-P10 6.7.2.191.R04 GA, June 20, 2018.,
  Object ID:    1.3.6.1.4.1.6486.800.1.1.2.1.12.1.2,
  Up Time:      143 days 22 hours 35 minutes and 38 seconds,
  Contact:      Benny,
  Name:         OS6450-P10,
  Location:     Benny's Lab,
  Services:     72,
  Date & Time:  SAT DEC 15 2018  10:50:23 (CET)

Flash Space:
    Primary CMM:
      Available (bytes):  54493184,
      Comments         :  None

OS6450-P10-> show lanpower 1
Port Maximum(mW) Actual Used(mW)   Status    Priority   On/Off    Class
----+-----------+---------------+-----------+---------+--------+-------
  1     31000         6700       Powered On     Low      ON        4
  2     31000         3200       Powered On     Low      ON        3 <--- PoE Pi :)
  3     31000            0       Powered Off    Low      OFF       -
  4     31000            0       Powered Off    Low      OFF       -
  5     31000         5200       Powered On     Low      ON        4
  6     31000            0       Powered Off    Low      OFF       -
  7     31000         3500       Powered On     Low      ON        3
  8     31000            0       Powered Off    Low      ON        -

Slot 1 Max Watts 120
18.6 Watts Actual Power Consumed
101.4 Watts Actual Power Remaining
120 Watts Total Power Budget Available
1 Power Supplies Available

OS6450-P10-> 

The_Raven
Posts: 23
Joined: Mon Sep 03, 2018 9:56 am
Location: Switzerland

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Fri Jan 04, 2019 3:44 pm

I have now 3 PI's with PoE HAT's and 2 cameras each (total 6 cameras). And all of them have sporadically flickering picture.
So yes it works, no errors in log, but something still disturbs the USB.
ATM i have no motivation to spend more time in it.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 21120
Joined: Sat Jul 30, 2011 7:41 pm

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Fri Jan 04, 2019 4:33 pm

The_Raven wrote:
Fri Jan 04, 2019 3:44 pm
I have now 3 PI's with PoE HAT's and 2 cameras each (total 6 cameras). And all of them have sporadically flickering picture.
So yes it works, no errors in log, but something still disturbs the USB.
ATM i have no motivation to spend more time in it.
So presumably USB cameras. If you power via a normally attached PS, does the flickering still happen, or is it specifically down to the PoE power arrangement? Multiple USB camera have been reported as sometimes being erratic (a consequence of the HW USB implementation on the SoC itself), so would be interesting to show if it is the PoE or not.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

The_Raven
Posts: 23
Joined: Mon Sep 03, 2018 9:56 am
Location: Switzerland

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Sun Jan 06, 2019 12:10 pm

It semes to be a PoE HAT problem. With a "stable" power (original pi power supply) this does not happen.
I know that the hub can be a problem. With the pi 3 the cameras are not working stable, but with the 3+ it works.
The problem is that this are no mjpeg cameras, which means a lot of data trough the usb. :roll:
I think the problem is the (little) noise on the usb generated from the HAT. I will try more testing and filtering when time is available.

Edit:
What does the attached error message mean? Power-Problem?
This happens on one Pi about once a week.
After a reboot, everything is fine.
Attachments
Error.zip
(2.36 KiB) Downloaded 6 times

Return to “HATs and other add-ons”