Posts: 18
Joined: Fri Jul 20, 2018 9:49 pm

Tor won't create hidden service directories or make .onion address

Fri Jul 20, 2018 10:55 pm

Hello forum

I'm trying to create a Tor hidden services server on my Raspberry Pi model B1, following this tutorial: ... i-and-tor/. I have successfully completed every step in the pre-Tor setup at the beginning of the tutorial.

On the Tor tutorial, once you have edited Tor's torrc.conf file to configure the file paths and ip addresses like this

Code: Select all

HiddenServiceDir /var/lib/tor/hidden_service/
HiddenServicePort 80
you run

Code: Select all

sudo service tor restart
and Tor is supposed to create the directory and hostname in "/var/lib/tor/hidden_service/" which is owned by group created by Tor called "Debian-tor".

When I get to this point and have restarted tor, I run

Code: Select all

sudo cat /var/lib/tor/hidden_service/hostname
which is supposed to show you your newly created .onion address, but when I run it, I get the error message

Code: Select all

cat: /var/lib/tor/hidden_service/hostname: No such file or directory
I checked the contents of /tor/ as root and the folder and files had not been created. I've tried changing the pathname to a folder I own in my home directory, but the result is always the same, nothing gets created.

I have previously managed to complete the whole tutorial and had my .onion website up and running, viewable from the Tor browser. The only difference is that I did it on a Raspberry Pi model B 3.

So I took the working micro SD card out of the B 3 and put it in the B1, edited the torrc.conf to create a new hidden service folder to see what it would do. To my surprise, it created the folder and gave me a host name BUT the site never became available online although Lighttpd server and Tor were both running.

On my B 3, it would take a few minutes after boot for my website to be available but it just doesn't appear when I put it in my B1.

I have literally no idea as to what is causing this. Do you think the older hardware doesn't support something necessary for the service to run?

Any suggestions would be greatly appreciated!


Return to “Troubleshooting”