Rygar
Posts: 5
Joined: Fri Jul 13, 2018 11:07 pm

Raspberry Pi 3 B+ Openvpn cant connect via external IP address

Fri Jul 13, 2018 11:13 pm

Hi, I just got a Raspberry Pi 3 B+ (I also own a Pi 3) and I am having problems connecting to it using OpenVPN from an external IP address.

I'm not to well up on how to configure it but I used the installer from https://install.pivpn.io.

Swapping hardware over to the old Raspberry Pi 3 everything works fine, even from External IP address, the problem is the NEW PI 3 B+.

When I switch over to the new Pi 3 B+ it doesn't connect, so I edited the .ovpn file to connect to it via LOCAL IP address and it works fine.

Something is blocking the connection in the new Pi 3 B+ setup via external IP, anyone one know what it could be ?

rohtua
Posts: 39
Joined: Sat Jul 16, 2016 9:01 am

Re: Raspberry Pi 3 B+ Openvpn cant connect via external IP address

Sat Jul 14, 2018 7:26 am

Is the new pi using the same IP address as the old pi??? If it's using a different IP then whatever port forwarding was setup so you could access the old pi externally won't apply to the new one and you won't connect.

Rygar
Posts: 5
Joined: Fri Jul 13, 2018 11:07 pm

Re: Raspberry Pi 3 B+ Openvpn cant connect via external IP address

Sat Jul 14, 2018 11:27 am

NO I added a new port forwarding rule for the new PI.

rohtua
Posts: 39
Joined: Sat Jul 16, 2016 9:01 am

Re: Raspberry Pi 3 B+ Openvpn cant connect via external IP address

Sat Jul 14, 2018 11:37 am

OK. When you say your swapping hardware are you just swapping the sd from one pi to the other?

Have you configured static IPs on the pi's? And are they both connecting in the same way both Ethernet or both Wi-Fi?

Does anything appear in the logs on the pi when you try to connect and what errors it giving you on the client when it true to connect?

Rygar
Posts: 5
Joined: Fri Jul 13, 2018 11:07 pm

Re: Raspberry Pi 3 B+ Openvpn cant connect via external IP address

Sat Jul 14, 2018 12:48 pm

I solved it.

Yes you were right it was a conflict between the ports and was forwarding the 1194 port to the OLD Pi which was why it worked on it.

I changed the port number (gave it a new one) in the files:

Code: Select all

	/etc/openvpn/server.conf 
	/etc/openvpn/easy-rsa/pki/Default.txt
   	pi3plus.ovpn 
forwarded the new port to the new Pi and it worked.


Return to “Troubleshooting”

Who is online

Users browsing this forum: DougieLawson, PhatFil and 61 guests