_ThaNerd_
Posts: 30
Joined: Tue May 09, 2017 3:20 pm

Re: Multiple Frame buffer beta testers wanted

Mon Jan 14, 2019 1:42 pm

OK so reinstalled latest raspbian full on my pi, went through your original post and got everything working but once again only one screen at a time depending what I set it in my 99-fbturbo.conf

Code: Select all

Option          "fbdev" "/dev/fb0" 
This displays my pi desktop on my HDMI 7" screen and makes my 7" DSI original raspberry screen black

Code: Select all

 Option          "fbdev" "/dev/fb1"
This displays my pi desktop on my 7" DSI original raspberry screen and makes my pi desktop on my HDMI 7" screen black

OK by doing the following I got it to work:

config.txt

Code: Select all

hdmi_force_hotplug=1
hdmi_ignore_edid=0xa5000080
config_hdmi_boost=4
hdmi_group=2
hdmi_mode=x
99-fbturbo.conf

Code: Select all

Section "Device"
        Identifier      "Allwinner A10/A13 FBDEV"
        Driver          "fbturbo"
        Option          "fbdev" "/dev/fb0"
        Option          "SwapbuffersWait" "true"
EndSection

Section "Device"
        Identifier      "FBDEV 1"
        Driver          "fbturbo"
        Option          "fbdev" "/dev/fb1"
EndSection

Section "Screen"
        Identifier      "VGA"
        Device          "Allwinner A10/A13 FBDEV"
        Monitor         "Monitor name 0"
EndSection

Section "Screen"
        Identifier      "HDMI"
        Device          "FBDEV 1"
        Monitor         "Monitor name 1"
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          0 "VGA"
        Screen          1 "HDMI" RightOf "VGA" ##the configuration of VGA(primary) to HDMI (Secondary)
EndSection

_ThaNerd_
Posts: 30
Joined: Tue May 09, 2017 3:20 pm

Re: Multiple Frame buffer beta testers wanted

Mon Jan 14, 2019 2:19 pm

OK so now the issue is I can't move windows between screens (for instance I can only open chromium on my main screen which is the HDMI but I can't drag it or open it on my DSI).

I had a resolution issue on my HDMI but it has been solved by editing the config.txt with:

Code: Select all

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1
 
# uncomment to force a specific HDMI mode (here we are forcing 800x480!)
hdmi_group=2
hdmi_mode=87
hdmi_cvt=800 480 60 6 0 0 0
hdmi_drive=1
 
max_usb_current=1

_ThaNerd_
Posts: 30
Joined: Tue May 09, 2017 3:20 pm

Re: Multiple Frame buffer beta testers wanted

Mon Jan 14, 2019 2:41 pm

I used this version of start_x.elf (in the quote below) and now when I click on my opened window I get an option "All Desktops" under Send to Desktop but it does nothing, I can't move anything to my DSI...
jamesh wrote:
Thu Aug 02, 2018 9:04 am
ONLY FOR PEOPLE USING A DSI AND A DPI SCREEN AT SAME TIME
(Although it should work under all circumstances, so try if you want)

OK, here is a link to a start_x.elf that I hope will fix the DPI/DSI coexistence issue. However, I am not entirely sure whether the HW will be able to cope, so use at peril.

https://drive.google.com/open?id=15_fwv ... 3k9OlmtIcL

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 21127
Joined: Sat Jul 30, 2011 7:41 pm

Re: Multiple Frame buffer beta testers wanted

Mon Jan 14, 2019 3:34 pm

I'm not an expert on X and multidesktops, so anything you find out you can post here!
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

_ThaNerd_
Posts: 30
Joined: Tue May 09, 2017 3:20 pm

Re: Multiple Frame buffer beta testers wanted

Mon Jan 14, 2019 3:56 pm

Tried this twice now and both times after

5) copy files from here viewtopic.php?f=63&t=216399&start=200#p1381436 (latest at the time of writing the post) to uSD
6) reboot

My mouse, bluetooth and wifi stop working
aBUGSworstnightmare wrote:
Thu Oct 18, 2018 5:28 am
wilsonb wrote:
Wed Oct 17, 2018 6:10 pm
Im using RetroPie and using the new Pimiero HyperPixel 4.0 https://shop.pimoroni.com/products/hype ... 9485443155
and after replacing files with HDMI plugged in, LCD looks good but HDMI is blank no rainbow.
Hi, as this is beta testing you should use Raspbian OS for testing with. Other versions (i.e. OSMC, Retropie, ..) might cause unknown issues as they - quite often. - use their own kernel.

Here is a brief guideline how to start (hope I didn't missed a point/mixed up the order):
1) prepare a fresh uSD, boot and configure (initial setting for WiFi,Keyboard, etc) using HDMI display only
2) add 'start_x=1' to config.txt
3) replace the /usr/share/X11/xorg.conf.d/99-fbturbo.conf contents with the contents below

Code: Select all

# This is a minimal sample config file, which can be copied to
# /etc/X11/xorg.conf in order to make the Xorg server pick up
# and load xf86-video-fbturbo driver installed in the system.
# When troubleshooting, check /var/log/Xorg.0.log for the debugging
# output and error messages.
#
# Run "man fbturbo" to get additional information about the extra
# configuration options for tuning the driver.

#Section "Device"
#        Identifier      "Allwinner A10/A13 FBDEV"
#        Driver          "fbturbo"
#        Option          "fbdev" "/dev/fb1"
#        Option          "SwapbuffersWait" "true"
#EndSection


Section "Device"
        Identifier      "fbturbo0"
        Driver          "fbturbo"
        Option          "fbdev" "/dev/fb0"

        Option          "SwapbuffersWait" "true"
        Option          "debug" "true"
EndSection

Section "Device"
        Identifier      "fbturbo1"
        Driver          "fbturbo"
        Option          "fbdev" "/dev/fb1"

        Option          "SwapbuffersWait" "true"
        Option          "debug" "true"
EndSection

Section "Device"
        Identifier      "fbdev0"
        Driver          "fbdev"
        Option          "fbdev" "/dev/fb0"
EndSection

Section "Device"
        Identifier      "fbdev1"
        Driver          "fbdev"
        Option          "fbdev" "/dev/fb1"
EndSection

Section "Monitor"
    Identifier "Monitor0"
    Option "Primary" "False"
EndSection

Section "Monitor"
    Identifier "Monitor1"
    Option "RightOf" "Monitor0"
    Option "Primary" "False"
EndSection

Section "Screen"
    Identifier "ScreenTurbo0"
    Monitor "Monitor0"
    Device "fbturbo0"
    Subsection "Display"
    EndSubSection
EndSection

Section "Screen"
    Identifier "ScreenTurbo1"
    Monitor "Monitor1"
    Device "fbturbo1"
    Subsection "Display"
    EndSubSection
EndSection

Section "Screen"
    Identifier "ScreenDev0"
    Monitor "Monitor0"
    Device "fbdev0"
    Subsection "Display"
    EndSubSection
EndSection

Section "Screen"
    Identifier "ScreenDev1"
    Monitor "Monitor1"
    Device "fbdev1"
    Subsection "Display"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier "Multihead"
    Screen  0 "ScreenTurbo0"
    Screen  1 "ScreenTurbo1" rightof "ScreenTurbo0"
    Option  "Xinerama" "true"
EndSection

Section "ServerLayout"
    Identifier "Singlehead0"
    Screen  0 "ScreenTurbo0"
EndSection

Section "ServerLayout"
    Identifier "Singlehead1"
    Screen  0 "ScreenTurbo1"
EndSection

Section "ServerFlags"
    Option "BlankTime"  "0"
    Option "StandbyTime"  "0"
    Option "SuspendTime"  "0"
    Option "OffTime"  "0"
    Option "DefaultServerLayout" "Singlehead0"
EndSection
4) reboot
5) copy files from here viewtopic.php?f=63&t=216399&start=200#p1381436 (latest at the time of writing the post) to uSD
6) reboot
7) use raspi-config and select to boot to CLI
8) reboot
9) at command line: start desktop with

Code: Select all

startx -- -layout Multihead
10) check if frame buffer is created

Code: Select all

ls /dev/fb*
11) enable and configure your second display, reboot, check if frame buffers are generated (same command as above). If everything went well you should have two displays running now. For changing desktop priority read here viewtopic.php?f=63&t=216399&start=175#p1364127

NOTE: As the HYPERPIXEL display is using DPI interface you cannot use it together with the official 7in display (because DPI and DSI can't be used together)!

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 21127
Joined: Sat Jul 30, 2011 7:41 pm

Re: Multiple Frame buffer beta testers wanted

Mon Jan 14, 2019 5:08 pm

_ThaNerd_ wrote:
Mon Jan 14, 2019 3:56 pm
Tried this twice now and both times after

5) copy files from here viewtopic.php?f=63&t=216399&start=200#p1381436 (latest at the time of writing the post) to uSD
6) reboot

My mouse, bluetooth and wifi stop working
aBUGSworstnightmare wrote:
Thu Oct 18, 2018 5:28 am
wilsonb wrote:
Wed Oct 17, 2018 6:10 pm
Im using RetroPie and using the new Pimiero HyperPixel 4.0 https://shop.pimoroni.com/products/hype ... 9485443155
and after replacing files with HDMI plugged in, LCD looks good but HDMI is blank no rainbow.
Hi, as this is beta testing you should use Raspbian OS for testing with. Other versions (i.e. OSMC, Retropie, ..) might cause unknown issues as they - quite often. - use their own kernel.

Here is a brief guideline how to start (hope I didn't missed a point/mixed up the order):
1) prepare a fresh uSD, boot and configure (initial setting for WiFi,Keyboard, etc) using HDMI display only
2) add 'start_x=1' to config.txt
3) replace the /usr/share/X11/xorg.conf.d/99-fbturbo.conf contents with the contents below

Code: Select all

# This is a minimal sample config file, which can be copied to
# /etc/X11/xorg.conf in order to make the Xorg server pick up
# and load xf86-video-fbturbo driver installed in the system.
# When troubleshooting, check /var/log/Xorg.0.log for the debugging
# output and error messages.
#
# Run "man fbturbo" to get additional information about the extra
# configuration options for tuning the driver.

#Section "Device"
#        Identifier      "Allwinner A10/A13 FBDEV"
#        Driver          "fbturbo"
#        Option          "fbdev" "/dev/fb1"
#        Option          "SwapbuffersWait" "true"
#EndSection


Section "Device"
        Identifier      "fbturbo0"
        Driver          "fbturbo"
        Option          "fbdev" "/dev/fb0"

        Option          "SwapbuffersWait" "true"
        Option          "debug" "true"
EndSection

Section "Device"
        Identifier      "fbturbo1"
        Driver          "fbturbo"
        Option          "fbdev" "/dev/fb1"

        Option          "SwapbuffersWait" "true"
        Option          "debug" "true"
EndSection

Section "Device"
        Identifier      "fbdev0"
        Driver          "fbdev"
        Option          "fbdev" "/dev/fb0"
EndSection

Section "Device"
        Identifier      "fbdev1"
        Driver          "fbdev"
        Option          "fbdev" "/dev/fb1"
EndSection

Section "Monitor"
    Identifier "Monitor0"
    Option "Primary" "False"
EndSection

Section "Monitor"
    Identifier "Monitor1"
    Option "RightOf" "Monitor0"
    Option "Primary" "False"
EndSection

Section "Screen"
    Identifier "ScreenTurbo0"
    Monitor "Monitor0"
    Device "fbturbo0"
    Subsection "Display"
    EndSubSection
EndSection

Section "Screen"
    Identifier "ScreenTurbo1"
    Monitor "Monitor1"
    Device "fbturbo1"
    Subsection "Display"
    EndSubSection
EndSection

Section "Screen"
    Identifier "ScreenDev0"
    Monitor "Monitor0"
    Device "fbdev0"
    Subsection "Display"
    EndSubSection
EndSection

Section "Screen"
    Identifier "ScreenDev1"
    Monitor "Monitor1"
    Device "fbdev1"
    Subsection "Display"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier "Multihead"
    Screen  0 "ScreenTurbo0"
    Screen  1 "ScreenTurbo1" rightof "ScreenTurbo0"
    Option  "Xinerama" "true"
EndSection

Section "ServerLayout"
    Identifier "Singlehead0"
    Screen  0 "ScreenTurbo0"
EndSection

Section "ServerLayout"
    Identifier "Singlehead1"
    Screen  0 "ScreenTurbo1"
EndSection

Section "ServerFlags"
    Option "BlankTime"  "0"
    Option "StandbyTime"  "0"
    Option "SuspendTime"  "0"
    Option "OffTime"  "0"
    Option "DefaultServerLayout" "Singlehead0"
EndSection
4) reboot
5) copy files from here viewtopic.php?f=63&t=216399&start=200#p1381436 (latest at the time of writing the post) to uSD
6) reboot
7) use raspi-config and select to boot to CLI
8) reboot
9) at command line: start desktop with

Code: Select all

startx -- -layout Multihead
10) check if frame buffer is created

Code: Select all

ls /dev/fb*
11) enable and configure your second display, reboot, check if frame buffers are generated (same command as above). If everything went well you should have two displays running now. For changing desktop priority read here viewtopic.php?f=63&t=216399&start=175#p1364127

NOTE: As the HYPERPIXEL display is using DPI interface you cannot use it together with the official 7in display (because DPI and DSI can't be used together)!
That's because the version of the modules doesn't match the kernel version. You need to ensure that you use the corrrect kernel
version to match the modules. I think all the numbers and how to do that are above.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

_ThaNerd_
Posts: 30
Joined: Tue May 09, 2017 3:20 pm

Re: Multiple Frame buffer beta testers wanted

Mon Jan 14, 2019 5:58 pm

So when I do this

Code: Select all

sudo rpi-update fe525d2
with the latest raspbian is that ok or should I use a diff update link?

_ThaNerd_
Posts: 30
Joined: Tue May 09, 2017 3:20 pm

Re: Multiple Frame buffer beta testers wanted

Mon Jan 14, 2019 7:22 pm

OK managed to get it to work, now I am trying to figure out how to configure my touchpad, it seems to think that the whole area (both of my screens are touch) is touch and so when I press on my touchscreen the mouse is like 1 inch to the left and 1 inch lower...

Edit: I can't seem to make it calibrate the x axis (always an inch to the left). But the y axis seems ok (at same height as where I touch the screen).

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 21127
Joined: Sat Jul 30, 2011 7:41 pm

Re: Multiple Frame buffer beta testers wanted

Mon Jan 14, 2019 9:57 pm

Double touch screens I didn't look at, so cannot help with that.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

Return to “General discussion”