Tweekzor
Posts: 2
Joined: Sat May 19, 2018 9:44 am

Incorrect package for git

Thu Jun 14, 2018 7:25 pm

Hi,

I installed a new Raspbian stretch image today and wanted to install git on it. I started with an apt update and upgrade which went fine. Installing git however produced the following error:

Code: Select all

[email protected]:~ $ sudo apt install git -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  git-man liberror-perl
Suggested packages:
  git-daemon-run | git-daemon-sysvinit git-doc git-el git-email git-gui gitk gitweb git-arch git-cvs git-mediawiki git-svn
The following NEW packages will be installed:
  git git-man liberror-perl
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 4,812 kB/4,839 kB of archives.
After this operation, 26.3 MB of additional disk space will be used.
Err:1 http://raspbian.raspberrypi.org/raspbian stretch/main armhf git-man all 1:2.11.0-3+deb9u2
  404  Not Found [IP: 93.93.128.193 80]
Err:2 http://raspbian.raspberrypi.org/raspbian stretch/main armhf git armhf 1:2.11.0-3+deb9u2
  404  Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/g/git/git-man_2.11.0-3+deb9u2_all.deb  404  Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/g/git/git_2.11.0-3+deb9u2_armhf.deb  404  Not Found [IP: 93.93.128.193 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
When checking the repository the listed packages were not available, only deb9u3 is available online resulting in the error:
[ ] git-man_2.11.0-3+deb9u3_all.deb 27-May-2018 19:16 1.4M Details
[ ] git_2.11.0-3+deb9u3_armhf.deb 30-May-2018 00:04 3.2M Details

apt update or apt update --fix-missing couldn't change anything, the policy would remain on deb9u2. I had to download and installed deb9u3 manually.

Code: Select all

[email protected]:~ $ apt-cache policy git
git:
  Installed: 1:2.11.0-3+deb9u3
  Candidate: 1:2.11.0-3+deb9u3
  Version table:
 *** 1:2.11.0-3+deb9u3 100
        100 /var/lib/dpkg/status
     1:2.11.0-3+deb9u2 500
        500 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages
I didn't find anywhere I could report this error so hopefully someone can pick it up here.

plugwash
Forum Moderator
Forum Moderator
Posts: 3287
Joined: Wed Dec 28, 2011 11:45 pm

Re: Incorrect package for git

Sat Jun 16, 2018 7:35 am

Looks fine from here now, is the problem still persisting for you?

Tweekzor
Posts: 2
Joined: Sat May 19, 2018 9:44 am

Re: Incorrect package for git

Sat Jun 16, 2018 4:42 pm

Seems fine now, apt-cache policy returns deb9u3 for the repo as well now. Some difference I notice with apt update from earlier this week

Code: Select all

[email protected]:~ $ sudo apt-get update
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Reading package lists... Done
and from today

Code: Select all

[email protected]:~ $ sudo apt update
Get:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Get:2 http://archive.raspberrypi.org/debian stretch InRelease [25.3 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11.7 MB]
Get:4 http://archive.raspberrypi.org/debian stretch/ui armhf Packages [32.9 kB]
Fetched 11.7 MB in 10s (1,083 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
That might explain the problem, there were 2 repo's missing in the update.

tempest766
Posts: 34
Joined: Sun Jan 07, 2018 3:44 pm

Re: Incorrect package for git

Thu Jan 17, 2019 7:24 am

This problem has reared its head again. Loaded raspian lite to manually install only the packages I need and the samba packages are not updated in the apt catalog, deb9u4 exists on the servers, but the update wants 9u3 versions. the raspian lite image was the latest on the site (november 2018)

apt-get update uploads nothing
Do you want to continue? [Y/n] y
Err:1 http://raspbian.raspberrypi.org/raspbian stretch/main armhf samba-libs armhf 2:4.5.12+dfsg-2+deb9u3
404 Not Found [IP: 93.93.128.193 80]
Err:2 http://raspbian.raspberrypi.org/raspbian stretch/main armhf libsmbclient armhf 2:4.5.12+dfsg-2+deb9u3
404 Not Found [IP: 93.93.128.193 80]
Unable to correct missing packages.
E: Failed to fetch http://raspbian.raspberrypi.org/raspbia ... _armhf.deb 404 Not Found [IP: 93.93.128
.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbia ... _armhf.deb 404 Not Found [IP: 93.93.1
28.193 80]
E: Aborting install.


tempest766
Posts: 34
Joined: Sun Jan 07, 2018 3:44 pm

Re: Incorrect package for git

Thu Jan 17, 2019 8:59 pm

mysteriously works now. published package catalog was not in sync with available packages from the repo. seems fixed for now.

Return to “Raspbian”