scottietrek
Posts: 1
Joined: Thu Jun 14, 2018 5:51 pm

Mapping Network Drive (NAS)

Thu Jun 14, 2018 5:56 pm

I have a nas drive i can see it in the network options and have full access to it using the file explorer. But when i try to use
sudo munt -t cifs -o username=<Uname>,password=<pwd> //192.168.0.xxx/Share /mnt/mylocalfold

this gives me an error invalid argument.

User avatar
bob_binz
Posts: 435
Joined: Thu Feb 02, 2012 7:58 pm
Location: Stockport, UK

Re: Mapping Network Drive (NAS)

Thu Jun 14, 2018 8:23 pm

Which operating system are you using?

Try adding vers=1.0 to the options list, e.g.

Code: Select all

sudo mount -t cifs -o username=<Uname>,password=<pwd>,vers=1.0 //192.168.0.xxx/Share /mnt/mylocalfold
--
BBz

User avatar
thagrol
Posts: 655
Joined: Fri Jan 13, 2012 4:41 pm
Location: Darkest Somerset, UK
Contact: Website

Re: Mapping Network Drive (NAS)

Fri Jun 15, 2018 7:09 pm

bob_binz wrote:
Thu Jun 14, 2018 8:23 pm
Which operating system are you using?

Try adding vers=1.0 to the options list, e.g.

Code: Select all

sudo mount -t cifs -o username=<Uname>,password=<pwd>,vers=1.0 //192.168.0.xxx/Share /mnt/mylocalfold
--
BBz
Doubt that'll make any difference. Try replaceing "username= with "user="

See

Code: Select all

man mount.cifs
Note to self: don't feed the trolls

Roken
Posts: 152
Joined: Sun Dec 31, 2017 4:35 pm

Re: Mapping Network Drive (NAS)

Fri Jun 15, 2018 8:34 pm

I second thagrol's suggestion. I don't use cifs anymore (I find nfs much easier), but when I did (I was forced to at the time by the server hardware) I used user=.
Headless PI. OMG, someone cut it's head off. Oh, hang on. it didn't have one to start with.

Return to “Advanced users”

Who is online

Users browsing this forum: No registered users and 8 guests