mtylerb
Posts: 7
Joined: Sat Apr 07, 2018 3:14 am
Location: Warburg, AB, Canada

Razberry V2 on Raspbian Stretch

Thu Jun 07, 2018 6:18 am

I'm having issues getting the Razberry v2 to work with Raspbian Stretch. I have a Ras Pi 3 B+ running on stock Raspbian Image that came on the USB. I have also installed Docker which has a copy of Hass.io running in a container. All was working well except that Z-Way (Razberry v2 server) doesn't appear to be running. Has anyone gotten the Razberry v2 Z-Wave hub daughter board to work with their Pi 3 B+? I noticed in the install directions they are expecting Raspbian Jessie, which obviously no longer comes with the Pi. There's a few things I've noticed while installing and from Googling the problem:

Code: Select all

cp: cannot stat '/opt/z-way-server_2018-06-06-13-14-22/config/Configuration.xml': No such file or directory
...
ls: cannot access 'config/zddx/*.xml': No such file or directory
Usage: ./z-cfg-update <filename>
diff: /etc/inittab: No such file or directory
diff: /tmp/zway_install_inittab: No such file or directory
Shows up while installing.

Code: Select all

[email protected]:~ $ sudo service z-way-server status
● z-way-server.service - LSB: RaZberry Z-Wave service
  Loaded: loaded (/etc/init.d/z-way-server; generated; vendor preset: enabled)
  Active: active (exited) since Wed 2018-06-06 12:55:22 MDT; 44s ago
    Docs: man:systemd-sysv-generator(8)
 Process: 2686 ExecStop=/etc/init.d/z-way-server stop (code=exited, status=0/SU
 Process: 2690 ExecStart=/etc/init.d/z-way-server start (code=exited, status=0/
     CPU: 19ms

Jun 06 12:55:22 pihouse systemd[1]: Starting LSB: RaZberry Z-Wave service...
Jun 06 12:55:22 pihouse z-way-server[2690]: Starting z-way-server: done.
Jun 06 12:55:22 pihouse systemd[1]: Started LSB: RaZberry Z-Wave service.
Not entirely sure if this is supposed to show (exited), but it does. There's very little in the journalctl, just shows the process stopping and starting. I had a bit of an undervoltage issue, but that was solved by changing the power supply/USB cord.

Going to my http://[ip address]:8083 and http://[ip address]:8084 bring up nothing. find.z-wave.me brings up the appropriate cloud service with the appropriate ip address listed below the login boxes. Typing the number and password listed in the install just brings up an "An error has occured during connection to your Z-Way". I'm no Linux expert, so I could use a bit of help.

mtylerb
Posts: 7
Joined: Sat Apr 07, 2018 3:14 am
Location: Warburg, AB, Canada

Re: Razberry V2 on Raspbian Stretch

Thu Jun 07, 2018 6:33 am

Well, answered my own question after having a eureka "search idea" moment. I found a github issue with a specific response that seems to have solve the problem. So for others:

Code: Select all

$ cd \tmp
$ wget http://mirrordirector.raspbian.org/raspbian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u8_armhf.deb
$ sudo dpkg -x libssl1.0.0_1.0.1t-1+deb8u8_armhf.deb .
$ sudo mv usr/lib/arm-linux-gnueabihf/lib* /opt/z-way-server/libs/
Please keep in mind that the filename had changed from the original response in the github issue. I had to traverse the URL directories to discover that libssl1.0.0_1.0.1t-1+deb8u7_armhf.deb had become libssl1.0.0_1.0.1t-1+deb8u8_armhf.deb. So if you get a 404 error with the wget command, you may need to do something similar. The problem occurs due to the change in libssl from 1.0.0 to 1.0.2, so you're looking specifically for libssl1.0.0.

With that in, my problem seems to be solved for the moment. They're planning on updating to stretch, but they seem to be on the slower side. At least it runs.

Return to “Raspbian”