Kaplas
Posts: 4
Joined: Mon Oct 29, 2012 7:37 pm
Location: Spain

HDMI output 720p only

Mon Oct 29, 2012 8:07 pm

Hi all!

I have my Raspberry Pi configured as a media player and it has worked very well (1080p and 5.1 audio) until yesterday, when it started to output only 720p video and stereo audio over HDMI.

If I use hdmi_drive=2 and hdmi_force_edid_audio=1 I have 5.1 audio, but I have no luck with video.
I've tried using hdmi_safe=1 or hdmi_group=1 and hdmi_mode=16, but the output is always 720p. I've tried also several values for config_hdmi_boost.

When I use /opt/vc/bin/tvservice -m CEA to find which formats are supported, I get this:

Code: Select all

Group CEA has 0 modes:
I've tried with other power supply, other hdmi cable, other sdcard and other fullhd screen, but the results are always the same.

Is it broken? Or is there anything left that I can try?

Regards!

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5331
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: HDMI output 720p only

Mon Oct 29, 2012 8:22 pm

Did this change with a software update?

I'm assuming not. My guess is the EDID is no longer being read. I'd imagine

Code: Select all

tvservice -d edid.dat
will produce a zero length file.

Possibly this is the Pi board (specifically the hdmi socket), or the cable, or the TV (again most likely the socket).

Can you connect to a different HDMI input on TV? Can you try another TV? Can you try another HDMI cable? Can you try another Pi board?

Kaplas
Posts: 4
Joined: Mon Oct 29, 2012 7:37 pm
Location: Spain

Re: HDMI output 720p only

Mon Oct 29, 2012 8:37 pm

No, the change was not after a software update. I tried to watch a movie and it played at 1080p but without sound, and after a reboot I had the issue.

You are right with the result of that command:

Code: Select all

Written 0 bytes to edid.dat
I've tried with other sdcard with a different image, other cable and other TV, and the result is the same. I can't try with other board because it is the only one I have.

Is there any option like hdmi_force_edid_audio=1 to force the video?

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5331
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: HDMI output 720p only

Mon Oct 29, 2012 9:01 pm

Kaplas wrote:Is there any option like hdmi_force_edid_audio=1 to force the video?
I'd like to say,
hdmi_ignore_edid=0xa5000080

will make all hdmi modes appear available, and then
hdmi_group=1
hdmi_mode=16

will let you force 1080p. But unfortunately it doesn't work how I'd like, and hdmi_ignore_edid requires a valid edid to start with.

I'll have a look at doing this.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5331
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: HDMI output 720p only

Mon Oct 29, 2012 9:39 pm

Okay, try updating (e.g. with rpi-update). Try:
hdmi_ignore_edid=0xa5000080
hdmi_group=1
hdmi_mode=16
hdmi_force_edid_audio=1
hdmi_drive=2

and hopefully you'll get 1080p with 5.1 audio.

Kaplas
Posts: 4
Joined: Mon Oct 29, 2012 7:37 pm
Location: Spain

Re: HDMI output 720p only

Mon Oct 29, 2012 11:14 pm

Ok, I'll try tomorrow.

Thank you very much!!!

Kaplas
Posts: 4
Joined: Mon Oct 29, 2012 7:37 pm
Location: Spain

Re: HDMI output 720p only

Tue Oct 30, 2012 6:02 pm

IT WORKS!!! :D :D :D :D

Thank you!!!

starduster_too
Posts: 2
Joined: Tue Jan 01, 2013 10:49 pm

Re: HDMI output 720p only

Tue Jan 01, 2013 11:10 pm

Hi,
I am having a similar problem and wonder if anyone can help.
If I plug my RPI into one TV I am getting 1080p, if I plug into another it is only working at 720p.
I know the second TV is full HD and capable of displaying 1080p - it is brand new yesterday. I bought it for the kids playroom and to double up as an RPI screen for them to learn with so it's disappointing to not be able to get the full resolution.

TV1 is an expensive 50" Panasonic
TV2 is a cheap 24" model from a brand called Sandstrom [from Currys]

I have tried the rpi-update suggestion above but it has had no effect on the second TV and the first one still works anyway. (It's possible I did it wrong but am fairly confident I didn't!).

starduster_too
Posts: 2
Joined: Tue Jan 01, 2013 10:49 pm

Re: HDMI output 720p only

Wed Jan 02, 2013 12:31 am

Update - managed to fix the issue....

This was the most useful piece of info - managed to force the RPI into 1080p by editing the config.txt file as per suggestion in this article.

http://elinux.org/RPi_config.txt

Return to “Troubleshooting”