kcg
Posts: 1
Joined: Thu May 17, 2018 6:30 pm

USB Ethernet which works with RPi 3 B without additional power supply.

Thu May 17, 2018 6:39 pm

Hello,

I'm trying to make simple router from my RPi 3 B, so to get another NIC I've plugged in Lenovo ThinkPad USB 3.0 Ethernet adapter. To my surprise this thing wasn't working neither in OpenBSD 6.3-current nor in Debian unstable 64bit build for RPi. Somehow it looks like working, leds flashing etc, but both OSes clearly waited for data arrival (DHCP) for ever.
Next I've found this site: https://elinux.org/RPi_USB_Ethernet_adapters

I've double checked, that tp-link was promissing:
"TP-Link UE300 USB 3.0 to Gigabit Ethernet Network Adapter. Works out of box on Raspbian Wheezy on a Pi 2 Model B. No external power source or USB hub needed. Pi is powered by a 2.5 amp power supply."

So I went ahead, purchased the adapter, plugged it in and viola, the same result like with ThinkPad's. Led's flashing, but OS is waiting forever on network initialization. BTW: both adapters seems to be based on the same hardware -- or looks from the internet research...

Please note, that together with my RPi3 B I've purchased "recommended RPi PSU" which should give my Pi 2.5A current.

Now, my question is: does anybody here know about usb -> ethernet network adapter which works well with just RPi 3 B and RPi is able to power it well and data flows throught it well?

Have anybody here seen issue(s) like I see with my RPi? I assume this should be kind of PSU/current limitation on RPi's USB ports, shouldn't it?

Any advice on this highly appreciated.

Thanks!
Karel

fruitoftheloom
Posts: 17443
Joined: Tue Mar 25, 2014 12:40 pm

Re: USB Ethernet which works with RPi 3 B without additional power supply.

Thu May 17, 2018 9:18 pm

kcg wrote:
Thu May 17, 2018 6:39 pm
Hello,

I'm trying to make simple router from my RPi 3 B, so to get another NIC I've plugged in Lenovo ThinkPad USB 3.0 Ethernet adapter. To my surprise this thing wasn't working neither in OpenBSD 6.3-current nor in Debian unstable 64bit build for RPi. Somehow it looks like working, leds flashing etc, but both OSes clearly waited for data arrival (DHCP) for ever.
Next I've found this site: https://elinux.org/RPi_USB_Ethernet_adapters

I've double checked, that tp-link was promissing:
"TP-Link UE300 USB 3.0 to Gigabit Ethernet Network Adapter. Works out of box on Raspbian Wheezy on a Pi 2 Model B. No external power source or USB hub needed. Pi is powered by a 2.5 amp power supply."

So I went ahead, purchased the adapter, plugged it in and viola, the same result like with ThinkPad's. Led's flashing, but OS is waiting forever on network initialization. BTW: both adapters seems to be based on the same hardware -- or looks from the internet research...

Please note, that together with my RPi3 B I've purchased "recommended RPi PSU" which should give my Pi 2.5A current.

Now, my question is: does anybody here know about usb -> ethernet network adapter which works well with just RPi 3 B and RPi is able to power it well and data flows throught it well?

Have anybody here seen issue(s) like I see with my RPi? I assume this should be kind of PSU/current limitation on RPi's USB ports, shouldn't it?

Any advice on this highly appreciated.

Thanks!
Karel

https://www.jeffgeerling.com/blogs/jeff ... networking
Adieu

Return to “Networking and servers”

Who is online

Users browsing this forum: No registered users and 11 guests