Posts: 76
Joined: Fri Mar 17, 2017 1:05 pm
Location: Switzerland

Citrix Receiver on RPi3 - Issues

Thu May 17, 2018 8:52 am


I'm trying to get Citrix Receiver run on RPi3 with Stretch.
I first tried with the Chromium plugin ... to no avail.
I then installed the latest Citrix Receiver according to some good sources I found in the web and linked to in this forum as well.
So far so good, connection to the Store Front works as expected. Upon trying to start a session the *.ica file is downloaded ... and that's where it ends.
Trying to manually start wfica with the ica file as parameter returns a memory error.
$? shows an error 139 = E_SSLSDK_ALERT_UNSUPPORTED_CERT

I tried to get some help in the Citrix forum. However, there is not much going on there.
Has someone here made some experience with Citrix Receiver for Linux, maybe even on RPi.

I'd be thankful for every hint.

Posts: 76
Joined: Fri Mar 17, 2017 1:05 pm
Location: Switzerland

Re: Citrix Receiver on RPi3 - Issues

Thu Jul 19, 2018 12:04 pm

An update:

I have it basically working now and I can connect to desktops and apps - feels kinda strange to see a WinServer2016 running fluently on the Raspi display :shock: . There were some issues with the certificates that I needed to copy over from FF to the CTX receiver and some settings on Martin's guide regarding VirtualDriver that seem not to work on my end.

What I still miss is audio. This might be caused by the USB-attached CODEC I'm using, or anything, I just don't know.
I also don't get the locally attached USB-camera to work. VLC in the CTX session tries to turn it on and then stops saying parameters are not supported. I can perfectly use the camera with the locally installed VLC though.

If someone has any experience or idea ... :D

Return to “Networking and servers”