stfnpi
Posts: 1
Joined: Wed Apr 18, 2018 8:45 am

Problem with Waveshare 1.3inch OLED

Wed Apr 18, 2018 9:00 am

I recently got an OLED hat for my raspberry PI zero W.
https://www.waveshare.com/1.3inch-oled-hat.htm.
https://www.waveshare.com/wiki/1.3inch_OLED_HAT
But can't seem to get it to work at all and think it might be dead on arrival as there is no sign of it working at all.
But to be sure just wanted to ask if im missing something before i request a refund since i'm not really that familiar with the GPIO stuff.

I tried following the instructions (on a fresh install of 2018-03-13-raspbian-stretch-lite) which basically are:
- Connect it to the PI GPIO Header (i connected all pins)
- Enable SPI (raspi-config)
- Install Python Libraries:
python-dev python-smbus python-serial python-imaging python-pip libfreetype6-dev libjpeg-dev

unrar and sudo python setup.py the following:
https://files.pythonhosted.org/packages ... 6.3.tar.gz
https://files.pythonhosted.org/packages ... 3.2.tar.gz
sudo -H pip install --upgrade luma.oled
- Run Python Demo

Every step goes without errors but running any of the 3 python demos nothing happens.
I tried the other demos as well (WiringPI & bcm2835) but again nothing happens.
I tried it via I2C as well but I2Cdetect will show -- for everything.

Am i missing some step on the commandline to get it to work or do i need to only connect certain GPIO pins for it to work?
Thanks

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5621
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Problem with Waveshare 1.3inch OLED

Wed Apr 18, 2018 1:32 pm

I can't comment on that specific OLED hat but, out of ~half-a-dozen (bare) OLED displays (I2C or SPI) I've only managed, so far, to get this one (the first) to work:
http://www.cpmspectrepi.uk/raspberry_pi ... SSD1306.29
The others, blue PCB's, have either appeared to respond to a "test mode" command initially and subsequently "failed" or remained blank "whatever I try". What is unclear with some of them is whether they're truly 3V - 5V operation or 3V only. If the latter's the case, since I'm using level shifters and 5V I2C I may have "killed" some. Whilst the Gaohou one still works at 3.3V, it's somewhat dim ----> a 5V device. W.r.t. to the SPI ones - I don't have an oscilloscope so I can't check the timing etc. (Although, at some point, I'll have to see if @joan's piscope gives me any clues. Ideally I'd like to re-try with known, working device!)
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, and a A+) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

timothyjcolley
Posts: 3
Joined: Sun Jan 12, 2014 5:44 pm

Re: Problem with Waveshare 1.3inch OLED

Sat Dec 29, 2018 6:12 pm

Assuming you have everything installed correctly, you need to use the following command:

sudo python demo.py

Remember the sudo, the screen needs sudo access to allow direct spi/serial access to the controller

Hope this solves your problem.

Return to “Troubleshooting”