rogermiranda1000
Posts: 11
Joined: Sat Mar 31, 2018 8:46 pm

Connection to dhcpcd lost

Sat Mar 31, 2018 9:32 pm

I was making IPv4 static modifying /etc/network/interfaces, this is my code:

Code: Select all

source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
	address 192.168.1.10
	netmask 255.255.255.0
	network 192.168.0.1
	gateway 192.168.1.1
	dns-nameservers 8.8.8.8 8.8.4.4

auto wlan0
iface wlan0 inet static
	wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
	address 192.168.1.11
	netmask 255.255.255.0
	network 192.168.0.1
	gateway 192.168.1.1
	dns-nameservers 8.8.8.8 8.8.4.4
The IP works fine, but I Raspberry says "No wireless interfaces found" (the Raspberry connects to Wi-Fi if it's putted in /etc/wpa_supplicant/wpa_supplicant.conf).

SurferTim
Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Connection to dhcpcd lost

Sun Apr 01, 2018 12:08 pm

If you are using Stretch, which you should be, your static settings should be set in /etc/dhcpcd.conf. Your entry in /etc/network/interfaces will cause the dhcpcd service to fail.

rogermiranda1000
Posts: 11
Joined: Sat Mar 31, 2018 8:46 pm

Re: Connection to dhcpcd lost

Thu Jun 14, 2018 10:20 am

It works, thanks!

thanospi
Posts: 1
Joined: Thu Nov 28, 2019 9:11 pm

Re: Connection to dhcpcd lost

Thu Nov 28, 2019 9:15 pm

For me the best solution was the next configuration:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.0.50
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1

auto wlan0
iface wlan0 inet dhcp

I have the ip and I can access to internet

josh1
Posts: 1
Joined: Tue Jun 16, 2020 8:15 am
Contact: Website

Re: Connection to dhcpcd lost

Tue Jun 16, 2020 10:28 am

rogermiranda1000 wrote:
Thu Jun 14, 2018 10:20 am
It works, thanks!
Where did you put the configuration?
/etc/dhcpcd.conf or /etc/network/interfaces?

I uninstalled my Pihole and I’m disconnected from the internet.

Return to “Troubleshooting”