LMulcahy
Posts: 2
Joined: Sun Mar 04, 2018 10:43 pm

Edited Autostart file now just blank screen when Pi booted up.

Sun Mar 04, 2018 11:17 pm

Hello, I'm new to the Pi and have been trying to run Raspbian to boot into a full screen web browser with the following code (which worked).

Code: Select all

# Auto run the browser
@xset s off
@xset -dpms
@xset s noblank
@midori -e Fullscreen -a http://google.com
The above code was placed into the .config/lxsession/LXDE-pi/autostart file.

I now want to go back into the original boot up view of the Pi GUI and have gone back to the original code that was in the file

Code: Select all

@lxpanel -- profile LXDE-pi
@pcmanfm - desktop  --profile LXDE-pi
@xscreensaver - no-splash
However now when I boot up I just get a black screen and I have been searching for 3 hours trying to find where the problem may be but I havn't found anything and i'm really stuck!

Any help would be appreciated so much ! :D

MarkDH102
Posts: 377
Joined: Fri Feb 13, 2015 3:18 pm

Re: Edited Autostart file now just blank screen when Pi booted up.

Mon Mar 05, 2018 7:32 am

These are the contents of my file
Note that the spacing is different with the -- and also you have a single - on desktop

Code: Select all

@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@point-rpi
Don't know if this helps...

LMulcahy
Posts: 2
Joined: Sun Mar 04, 2018 10:43 pm

Re: Edited Autostart file now just blank screen when Pi booted up.

Mon Mar 05, 2018 12:16 pm

Hi Mark,

Thanks for your help, this worked! :D

Return to “Troubleshooting”