mvdvarrier
Posts: 6
Joined: Sat Jan 13, 2018 1:54 pm

PiServer - Client OS installing error using apt

Sat Jan 13, 2018 2:07 pm

I have installed Raspbian for PC in a desktop computer. after installation when I tried to configure pi clients through PiServer;
The MAC address of the client pi3 has been detected but when i tried to install the client OS (Raspbian regular or lite) in the next step, the installation quits by showing following error message "Error executing 'apt-get -q -y install dnsmasq openssh-server nfs-kernel-server slapd libnss-ldapd libpam-ldapd ldap-utils gnutls-bin'
Help in this matter will be highly appreciated.

User avatar
mikerr
Posts: 2540
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: PiServer - Client OS installing error using apt

Sat Jan 13, 2018 2:25 pm

The PC running PiServer needs internet access - at least for first setup.

Try typing that command in the terminal:

Code: Select all

sudo apt-get -q -y install dnsmasq openssh-server nfs-kernel-server slapd libnss-ldapd libpam-ldapd ldap-utils gnutls-bin
Last edited by mikerr on Sat Jan 13, 2018 2:34 pm, edited 1 time in total.
Android app - Raspi Card Imager - download and image SD cards - No PC required !

mvdvarrier
Posts: 6
Joined: Sat Jan 13, 2018 1:54 pm

Re: PiServer - Client OS installing error using apt

Sat Jan 13, 2018 2:31 pm

The internet connection is OK, That I am writing this post from the PC

mvdvarrier
Posts: 6
Joined: Sat Jan 13, 2018 1:54 pm

Re: PiServer - Client OS installing error using apt

Sat Jan 13, 2018 2:34 pm

Qustion: "There is no Raspbian for x86 machines, did you actually install Debian Stretch with Raspberry Pi Desktop ??"
Oh Sorry! Precisely My OS running in the PC is Linux raspberry 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2017-09-28) x86_64 GNU/Linux

mvdvarrier
Posts: 6
Joined: Sat Jan 13, 2018 1:54 pm

Re: PiServer - Client OS installing error using apt

Sat Jan 13, 2018 2:52 pm

When tried the command the error is as follows;
sudo apt-get -q -y install dnsmasq openssh-server nfs-kernel-server slapd libnss-ldapd libpam-ldapd ldap-utils gnutls-bin
Reading package lists...
Building dependency tree...
Reading state information...
Package nfs-kernel-server is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
nfs-common

Package slapd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package ldap-utils is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'nfs-kernel-server' has no installation candidate
E: Package 'slapd' has no installation candidate
E: Unable to locate package libnss-ldapd
E: Unable to locate package libpam-ldapd
E: Package 'ldap-utils' has no installation candidate

User avatar
fruitoftheloom
Posts: 15421
Joined: Tue Mar 25, 2014 12:40 pm
Location: Bognor Regis UK

Re: PiServer - Client OS installing error using apt

Sat Jan 13, 2018 3:16 pm

mvdvarrier wrote:
Sat Jan 13, 2018 2:52 pm
When tried the command the error is as follows;
sudo apt-get -q -y install dnsmasq openssh-server nfs-kernel-server slapd libnss-ldapd libpam-ldapd ldap-utils gnutls-bin
Reading package lists...
Building dependency tree...
Reading state information...
Package nfs-kernel-server is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
nfs-common

Package slapd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package ldap-utils is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'nfs-kernel-server' has no installation candidate
E: Package 'slapd' has no installation candidate
E: Unable to locate package
E: Unable to locate package libpam-ldapd
E: Package 'ldap-utils' has no installation candidate


In Debian Stretch they are all valid packages, did you run:

Code: Select all

sudo apt update
sudo apt dist-upgrade

https://packages.debian.org/stretch/nfs-common

https://packages.debian.org/stretch/ldap-utils

https://packages.debian.org/stretch/libnss-ldapd

https://packages.debian.org/stretch/slapd

https://packages.debian.org/stretch/libpam-ldapd
My only "PC" is an Asus ChromeBit running ChromeOS, cloudcentric at its best !
Rockchip Quad-Core RK3288C ARM32 SoC as used in ASUS Chromebook C201 & Chromebook Flip C100PA as well as the Tinker SBC.
3 Mobile Huawei E5330 Mobile Mi-Fi

User avatar
fruitoftheloom
Posts: 15421
Joined: Tue Mar 25, 2014 12:40 pm
Location: Bognor Regis UK

Re: PiServer - Client OS installing error using apt

Sat Jan 13, 2018 4:45 pm

mvdvarrier wrote:
Sat Jan 13, 2018 2:34 pm
Qustion: "There is no Raspbian for x86 machines, did you actually install Debian Stretch with Raspberry Pi Desktop ??"
Oh Sorry! Precisely My OS running in the PC is Linux raspberry 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2017-09-28) x86_64 GNU/Linux

Still not full information, cat /etc/os-release, see:

https://linuxconfig.org/check-what-debi ... nux-system
My only "PC" is an Asus ChromeBit running ChromeOS, cloudcentric at its best !
Rockchip Quad-Core RK3288C ARM32 SoC as used in ASUS Chromebook C201 & Chromebook Flip C100PA as well as the Tinker SBC.
3 Mobile Huawei E5330 Mobile Mi-Fi

mvdvarrier
Posts: 6
Joined: Sat Jan 13, 2018 1:54 pm

Re: PiServer - Client OS installing error using apt

Sun Jan 14, 2018 2:14 am

In Debian Stretch they are all valid packages, did you run:
Code: Select all

sudo apt update
sudo apt dist-upgrade
Even after the distro upgrading the apt, same error repeats.

mvdvarrier
Posts: 6
Joined: Sat Jan 13, 2018 1:54 pm

Re: PiServer - Client OS installing error using apt

Sun Jan 14, 2018 2:37 am

I think the problem is now solved .
I just carefully inspected the entries in the /etc/apt/sources.list file.
the default entries are
deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

I just added the line
deb http://httpredir.debian.org/debian/ stretch main contrib non-free
I think the non-free item can be avoided but i have an old nvidia card and i need it.
This line solved all the issues during updating and OS installation by the PiServer.
I suspect this error with sources.list file caused by any startup scripts during installation.
Any how thanks to all who helped me with my humble problem. Thanks gentlemen, Thanks!!!

User avatar
mikerr
Posts: 2540
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: PiServer - Client OS installing error using apt

Sun Jan 14, 2018 10:16 am

Glad you got it sorted, but for clarity my default unaltered sources.list reads like this:

Code: Select all

deb http://ftp.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free

# Uncomment lines below then 'apt-get update' to enable 'apt-get source'
#deb-src http://ftp.debian.org/debian/ stretch main contrib non-free
#deb-src http://security.debian.org/ stretch/updates main contrib non-free
#deb-src http://ftp.debian.org/debian/ stretch-updates main contrib non-free
Android app - Raspi Card Imager - download and image SD cards - No PC required !

Return to “Raspberry Pi Desktop for PC and Mac”

Who is online

Users browsing this forum: jpst and 1 guest