kamdzie
Posts: 2
Joined: Thu Jan 04, 2018 9:46 pm

etc/kbd/config no such file or directory

Thu Jan 04, 2018 9:48 pm

Hi!
I am struggling with shutting down the screen saver. Everywhere on the Internet everybody say, that I have to edit /etc/kbd/config file. The problem is that I don't have such directory on my raspberry (newest Raspbian). Please help cause it's making me go cracy.

User avatar
DougieLawson
Posts: 36528
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: etc/kbd/config no such file or directory

Thu Jan 04, 2018 10:13 pm

/etc/default/keyboard holds the default keyboard configuration.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

kamdzie
Posts: 2
Joined: Thu Jan 04, 2018 9:46 pm

Re: etc/kbd/config no such file or directory

Thu Jan 04, 2018 10:22 pm

Thank you for a quick response, but :
I cannot see lines about power management in that file as it was said so.........

User avatar
DougieLawson
Posts: 36528
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: etc/kbd/config no such file or directory

Thu Jan 04, 2018 10:51 pm

Try reading a different tutorial, ignore everything that's more than a year old, they will be out of date.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

W. H. Heydt
Posts: 11064
Joined: Fri Mar 09, 2012 7:36 pm
Location: Vallejo, CA (US)

Re: etc/kbd/config no such file or directory

Tue Oct 30, 2018 2:44 pm

DougieLawson wrote:
Thu Jan 04, 2018 10:13 pm
/etc/default/keyboard holds the default keyboard configuration.
(Sorry about the necro...)

That doesn't actually answer the OPs question.

It used to be (Wheezy, Jessie) that one could alter the screen blanking time (or suppress it completely) by setting the BLANK_TIME and POWERDOWN_TIME statements in /etc/kbd/config. Without that file, the only solution anyone seems to have to do this is to add xscreensaver to the system. That's a poor solution.

So at least for me, the question is: Where do those parameters live in Stretch?

klricks
Posts: 6614
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: etc/kbd/config no such file or directory

Tue Oct 30, 2018 5:17 pm

W. H. Heydt wrote:
Tue Oct 30, 2018 2:44 pm
DougieLawson wrote:
Thu Jan 04, 2018 10:13 pm
/etc/default/keyboard holds the default keyboard configuration.
(Sorry about the necro...)

That doesn't actually answer the OPs question.

It used to be (Wheezy, Jessie) that one could alter the screen blanking time (or suppress it completely) by setting the BLANK_TIME and POWERDOWN_TIME statements in /etc/kbd/config. Without that file, the only solution anyone seems to have to do this is to add xscreensaver to the system. That's a poor solution.

So at least for me, the question is: Where do those parameters live in Stretch?
The easiest way to disable screen blanking in Raspbian Desktop:
Add these 2 lines to: /home/pi/.config/lxsession/LXDE-pi/autostart

Code: Select all

@xset s off
@xset -dpms
Note that there are 2 screen savers running together so the above commands will turn off both.
The default for both screensavers is 10 min.

If you wanted to change the blanking time to say 15 minutes then the commands are:
(Just leaving the DPMS disabled)

Code: Select all

@xset s 900
@xset -dpms
The maximum seconds is 32767
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

Return to “Troubleshooting”