Fredenando
Posts: 1
Joined: Thu Nov 02, 2017 9:38 pm

Raspbian Stretch USB audio as default

Thu Nov 02, 2017 10:16 pm

Hi all,

I'm newbie with Raspberry and Linux so please my excusses.

I have the Raspberry 3 with Raspbian Stretch and want to use as default audio a Behringer UMC202 that in fact are detected and working but only with some programs that let me select the audio device in/out, but never if I play an audio file with alsaplayer or open a Youtube video or sound from a web.

I have search a lot on Google and found it a few solutions based on modificate some files like alsa-base.conf or similars but that don't exist in the respective folders, so I'm lost looking for help...

Thanks!!

panmnesia
Posts: 15
Joined: Mon Jun 13, 2016 2:11 pm

Re: Raspbian Stretch USB audio as default

Thu Dec 28, 2017 1:04 am

Don't know if this is helpful, but I'm having the same issue; adafruit's how-to on the sound card I got from them seems really out of date.

Maybe this will help: https://wiki.archlinux.org/index.php/Ad ... ts.22_node

...I have that file and am going to try changing the following lines to be "1" instead of 0:

defaults.ctl.card 0
defaults.pcm.card 0
defaults.pcm.device 0

I'm most unsure about setting the "device" line, because I don't know the difference between the card and the device... maybe that should stay 0?

jonsafc
Posts: 2
Joined: Wed Jan 17, 2018 10:19 pm

Re: Raspbian Stretch USB audio as default

Thu Jan 18, 2018 5:15 pm

Hi, I'm pulling my hair out here tying to figure this out too. I've tried what the previous comment said with little success.

I've created another subject yesterday and would really like some help here. I'll post the link below. Thanks.

viewtopic.php?f=38&t=202837&p=1260472#p1260472

wunderFish
Posts: 1
Joined: Sun Feb 18, 2018 3:24 pm

Re: Raspbian Stretch USB audio as default

Sun Feb 18, 2018 3:48 pm

Hi, this solution worked for me, on Raspbian Stretch.

Initial checks :
This should display snd_usb_audio when the device is plugged in :

Code: Select all

lsmod | grep snd_usb_audio
The following command was working fine on the usb device

Code: Select all

speaker-test -Dhw:1,0 -c2 -twav

But this one not

Code: Select all

sudo aplay /usr/share/sounds/alsa/Front_Center.wav
Solution :
1. Backing up the file /usr/share/alsa/alsa.conf

Code: Select all

cd /usr/share/alsa
sudo cp alsa.conf alsa.conf.orig
2. Editing the file /usr/share/alsa/alsa.conf, changing

Code: Select all

defaults.ctl.card 0
defaults.pcm.card 0
to

Code: Select all

defaults.ctl.card 1
defaults.pcm.card 1
3. Rebooting
4. Checking if the sound plays with

Code: Select all

sudo aplay /usr/share/sounds/alsa/Front_Center.wav

Return to “Beginners”