Posts: 23
Joined: Fri Oct 06, 2017 4:47 pm

VPN not working

Mon Oct 30, 2017 4:40 pm

Hello guys,

I can't use my vpn on my RaspberryPi3.
Latest fresh (!) raspbian, updates, upgrades and rpi-updates are installed.
RPI is connected over ethernet.
Webbrowser chromium is working good and is also connected to the internet.

So I installed openvpn and network-manager-openvpn.
My vpn-host is "private internet access".

I could use it with the console by typing "sudo openvpn Netherlands.ovpn" for example.

I tried several tutorials to install it but when I start the vpn the RPi loses the internet-connection (LAN still working) until I disconnect it again.

Is there any working GUI which I could use instead?
I tried GADMIN-openvpn-client but it won't launch when I start it.

Thank you for your help.

Posts: 1
Joined: Mon Nov 20, 2017 11:21 am

Re: VPN not working

Mon Nov 20, 2017 3:11 pm

I also have an issue with my VPN.
I get an error message that a key is not initialised and that it is dropping packets.
I am almost sure it is the following issue:

This is a know bug with the current package 2.4.0 that comes with stretch. the issue would be solved if I could upgrade to 2.4.3.
But that i don't know how to do, or to downgrade the openvpn to 2.3.

Any help i sappreciated.

Return to “Troubleshooting”