Favdaukar
Posts: 4
Joined: Wed Oct 04, 2017 7:58 pm

Using a 7'' TFT I can't use HDMI

Wed Oct 04, 2017 8:51 pm

Hi everyone!

I've been digging a lot on the internet about this, and also asked in the Recalbox forum, and nobody seems to know.
I'm using a Raspberry Pi 3 B with Recalbox (4.1), I installed the Element14 7'TFT https://www.element14.com/community/doc ... ated-prods

Screen works perfectly, has a terrific image quality, sound output is flawless through audio jack.

Problem is when I plug the HDMI cable I've been using before to the TV, when I turn the RPi on I just see a black screen on the TV, and the image comes from the 7'' TFT.
Only thing I get from the TV is sound.
What am I doing wrong?
Can I configure config.txt to "autodetect" when I plug HDMI and switch between HDMI and 7TFT? Or is there any script available for that?
Thanks a lot in advance.
Here's a copy of my current config.txt

Code: Select all

uncomment if you get no picture on HDMI for a default "safe" mode
hdmi_safe=1

disable_overscan=1

uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

#comment to get jack audio
hdmi_drive=2

#config_hdmi_boost=0

force hdmi while the tv can take time before sending the signal on the hdmi output
hdmi_force_hotplug=1

#uncomment for composite PAL
sdtv_mode=2

uncomment for lirc-rpi
#dtoverlay=lirc-rpi

if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it
boot_delay=3

#uncomment if you don't want the rainbow at startup
disable_splash=1

Overclock
gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=512

avoid_safe_mode=1

kernel=zImage

NOOBS Auto-generated Settings:
#hdmi_force_hotplug=1
overscan_scale=0

max_usb_current=1
lcd_rotate=2
avoid_warnings=1
dtparam=audio=on

Tried tvservice while the HDMI cable is plugged and it detects the TV, but just that.
It won't let me try -m or -M commands.

-s says this:

/recalbox/share_init/system$ tvservice -s
state 0x400000 [LCD], 800x480 @ 60.00Hz, progressive

-n says this:

/recalbox/share_init/system$ tvservice -n
device_name=GSM-LG_TV

-a says this:

/recalbox/share_init/system$ tvservice -a
PCM supported: Max channels: 2, Max samplerate: 192kHz, Max samplesize 24 bits.
AC3 supported: Max channels: 6, Max samplerate: 48kHz, Max rate 640 kb/s.

Just to confirm the HDMI is working, I added "ignore_lcd=1" to config.txt
Then I rebooted and as expected, I got image and sound from the TV, the RPi LCD is off now.

I used display_default_lcd=0 on the config.txt
HDMI works fine on TV, no image on LCD screen. When rebooted without the HDMI cable plugged, still no image on LCD.

I got it to work but only partially.
I added this to the config.txt:

Code: Select all

[EDID=GSM-LG_TV]
ignore_lcd=1
hdmi_group=2
hdmi_mode=82
[all]
Now when the HDMI from my TV is connected before boot, it will detect and prefer HDMI and it works fine, and if HDMI is not plugged in, the LCD will come up as usual.

Problem is it only works with my TV... How do I make that work for example if I take it to a friends house?

I think the answer is finding a way to have it detect HDMI and if detected run ignore_lcd=1 and if not detected, don't run it or change it to ignore_lcd=0

Any help please?
Thanks a lot in advance!

fruitoftheloom
Posts: 19363
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Using a 7'' TFT I can't use HDMI

Thu Oct 05, 2017 5:42 pm

adieu

My other Computer is an Asus CS10 ChromeBit running Chrome Operating System.
HP Envy 4500 Wireless Printer supported by HPLIP software in Raspbian Stretch.

Favdaukar
Posts: 4
Joined: Wed Oct 04, 2017 7:58 pm

Re: Using a 7'' TFT I can't use HDMI

Thu Oct 05, 2017 10:24 pm

Thank you for the reply!
It seems like a solid solution. I'll be testing it during the weekend and let you know how it went.
Thanks!

Favdaukar
Posts: 4
Joined: Wed Oct 04, 2017 7:58 pm

Re: Using a 7'' TFT I can't use HDMI

Tue Oct 10, 2017 12:15 am

No luck, I couldn't get it to work.
For some reason after doing everything described in the instructions, Recalbox won't even boot on a fresh install.

When I do this step :

Code: Select all

Edit "recovery.cmdline" in F:, add to the end of the line " dsi" , dont fortget the space-character, and save
It will work properly on HDMI when connected, PINN boots perfectly on HDMI, but then when Recalbox starts, the image is back on the LCD.

Then I do the next steps:

Code: Select all

Go to F:\ and create a config.txt and add the line "ignore_lcd=1" and save
when starting, the output will be forced onto hdmi with this command. PINN menu will only be visible on hdmi source now
this is important, so the dsi display does not blink, while using hdmi
Mount sd card back into raspberry pi and start into rasbian.
10.Open terminal and go to /boot/

Create file "config.dsi" in /boot/ - this config will be loaded, when hdmi is not connected
dsi display loads automatically and does not need any commands, so the config.dsi can be empty
you can add later, what usually would go into config.txt to configure your dsi display
Create file "config.hdmi" in /boot/ - this config will be loaded, when hdmi is connected
add line "ignore_lcd=1" to config.hdmi, this forces to ignore the dsi display
After that, it won't boot.

Favdaukar
Posts: 4
Joined: Wed Oct 04, 2017 7:58 pm

Re: Using a 7'' TFT I can't use HDMI

Tue Nov 07, 2017 7:12 am

Still haven't found a solution for this...
Anyone else has any idea?
I appreciate any help!

JohnSar.M
Posts: 1
Joined: Tue Jun 12, 2018 5:38 pm

Re: Using a 7'' TFT I can't use HDMI

Tue Jun 12, 2018 5:44 pm

Hi. Having the same problem and still researching for a solution. Did you have any luck with this though? Adding to it...if i find a solution for the auto detect hdmi problem...i would want the touchscreen to auto transform into a touch keyboard.

drmemory
Posts: 1
Joined: Sun Mar 31, 2019 10:06 pm

Re: Using a 7'' TFT I can't use HDMI

Sun Mar 31, 2019 10:18 pm

I am a Pi newbie, building a kodi based 'magic movie machine' for my 5 year old granddaughter (mounting it in a vented pink jewelry box with a 5ooomha cell battery as its power supply (to stay away from wall voltage always). Everyone here is much more skilled than I, but I offer my solution for other newbies.

With UPNP and discoverable then in TFT it's library is playable on a smart tv, but that assumes wifi on. I wanted to allow for cabled HDMI.

Since I am playing with NOOBS, Raspian and PINN as I learn this platform and since the element14 7" is so clever (TFT if it is there at boot, HDMI if it is there and TFT is not), I installed a SPDT switch that allows or disconnects GPIO 1 (5v). A position (on) boots to TFT, B position (off) boots to HDMI.

It would of course be much nicer if a desktop icon could enable/disable GPIO Pin 1 (5v) but, being a newbie, I haven't a clue how to do this. Is that even possible, or is GPIO (1) 5v always ON?

User avatar
rpdom
Posts: 13892
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Using a 7'' TFT I can't use HDMI

Mon Apr 01, 2019 4:17 am

It is always on. It is a power pin, not a GPIO pin. The power pins are fixed.
Signature is on holiday.

Return to “Official Foundation Display”