User avatar
VascoFerraz
Posts: 80
Joined: Thu Aug 30, 2012 11:54 am

Disable power management in Stretch

Wed Oct 04, 2017 11:12 am

In Stretch, with predicables names active, on a RPi3 how can I disable the power management of the embedded wireless chip?

Thank you.
Vasco Ferraz

DirkS
Posts: 9778
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Disable power management in Stretch

Wed Oct 04, 2017 4:30 pm

AFAIK it's switched off by default.

User avatar
VascoFerraz
Posts: 80
Joined: Thu Aug 30, 2012 11:54 am

Re: Disable power management in Stretch

Wed Oct 04, 2017 9:33 pm

DirkS wrote:
Wed Oct 04, 2017 4:30 pm
AFAIK it's switched off by default.
After a fresh install of the following version:
Version: September 2017
Release date: 2017-09-07
Kernel version: 4.9
SHA-256: a64d742bc525b548f0435581fac5876b50a4e9ba1d1cd6433358b4ab6c7a770b

Also:
"/etc/network/interfaces" is empty.
I only added my network to the "/etc/wpa_supplicant/wpa_supplicant.conf"
Installed, samba, changed default ssh ports, edited fstab.

Image
Vasco Ferraz

DirkS
Posts: 9778
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Disable power management in Stretch

Thu Oct 05, 2017 4:43 pm

Take a look at the log:

Code: Select all

[email protected]:~$ dmesg | grep brcm
[   10.622921] usbcore: registered new interface driver brcmfmac
[   10.750197] brcmfmac: Firmware version = wl0: Aug  7 2017 00:46:29 version 7.45.41.46 (r666254 CY) FWID 01-f8a78378
[   20.651866] brcmfmac: power management disabled
Due to some problems power management had to be switched off / disabled.
Right now I can't find relevant posts here on the forum or on the RPF github site.

DirkS
Posts: 9778
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Disable power management in Stretch

Thu Oct 05, 2017 4:54 pm

Found the firmware / kernel commit: https://github.com/raspberrypi/firmware ... a8d44af54b
And the forum topic: viewtopic.php?f=28&t=138312

User avatar
VascoFerraz
Posts: 80
Joined: Thu Aug 30, 2012 11:54 am

Re: Disable power management in Stretch

Thu Oct 05, 2017 8:02 pm

You are right!

Code: Select all

[   26.801862] usbcore: registered new interface driver brcmfmac
[   26.942622] brcmfmac: Firmware version = wl0: Aug  7 2017 00:46:29 version 7.45.41.46 (r666254 CY) FWID 01-f8a78378
[   29.284947] brcmfmac: power management disabled
[16192.219005] brcmfmac: power management disabled

Then why I get my wlan0 disabled from time to time?

Code: Select all

wlan0   IEEE 802.11  ESSID:off/any
             Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm
             Retry short limit:7   RTS thr:off   Fragment thr:off
             Power Management:on
Vasco Ferraz

DirkS
Posts: 9778
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Disable power management in Stretch

Thu Oct 05, 2017 8:06 pm

VascoFerraz wrote:
Thu Oct 05, 2017 8:02 pm
Then why I get my wlan0 disabled from time to time?
No idea.
I have a Zero W connected for days on end and have never noticed any dropouts.
(well, at least after I set our AP to a channel that was not hogged by all the other ones in the neighbourhood)

User avatar
VascoFerraz
Posts: 80
Joined: Thu Aug 30, 2012 11:54 am

Re: Disable power management in Stretch

Sun Oct 08, 2017 9:41 am

DirkS wrote:
Thu Oct 05, 2017 8:06 pm
VascoFerraz wrote:
Thu Oct 05, 2017 8:02 pm
Then why I get my wlan0 disabled from time to time?
No idea.
I have a Zero W connected for days on end and have never noticed any dropouts.
(well, at least after I set our AP to a channel that was not hogged by all the other ones in the neighbourhood)
You are again right.

I set the router to another non hogged channel and since then I am not experiencing any disconnections from wlan0.
Vasco Ferraz

rafnus
Posts: 1
Joined: Fri Nov 10, 2017 12:13 pm

Re: Disable power management in Stretch

Fri Nov 10, 2017 12:19 pm

Hi,

I am new with pi and if that can help you I found by this link
http://www.thelowercasew.com/disabling- ... ian-jessie

You just have to type
sudo iwconfig wlan0 power off

It should work as with the command sudo iwconfig shows me
Power Management : off

amcdonley
Posts: 143
Joined: Mon Jan 26, 2015 5:56 pm
Location: Florida, USA

Re: Disable power management in Stretch

Sat Nov 25, 2017 3:04 pm

added to /etc/rc.local:

iwconfig wlan0 power off

resulted in my Stretch Pi3 onboard wifi power management being permanently off.

For my robot, this reduces the tx excessive retries by a factor of 10, and incoming ping Request timeouts by a factor of 2.

Code: Select all

Linux RWPi 4.9.41-v7+ #1023 SMP Tue Aug 8 16:00:15 BST 2017 armv7l GNU/Linux

User avatar
Ronaldlees
Posts: 294
Joined: Sat Apr 16, 2016 4:28 pm
Location: North Carolina, US
Contact: Website

Re: Disable power management in Stretch

Sat Nov 25, 2017 3:51 pm

amcdonley wrote:
Sat Nov 25, 2017 3:04 pm
added to /etc/rc.local:

iwconfig wlan0 power off

resulted in my Stretch Pi3 onboard wifi power management being permanently off.

For my robot, this reduces the tx excessive retries by a factor of 10, and incoming ping Request timeouts by a factor of 2.

Code: Select all

Linux RWPi 4.9.41-v7+ #1023 SMP Tue Aug 8 16:00:15 BST 2017 armv7l GNU/Linux
I wish i had a nickel for every post about a power-saving "feature" wasting people's time and causing things to break. My theory is that the companies that make hardware get a special tax break for putting "energy saving" modes into everything. Even though most of this stuff wouldn't save enough energy to warm a bird's nest for a day.
I am the Umbrella man

User avatar
DougieLawson
Posts: 35025
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Disable power management in Stretch

Mon Nov 27, 2017 8:25 am

For the RPF built-in Broadcom (aka Cypress) WiFi/BT there's no control for power management. It's disabled by the kernel and the only thing you're seeing is a bug in the iw / iwlist / iwconfig commands.
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a hippy & doctor free zone.

grobi
Posts: 1
Joined: Sat Mar 10, 2018 4:54 am

Re: Disable power management in Stretch

Sat Mar 10, 2018 4:57 am

rc.local works for my Raspberry Pi Zero with Stretch 9.3. Thanks a lot :D

Return to “Advanced users”