EmaU
Posts: 3
Joined: Fri Sep 29, 2017 10:57 am

Debian Stretch: deactivate screen blanking

Fri Sep 29, 2017 3:51 pm

Hi all,

I am rather new to the Raspberry pi and would need your help. I have a Raspberry 3b attached to the 7 Inch Raspberry pi touchscreen running on Stretch.
I would like to deactivate the screen blanking in the new Debian Stretch but I have been unsuccessful so far. I found several suggestions on the internet but some seem rather old and do not apply to Stretch anymore (see 3.).
I tried:
1) in /etc/ issue
add TERM=Linux setterm -blank 0

2) in /etc/xdg/lxsession/LXDE-pi/autostart
add:
@xset s noblank
@xset s off
@xset -dpms

3) there was a suggestion to add 3 lines in /etc/kbd/config but this file does not exist in Stretch

Nothing works.

Does anyone have any other suggestions that I could try?

By the way, the method that I used in Jessie does not work anymore, on the contrary I lost the taskbar and the application menu and had a hard time to undo everything:
In Jessie (not Stretch) I did:
in /etc/lightdm/lightdm.conf
added in the [SeatDefaults] section:
xserver-command=X -s 0 -dpms

I would really appreciate your help
Regards,
EmaU

fruitoftheloom
Posts: 20685
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Debian Stretch: deactivate screen blanking

Fri Sep 29, 2017 6:26 pm

EmaU wrote:
Fri Sep 29, 2017 3:51 pm
Hi all,

I am rather new to the Raspberry pi and would need your help. I have a Raspberry 3b attached to the 7 Inch Raspberry pi touchscreen running on Stretch.
I would like to deactivate the screen blanking in the new Debian Stretch but I have been unsuccessful so far. I found several suggestions on the internet but some seem rather old and do not apply to Stretch anymore (see 3.).
I tried:
1) in /etc/ issue
add TERM=Linux setterm -blank 0

2) in /etc/xdg/lxsession/LXDE-pi/autostart
add:
@xset s noblank
@xset s off
@xset -dpms

3) there was a suggestion to add 3 lines in /etc/kbd/config but this file does not exist in Stretch

Nothing works.

Does anyone have any other suggestions that I could try?

By the way, the method that I used in Jessie does not work anymore, on the contrary I lost the taskbar and the application menu and had a hard time to undo everything:
In Jessie (not Stretch) I did:
in /etc/lightdm/lightdm.conf
added in the [SeatDefaults] section:
xserver-command=X -s 0 -dpms

I would really appreciate your help
Regards,
EmaU

https://www.raspberrypi.org/documentati ... ensaver.md
Retired disgracefully.....

klricks
Posts: 6586
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Debian Stretch: deactivate screen blanking

Fri Sep 29, 2017 9:40 pm

EmaU wrote:
Fri Sep 29, 2017 3:51 pm
.....
2) in /etc/xdg/lxsession/LXDE-pi/autostart
add:
@xset s noblank
@xset s off
@xset -dpms
That is the wrong autostart, try:

Code: Select all

/home/pi/.config/lxsession/LDXE-pi/autostart
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

MarkDH102
Posts: 340
Joined: Fri Feb 13, 2015 3:18 pm

Re: Debian Stretch: deactivate screen blanking

Sat Sep 30, 2017 6:41 am

I did this :

sudo nano /etc/lightdm/lightdm.conf

in section [Seat:*] add or adjust line to say

xserver-command=X -s 0 -dpms

That worked for me with a normal HDMI monitor...

Lena01
Posts: 1
Joined: Sat Sep 30, 2017 10:19 am

Re: Debian Stretch: deactivate screen blanking

Sat Sep 30, 2017 10:21 am

hi all, my name is Lena)) I am a new member here )) thanks for your post , nice to meet you all here, in this web site
:D

EmaU
Posts: 3
Joined: Fri Sep 29, 2017 10:57 am

Re: Debian Stretch: deactivate screen blanking

Sat Sep 30, 2017 11:43 am

Hi all,
Thanks to all for your quick replies. I do not have access to my raspberry pi at the moment but
I will try all your suggestions tomorrow evening and will report back about the results.

Kind regards and have a nice weekend,
EmaU

EmaU
Posts: 3
Joined: Fri Sep 29, 2017 10:57 am

Re: Debian Stretch: deactivate screen blanking

Mon Oct 02, 2017 9:49 pm

Thanks a lot to klricks

Adding
@xset s noblank
@xset s off
@xset -dpms
to
/home/pi/.config/lxsession/LXDE-pi/autostart worked in Debian Stretch.
Even after 30 minutes no blank monitor, therefore my question is solved.

re: fruitoftheloom
I am sorry, but I did not try your suggestion because I did not want to install another software.

Thanks a lot for your help to all of you.
Kind regards,
EmaU

mikevanis
Posts: 4
Joined: Tue Sep 15, 2015 3:53 pm

Re: Debian Stretch: deactivate screen blanking

Tue Oct 02, 2018 10:32 am

The above did not work for me. I think it's because the X session is spawned from lightdm. What DID work for me was modifying the x-server command options in /etc/lightdm/lightdm.conf to:

Code: Select all

xserver-command=X -s 0 -dpms

aBUGSworstnightmare
Posts: 1491
Joined: Tue Jun 30, 2015 1:35 pm

Re: Debian Stretch: deactivate screen blanking

Tue Oct 02, 2018 11:35 am

install xscreensaver and deactivate Screen blanking.

Code: Select all

sudo apt install xscreensaver

Return to “General discussion”