satimis
Posts: 92
Joined: Thu Aug 31, 2017 3:16 pm

How to remove the black border?

Thu Sep 07, 2017 4:23 pm

Hi all,

I tried to remove the border running;

$ sudo nano /boot/config.txt
uncomment disable_overscan=1

-> save and exit

$ systemctl reboot
to reboot Raspbian

After booting the black border is still there.

Please help. Thanks

Regards
satimis

gordon77
Posts: 5133
Joined: Sun Aug 05, 2012 3:12 pm

Re: How to remove the black border?

Thu Sep 07, 2017 4:37 pm

Try uncommenting and changing these values in config.txt

overscan_left=20
overscan_right=12
overscan_top=10
overscan_bottom=10

satimis
Posts: 92
Joined: Thu Aug 31, 2017 3:16 pm

Re: How to remove the black border?

Fri Sep 08, 2017 3:31 am

gordon77 wrote:
Thu Sep 07, 2017 4:37 pm
Try uncommenting and changing these values in config.txt

overscan_left=20
overscan_right=12
overscan_top=10
overscan_bottom=10
Thanks for your advice.

Tried following configuration;

1)

Code: Select all

disable_overscan=1

overscan_left=20
overscan_right=12
overscan_top=10
overscan_bottom=10
2)

Code: Select all

#disable_overscan=1

overscan_left=20
overscan_right=12
overscan_top=10
overscan_bottom=10
3)

Code: Select all

disable_overscan=1

overscan_left=-20
overscan_right=-12
overscan_top=-10
overscan_bottom=-10
4)

Code: Select all

#disable_overscan=1

overscan_left=-20
overscan_right=-12
overscan_top=-10
overscan_bottom=-10
all without result. The black border is still there without any alternation.

I'm running 24" LCD display with 1920x1080 resolution.

Regards
satimis

User avatar
ab1jx
Posts: 885
Joined: Thu Sep 26, 2013 1:54 pm
Location: Heath, MA USA
Contact: Website

Re: How to remove the black border?

Fri Sep 08, 2017 4:56 am

I don't know, the disable_overscan=1 should have done it as far as I know. Does the monitor work without a border on other things? I have a white border of about 1/2 inch but I've only used this monitor with the Pi. It's odd, it appears, then as soon as something covers it up it seems to go away.

tvservice -s probably won't show a lot other than the mode, but you could try tvservice -d > somefile.bin. That should dump the monitor's Extended Display Identification Data (EDID) to a binary file. Then try parse-edid on it. EDID has been through several revisions, so parse-edid doesn't always work. There are some online EDID parsers I think, or other programs to try no doubt. The EDID parsing built into the Pi only works with recent monitors, I have a couple it doesn't work with. My Dell S2409 from 2009 doesn't work with it.

There's also a "roll your own" video mode called CVT, there's a sticky for that at viewtopic.php?f=29&t=24679&hilit=cvt

R_a_s_s_b_e_r_y
Posts: 1
Joined: Sat Aug 10, 2019 10:38 pm

Re: How to remove the black border?

Sun Aug 18, 2019 12:47 am

Try to use negative numbers not positive in /boot/config.txt this helped me ;)

W. H. Heydt
Posts: 13057
Joined: Fri Mar 09, 2012 7:36 pm
Location: Vallejo, CA (US)

Re: How to remove the black border?

Sun Aug 18, 2019 5:16 am

I would suggest checking the *entire* contents of config.txt. If a command appears in it more than once, the final effect will be that of the last occurrence. It's pretty easy, when adding things at the end to override a previous version of the same directive and then if you change the earlier copy, wonder why it didn't work.

Yodhan
Posts: 3
Joined: Wed Dec 18, 2019 2:39 pm

Re: How to remove the black border?

Sat Jun 06, 2020 3:05 pm

I was also having the same problem at the beginning. I tried various method , after I made a change in display settings. it worked for me.
check this article. https://www.hackerstec.com/raspberry-pi ... eshooting/
It has a tutorial on how to change screen settings and remove black border

eddykacak
Posts: 1
Joined: Mon Jun 15, 2020 7:10 am

Re: How to remove the black border?

Mon Jun 15, 2020 7:15 am

Hi all, I registered just to post this.

Try disable this line = #hdmi_safe=1

Worked for me.

User avatar
trezhunter
Posts: 1
Joined: Fri Jul 10, 2020 3:16 am

Re: How to remove the black border?

Fri Jul 10, 2020 3:20 am

You have conflicting parameters in your config.txt.

You can't disable overscan, AND try to use overscan settings.
Comment disable_overscan=1 back out again.. Just use the overscan settings.

As another user mentioned, black borders mean you need to use negative numbers.

Try something like:
overscan_left=-50
overscan_right=-50
overscan_top=-50
overscan_bottom=-50

then reboot..

Return to “General discussion”