jlazkano
Posts: 14
Joined: Wed Nov 13, 2013 8:19 pm

NFS server in Raspbian

Tue Aug 22, 2017 6:44 pm

Hello,

I have a Raspberry Pi device to serve some multimedia content in the LAN, I use NFS for it. The problem is that it doesn't work for me out of the box. It happens same in Jessie and Stretch.

I need to add this line in "/etc/rc.local" file:

Code: Select all

echo 5
systemctl enable rpcbind
/etc/init.d/rpcbind restart
/etc/init.d/nfs-kernel-server restart
Is possible to fix it?

Kind regards.

User avatar
chrisoh
Posts: 217
Joined: Sun Dec 06, 2015 8:50 pm
Location: Essex, UK

Re: NFS server in Raspbian

Tue Aug 22, 2017 8:34 pm

jlazkano wrote:
Tue Aug 22, 2017 6:44 pm

Code: Select all

echo 5
systemctl enable rpcbind
/etc/init.d/rpcbind restart
/etc/init.d/nfs-kernel-server restart
Curious if there's any further updates on this also.
Sounds like you've tested Stretch to no avail, bit dissapointing.
By 'echo' I presume you mean 'sleep' and is enabling rpcbind necessary? I've only included the service restarts in rc.local (no sleep) and its been functioning fine (4.9.35-v7+).
Raspberry Pi 3 model B Idle @ 250mA
  • HDMI +200mA
  • Minecraft 1.9 Server +100mA
  • 2.4Ghz dongle +20mA

jlazkano
Posts: 14
Joined: Wed Nov 13, 2013 8:19 pm

Re: NFS server in Raspbian

Wed Aug 23, 2017 10:04 am

Thanks for the reply,

Yes, it is "sleep" and not "echo".

I am going to try just restarting the NFS.

Could we debug it? This is not happens in Debian "normal" servers.

Kind regards.

Return to “Raspbian”