jeebo
Posts: 69
Joined: Tue Mar 28, 2017 3:55 pm

USB HDD wont auto mount

Fri May 26, 2017 10:26 am

Hi All,

I have my pi home server setup, but seem to be having considerable problems getting it to automount at boot.

I have changed the /etc/fstab file as so:

Code: Select all


proc            /proc           proc    defaults          0       0
PARTUUID=29469a15-01  /boot           vfat    defaults          0       2
PARTUUID=29469a15-02  /               ext4    defaults,noatime  0       1
/dev/sda1/      /Media/pHDD_Other       ntfs-3g defaults,nofail 0       0
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that
if I try to mount the device manually:

Code: Select all

mount -t auto /dev/sda1 /media/pHDD_Other
it works until I reboot the Pi.

Basically, its running Samba which when the drive is mounted, I can connect to the Pi from another device and can access it as a file server. Unfortunately though, it needs that manual intervention after boot to get it to work.

Can anyone advise the potential reason for this?

fred44nl
Posts: 292
Joined: Sat Jun 25, 2016 11:59 am
Location: Scharendijke, NL

Re: USB HDD wont auto mount

Fri May 26, 2017 10:53 am

is the usb-hdd truly formatted with ntfs ??
or is it ext4 ??

you have proc and sda1 both on "0" (last char on the line)
not sure if that's really a problem :)
headless RPi 3B running from usbhdd.

User avatar
RaTTuS
Posts: 10498
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: USB HDD wont auto mount

Fri May 26, 2017 11:05 am

/proc should be 0 0
/dev/sda1 should be 0 1 possibly with an auto in it also ...
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

User avatar
thagrol
Posts: 1981
Joined: Fri Jan 13, 2012 4:41 pm
Location: Darkest Somerset, UK
Contact: Website

Re: USB HDD wont auto mount

Tue May 30, 2017 6:09 pm

What's the output of

Code: Select all

sudo mount -t ntfs-3g /dev/sda1 /media/pHDD_Other
with the drive unmounted and

Code: Select all

mount | grep sda1
after mounting manually as above?
Attempts to contact me outside of thes forums will be ignored unless signed in triplicate, sent in, sent back, queried, lost, found, subjected to public enquiry, lost again, and finally buried in soft peat for three months and recycled as firelighters

Return to “Advanced users”