Nathalia21
Posts: 117
Joined: Thu Nov 10, 2016 9:35 am

Installing 3G modem

Sat Apr 08, 2017 6:59 am

I try to install new generic 3G modem. I cannot use MiFi/WiFi because it's so flimsy.
HSDPA USB STICK SIM Modem 7.2Mbps 3G Wireless USB dongle EDGE/ GSM 850/900/1800/1900MHz HSDPA/ UMTS (2100MHz)
Brand:HDSPA
Service Supported:MTS/ HSDPA/GSM
Band:2G: EDGE/ GSM 850/900/1800/1900MHz.
3G: HSDPA/ UMTS (2100MHz)
OS Supported:Windows2000/XP/Vista/Windows7/Windows8/Android Operating
Install Disc:Built-in Driver, automatic installation
HSUPA network always-on, users maintain contact with the network at any time
Support hot-swappable,plug-and-play
https://www.thefanclub.co.za/how-to/how ... and-wvdial

Installed NOOBS 2.3 then booted and sudo apt-get update, sudo apt-get upgrade

Code: Select all

sudo apt-get update
sudo apt-get install ppp usb-modeswitch wvdial
Connected modem and modem led pulsates slowly

Code: Select all

lsusb —->05c6:1000
sudo reboot (modem connected)
lsusb —->05c6:1000 (still same number)

Code: Select all

cd /tmp
tar -xzvf /usr/share/usb_modeswitch/configPack.tar.gz 05c6\:1000 (used here 1000 since it don’t change)
--> No such file or directory

So i peeked in to configPack and there are these 05c6 files:
05c6:1000:sVe=GT
05c6:1000:sVe=Option
05c6:1000:uMa=AnyDATA
05c6:1000:uMa=CELOT
05c6:1000:uMa=Co.,Ltd
05c6:1000:uMa=DGT
05c6:1000:uMa=Option
05c6:1000:uMa=SAMSUNG
05c6:1000:uMa=SSE
05c6:1000:uMa=StrongRising
05c6:1000:uMa=Vertex
I tried first one (GT) and got error again.

Code: Select all

tar -xzvf /usr/share/usb_modeswitch/configPack.tar.gz 05c6\:1000:sVe=GT
Copied manually below text from first GT to /etc/usb_modeswitch.conf but changed numbers to 05c6 and 1000
# Option GlobeTrotter GX0201
TargetVendor=0x05c6
TargetProduct=0x1000
MessageContent=“55534243123456780000000000000601000000000000000000000000000000”
NeedResponse=1

Code: Select all

sudo nano /etc/wvdial.conf
[Dialer 3gconnect]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"IP”,”internet"
Stupid Mode = 1
Modem Type = Analog Modem
ISDN = 0
Phone = *99#
Modem = /dev/gsmmodem
Username = { }
Password = { }
Baud = 460800
Above phone number and “internet” is correct for my setup

Code: Select all

sudo usb_modeswitch -c /etc/usb_modeswitch.conf —-> No default vendor/product ID given. Abort
wvdial 3gconnect —-> cannot open/dev/modem: no such file or directory
I tried this but still same number 1000:
Most modems have two modes, the USB mode and a modem mode. The modem is detected differently if plugged in on a soft reboot vs hard reboot. Try booting the Pi without the modem plugged in. Then plug it in, wait a 10 seconds and the do the lsusb. Usually this is the usb mode. Then with reboot with sudo reboot, this will make sure the modem is powered on the reboot and usb modeswitch should do the switching to modem mode. Check the numbers again now with lsusb.
Error message : Cannot open /dev/gsmmodem: no such file or directory
Solution : change the “Modem=” line in  /etc/wvdial.conf , with the appropiate device. You can find that out by unpluging and pluging in the USB and checking dmesg. 

Code: Select all

dmesg | tail -n 20 | grep tty
This only finds my keyboard so i cannot change "Modem=" line.

This also fails:
I used it for my Raspberry PI. I changend the following info in the usb_modeswitch.conf file to activate the /dev/ttyUSB0 serial port modem DisableSwitching=0 DefaultVendor=0x12d1 DefaultProduct=0x1436 MessageContent="55534243123456780000000000000011062000000100000000000000000000"

fruitoftheloom
Posts: 18556
Joined: Tue Mar 25, 2014 12:40 pm

Re: Installing 3G modem

Sat Apr 08, 2017 3:17 pm

adieu

My other Computer is an Asus CS10 ChromeBit

Nathalia21
Posts: 117
Joined: Thu Nov 10, 2016 9:35 am

Re: Installing 3G modem

Sat Apr 15, 2017 11:37 am

fruitoftheloom wrote:SAKIS3G software may suffice ??

https://github.com/Trixarian/sakis3g-so ... /README.md
Thanks. Okay i just reinstalled Raspbian 50th time to try to get internet access via 3G.

https://github.com/Trixarian/sakis3g-so ... /README.md

installed raspbian 2.3
sudo apt-get update
sudo apt-get upgrade
boot

sudo apt-get install libusb-1.0-0-dev
sudo cp /usr/include/libusb-1.0/libusb.h /usr/include
git clone https://github.com/Trixarian/sakis3g-source.git
cd sakis3g-source
./compile
./compile embedded
./compile stripped
sudo cp build/sakis3gz /usr/bin/sakis3g

lsusb
>05c6:1000 Qualcomm, Inc. Mass Storage Device

It shows always as Mass Storage Device 05c6:1000

reboot

sakis3g

I’m not sure what i should choose in these dialogs:

choosed Connect with 3G

USB device

Qualcomm CDMA Technologies MSM

>Failed to connect

If i choose More options

Only switch modem (if applicable)

>Modem switched

Connect with 3G

>Failed to connect

Only prepare modem (Setup + PIN unlock + Register Network + Update HAL)

>Failed to prepare modem

Only setup modem (Switch + Load module + Setup tty)

>Failed to setup modem

If i choose DWC OTG Controller

>Failed to detect driver of interface 0

dmesg | tail -n 20 | grep tty
>input: apple wireless keyboard as…

Thanks

qwg
Posts: 1
Joined: Fri Jul 21, 2017 8:14 am

Re: Installing 3G modem

Fri Jul 21, 2017 8:41 am

2 years later but google had you indexed; so I'll reply to this post as I just solved my issue.
Install the required packages

Code: Select all

sudo apt-get update
sudo apt-get install ppp usb-modeswitch wvdial
Identify your modem

Code: Select all

$ lsusb
Bus 001 Device 009: ID 05c6:1000 Qualcomm, Inc. Mass Storage Device 
Switch the Mode from Mass Storage Device to 3G Modem

Code: Select all

$ sudo usb_modeswitch -W -v 05c6 -p 1000 -K
Check for changes by running lsusb again, if successful you should now see a new device ID as below:

Code: Select all

$ lsusb
Bus 001 Device 006: ID 05c6:6000 Qualcomm, Inc. Siemens SG75
. . .

Now to make it switch automatically using Udev
Create a rule

Code: Select all

 nano  /etc/udev/rules.d/05c6\:1000.rules
Put the following line into the empty file; It says if you see this USB device with these properties run the command we used above to switch modes from USB to 3G Modem:

Code: Select all

ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="1000", RUN+="/usr/sbin/usb_modeswitch -W -v 05c6 -p 1000 -K"
Save the file and reboot.
Subsequent hot plugs should see the device attached as a USB 3G modem

This guy's site helped a lot:
https://myopenhab.wordpress.com/

I followed a few non debian/raspbian instructions but their paths to the usb_modeswitch were different.
Hope this helps someone . . .

HallMark
Posts: 8
Joined: Fri Sep 29, 2017 11:18 am

Re: Installing 3G modem

Fri Sep 29, 2017 11:20 am

qwg wrote:
Fri Jul 21, 2017 8:41 am
2 years later but google had you indexed; so I'll reply to this post as I just solved my issue.
Install the required packages

Code: Select all

sudo apt-get update
sudo apt-get install ppp usb-modeswitch wvdial
Identify your modem

Code: Select all

$ lsusb
Bus 001 Device 009: ID 05c6:1000 Qualcomm, Inc. Mass Storage Device 
Switch the Mode from Mass Storage Device to 3G Modem

Code: Select all

$ sudo usb_modeswitch -W -v 05c6 -p 1000 -K
Check for changes by running lsusb again, if successful you should now see a new device ID as below:

Code: Select all

$ lsusb
Bus 001 Device 006: ID 05c6:6000 Qualcomm, Inc. Siemens SG75
. . .

Now to make it switch automatically using Udev
Create a rule

Code: Select all

 nano  /etc/udev/rules.d/05c6\:1000.rules
Put the following line into the empty file; It says if you see this USB device with these properties run the command we used above to switch modes from USB to 3G Modem:

Code: Select all

ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="1000", RUN+="/usr/sbin/usb_modeswitch -W -v 05c6 -p 1000 -K"
Save the file and reboot.
Subsequent hot plugs should see the device attached as a USB 3G modem

This guy's site helped a lot:
https://myopenhab.wordpress.com/

I followed a few non debian/raspbian instructions but their paths to the usb_modeswitch were different.
Hope this helps someone . . .
Hi,
This is working like charm. But I have noticed that it's still not creating ttyusb0 and all ports. what should be problem with it?

jaron
Posts: 1
Joined: Mon Dec 11, 2017 10:43 am

Re: Installing 3G modem

Mon Dec 11, 2017 10:46 am

qwg wrote:
Fri Jul 21, 2017 8:41 am
2 years later but google had you indexed; so I'll reply to this post as I just solved my issue.
Install the required packages

Code: Select all

sudo apt-get update
sudo apt-get install ppp usb-modeswitch wvdial
Identify your modem

Code: Select all

$ lsusb
Bus 001 Device 009: ID 05c6:1000 Qualcomm, Inc. Mass Storage Device 
Switch the Mode from Mass Storage Device to 3G Modem

Code: Select all

$ sudo usb_modeswitch -W -v 05c6 -p 1000 -K
Check for changes by running lsusb again, if successful you should now see a new device ID as below:

Code: Select all

$ lsusb
Bus 001 Device 006: ID 05c6:6000 Qualcomm, Inc. Siemens SG75
. . .

Now to make it switch automatically using Udev
Create a rule

Code: Select all

 nano  /etc/udev/rules.d/05c6\:1000.rules
Put the following line into the empty file; It says if you see this USB device with these properties run the command we used above to switch modes from USB to 3G Modem:

Code: Select all

ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="1000", RUN+="/usr/sbin/usb_modeswitch -W -v 05c6 -p 1000 -K"
Save the file and reboot.
Subsequent hot plugs should see the device attached as a USB 3G modem

This guy's site helped a lot:
https://myopenhab.wordpress.com/

I followed a few non debian/raspbian instructions but their paths to the usb_modeswitch were different.
Hope this helps someone . . .

God bless you, kind soul. I have been struggling with this exact issue and you just saved me from this hell.

Return to “Beginners”