misanthrophy
Posts: 5
Joined: Thu Jan 12, 2017 12:25 pm

Keine WLAN Verbindung

Wed Jan 18, 2017 6:20 pm

Hi,

ich habe seit heute meinen ersten Raspi und bin deshalb noch frisch in der Materie. Ich wuerde meinen Pi 3B gerne per Wifi in mein Netzwerk integrieren und nicht mehr per lan. Die Lan Verbindung klappt sofort, aber ueber wifi krieg ich ihn nicht verbunden.

Ich habe diese Anleitung befolgt:

https://www.raspberrypi.org/documentati ... ess-cli.md

Es findet die Netzwerke (auch meines) Ich kann die wpa-supplicant Datei aendern. Diese sieht aktuell so aus:

Code: Select all

  GNU nano 2.2.6    File: /etc/wpa_supplicant/wpa_supplicant.conf               

country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
    ssid=„SSID“
    psk="PASSWORD"
}
Passwort besteht nur aus Groß-/Kleinbuchstaben und Zahlen, aber 50 Zeichen lang mit WPA2 Verschluesselung.

Wenn ich danach ifconfig wlan0 uebers Terminal pruefe kommt nur:

Code: Select all

[email protected]:~ $ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr b8:27:eb:76:14:2c  
          inet6 addr: fe80::c5b0:dc3a:4769:9473/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:11 errors:0 dropped:11 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2700 (2.6 KiB)  TX bytes:0 (0.0 B)
Auch der Versuch mit statischer IP Adresse bringt keine Aendernung. ifdown wlan0 ifup wlan0 bringt auch alles nichts.

Da der Raspi nur uebers terminal gesteuert wird, ohne UI, hab ich leider keine anderen Alternativen.

Ich hoffe mir kann jemand helfen!

User avatar
mline
Posts: 1295
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: Keine WLAN Verbindung

Wed Jan 18, 2017 8:31 pm

Wenn ich nicht irre müsste das mindestens so aussehen:

Code: Select all

  GNU nano 2.2.6    File: /etc/wpa_supplicant/wpa_supplicant.conf               

country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
    ssid="SSID"
    key_mgmt=WPA-PSK
    psk="PASSWORD"
}
Außerdem achte auf die Anführungszeichen. Bei der SSID waren die es die falschen: „SSID“
<~~>

misanthrophy
Posts: 5
Joined: Thu Jan 12, 2017 12:25 pm

Re: Keine WLAN Verbindung

Wed Jan 18, 2017 10:17 pm

Hi mline,

danke für die Antwort, leider hilft auch das hinzufuegen der zusaetzlichen Zeile nichts. Die Anfuehrungszeichen hab ich auch nochmal korrigiert. Immer noch ohne Erfolg.

Egal wie ich das Ganze eintrage, es endet immer wieder damit:

Code: Select all

[email protected]:~ $ sudo ifdown wlan0
ifdown: interface wlan0 not configured

lbog
Posts: 177
Joined: Sun Mar 06, 2016 9:44 am

Re: Keine WLAN Verbindung

Wed Jan 18, 2017 10:27 pm

misanthrophy wrote:

Code: Select all

  GNU nano 2.2.6    File: /etc/wpa_supplicant/wpa_supplicant.conf               

country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
    ssid=„SSID“
    psk="PASSWORD"
}
Befindet sich der PI3 in GB oder in DE?

Versuch mal als Test, mit:

Code: Select all

sudo killall wpa_supplicant
sudo wpa_supplicant -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf -d
im debug mode und poste danach die Ausgaben von:

Code: Select all

ps aux | grep -i [w]pa
iwconfig wlan0

misanthrophy
Posts: 5
Joined: Thu Jan 12, 2017 12:25 pm

Re: Keine WLAN Verbindung

Wed Jan 18, 2017 10:51 pm

Believe it or not, aber ich hab den Fehler gefunden. Und zwar habe ich zwischen update_config=1 und network eine Leerzeile eingefuegt. Nun konnte meine Eingabe gelesen werden und funktioniert :)

Return to “Deutsch”