Binson
Posts: 8
Joined: Wed Jul 04, 2012 10:27 pm
Location: near Brussels, Belgium

Keyboard remapping broken on X-windows ?

Mon Sep 03, 2012 4:56 am

Hi All !

As i was preparing for may first attempt at compiling anything ever * i remarked that my a's came out as q's . After some searching on this forum i hit on a subject** and posted this :
Quote/
Am having the same problem as Johann : Belgian keymap (azerty iso qwerty, etc) is used in the console, but as soon as i use X lxde the mapping reverts to qwerty . This is on a fresh install of the official raspbian, with latest updates of firmware, software et al .

I also installed an sd card with pisces MATE R2, did all the updates and upgrades, and Bingo! Qwerty in the GUI . In MATE one can set the keymap in the preferences, but this shows the be(lgian) map duly set .

I can't recall having this problem when i first installed the official raspbian image, few hours after it came out, so it's got to be one of the upgrades to the x innards thats the culprit, hence this mayday call .
end quote/

I have rewritten the MATE sd-card with an original raspbian image and can confirm remapping works correctly in an un-upgraded X-lxde session on my machine . I can keep this image for now to run some upgrade tests, but don't know where to start . The fully upgraded wheezy armel image that i also have does not exhibit this flaw btw .

Thanks for reading .

Binson
=

* want to compile Synergy 1.4.10 on PI to be able to use it as server with my Macbook as client, but thats andother story

**http://www.raspberrypi.org/phpBB3/viewt ... 42#p163542

thsBavR10
Posts: 233
Joined: Sat Jul 21, 2012 3:11 pm

Re: Keyboard remapping broken on X-windows ?

Mon Sep 03, 2012 3:49 pm

I have the same problem,
(keyboard mapping is in gnome different to bash, qerty istead of qwertz (german)),
and i can't find an option in gnome to change the remapping. there is no option in settings.
Has anybody made an custom xorg.conf or an other solution?

Thanks!

thsBavR10
Posts: 233
Joined: Sat Jul 21, 2012 3:11 pm

Re: Keyboard remapping broken on X-windows ?

Mon Sep 03, 2012 4:30 pm

I've found an workaround:
inserting the line

Code: Select all

setxkbmap -option grp:ctrl_shift_toggle,grp_led:scroll  de,de
in the file /etc/X11/xinit/xinitrc
(before calling . /etc/X11/Xsession) helps.
You have only to insert the mapping at the end of the line.

Binson
Posts: 8
Joined: Wed Jul 04, 2012 10:27 pm
Location: near Brussels, Belgium

Re: Keyboard remapping broken on X-windows ?

Tue Sep 04, 2012 1:56 am

Hi All !

Thanks thsBavR10 for putting me on the right track .

The file you mentioned did not have any entries so i just added in

setxkbmap be

and it worked !!!

Forcing it in this way does not explain what, or how, it got broken in the first place though .
Hmmm ...

Bye for now .

Binson
=

thsBavR10
Posts: 233
Joined: Sat Jul 21, 2012 3:11 pm

Re: Keyboard remapping broken on X-windows ?

Tue Sep 04, 2012 10:22 am

I am pleased that it has helped.

But this is, as you wrote, only a workaround, not a final solution.
Something has broken between the individual changes at the console to locale and keyboard-mapping and so on,
and the X11 / LXDE.
Don't know, where to adress this error (maybe in the rasbian board).

Sleep Mode zZ
Posts: 319
Joined: Sun Aug 19, 2012 5:56 am
Location: Finland

Re: Keyboard remapping broken on X-windows ?

Tue Sep 04, 2012 10:33 am

I can confirm this problem. I'm not sure when I last time typed something in X, I noticed this only now.

brutus
Posts: 2
Joined: Thu Nov 01, 2012 11:13 pm

Re: Keyboard remapping broken on X-windows ?

Fri Nov 30, 2012 9:32 am

Same problem for me, mz swiss kezboard work fine under the standard bash but switch to Uk or US kezboard as soon as I run LXDE, as zou can see :)

brutus
Posts: 2
Joined: Thu Nov 01, 2012 11:13 pm

Re: Keyboard remapping broken on X-windows ?

Fri Nov 30, 2012 12:37 pm

thsBavR10 wrote:I've found an workaround:

Code: Select all

setxkbmap -option grp:ctrl_shift_toggle,grp_led:scroll  de,de
Thanks, it work for me except that I used the Swiss - French keyboard
setxkbmap -option 'grp:ctrl_shift_toggle,grp_led:scroll' 'ch(fr)'

ausinch
Posts: 4
Joined: Thu Dec 20, 2012 10:26 pm

Re: Keyboard remapping broken on X-windows ?

Fri Dec 21, 2012 11:50 pm

My problem is my Swiss German does work right from the start.
BUT the Alt Gr button will not work - so I cant get a backslash or AT symbol.

I have run "sudo raspi-config" and set the k/b again (configure_keyboard) but to no avail

thsBavR10
Posts: 233
Joined: Sat Jul 21, 2012 3:11 pm

Re: Keyboard remapping broken on X-windows ?

Sat Dec 22, 2012 11:25 am

AltGr is working for me, both on commandline and in X11.
What does your /etc/default/keyboard contain regarding XKBMODEL ?

Code: Select all

XKBMODEL="pc105"
?

I also have this file:

Code: Select all

cat /etc/X11/xorg.conf.test : 
# only sectionInputDevice for testing
#
Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver	"kbd"
	Option	"XkbRules"	"xorg"
	Option	"XkbModel"	"pc105"
	Option	"Xkblayout"	"de"
EndSection

ausinch
Posts: 4
Joined: Thu Dec 20, 2012 10:26 pm

Re: Keyboard remapping broken on X-windows ?

Mon Dec 24, 2012 11:05 am

My Alt Gr key works now.
I didnt do anything to get it going it just started working. I did change the power supply on the pi to a hub and connected the wireless USB transmitter to the hub, it could have been a power issue.

Here's my config file anyway:

Code: Select all

cat /etc/default/keyboard 
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="logicda"
XKBLAYOUT="ch"
XKBVARIANT=""
XKBOPTIONS="lv3:ralt_switch,terminate:ctrl_alt_bksp"

BACKSPACE="guess"

Return to “Troubleshooting”

Who is online

Users browsing this forum: JustinL and 69 guests