User avatar
RaTTuS
Posts: 9630
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

building Xbmc problems

Wed Aug 29, 2012 11:06 am

with the latest raspbian
following
http://www.raspbian.org/RaspbianXBMC
during the make I get
CPP xbmc/cores/dvdplayer/DVDPlayerVideo.o
In file included from /home/pi/xbmc-rbp/xbmc/rendering/RenderSystem.h:30:0,
from /home/pi/xbmc-rbp/xbmc/rendering/gles/RenderSystemGLES.h:29,
from /home/pi/xbmc-rbp/xbmc/windowing/egl/WinSystemGLES.h:27,
from /home/pi/xbmc-rbp/xbmc/windowing/WindowingFactory.h:40,
from DVDPlayerVideo.cpp:24:
/home/pi/xbmc-rbp/xbmc/utils/StdString.h:1605:14: note: the mangling of âva_listâ has changed in GCC 4.4
In file included from /home/pi/xbmc-rbp/xbmc/windowing/egl/WinEGLPlatform.h:28:0,
from /home/pi/xbmc-rbp/xbmc/windowing/egl/WinSystemGLES.h:29,
from /home/pi/xbmc-rbp/xbmc/windowing/WindowingFactory.h:40,
from DVDPlayerVideo.cpp:24:
/home/pi/xbmc-rbp/xbmc/windowing/egl/WinEGLPlatformRaspberryPI.h:61:3: error: âEGL_DISPMANX_WINDOW_Tâ does not name a type
make[1]: *** [DVDPlayerVideo.o] Error 1
make: *** [xbmc/cores/dvdplayer/DVDPlayer.a] Error 2

any clues as to what I have done wrong?
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5105
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: building Xbmc problems

Wed Aug 29, 2012 11:10 am

You're picking up egl.h from mesa version in /usr/include rather than desired version from /opt/vc/include.

You need to uninstall mesa gl libs:
libegl1-mesa-dev libgl1-mesa-dev libgles2-mesa-dev

(the other mesa utility libs are okay).

The instructions should be updates (as I've requested...)

User avatar
RaTTuS
Posts: 9630
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: building Xbmc problems

Wed Aug 29, 2012 11:14 am

cheers dom,
sudo apt-get remove libegl1-mesa-dev libgl1-mesa-dev libgles2-mesa-dev
then re-configure and rebuild?
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5105
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: building Xbmc problems

Wed Aug 29, 2012 11:33 am

RaTTuS wrote:cheers dom,
sudo apt-get remove libegl1-mesa-dev libgl1-mesa-dev libgles2-mesa-dev
then re-configure and rebuild?
Yes, that sounds right.

User avatar
RaTTuS
Posts: 9630
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: building Xbmc problems

Thu Aug 30, 2012 7:26 am

Ok that has built it all ,
now I need to see why I don't have any control over the beast - keyboard does not do anything ...
I'll be back ;-p
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

User avatar
PeterO
Posts: 3662
Joined: Sun Jul 22, 2012 4:14 pm

Re: building Xbmc problems

Thu Aug 30, 2012 6:57 pm

Following the instructions at http://www.raspbian.org/RaspbianXBMC, using up to date Raspian as the starting point,

I'm seeing lots of warnings during the build: "swp{b} use is deprecated for this architecture"

Is that normal or have a made a mistake in following the instructions ?

PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),Aeromodelling,1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

User avatar
RaTTuS
Posts: 9630
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: building Xbmc problems

Fri Aug 31, 2012 7:35 am

those warnings are normal
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

User avatar
PeterO
Posts: 3662
Joined: Sun Jul 22, 2012 4:14 pm

Re: building Xbmc problems

Fri Aug 31, 2012 7:50 pm

OK, all built and running, except when I put a Disk (DVD or CD) into the drive it is recognised but when I try to play it I get a pop-up telling me to put the disc in the drive, where it is already !

I see a few other posts about this on various forums but no solutions.

PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),Aeromodelling,1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

cybershot
Posts: 2
Joined: Sun Mar 17, 2013 7:22 pm

Re: building Xbmc problems

Sun Mar 17, 2013 9:35 pm

Hi at all!

I've the same problem with Raspian Wheezy:
=========================================================
CPP xbmc/cores/dvdplayer/DVDPlayerVideo.o
In file included from /usr/include/bcm_host.h:50:0,
from /home/pi/xbmc-rbp/xbmc/linux/DllBCM.h:34,
from /home/pi/xbmc-rbp/xbmc/windowing/egl/WinEGLPlatformRaspberryPI.h:31,
from /home/pi/xbmc-rbp/xbmc/windowing/egl/WinEGLPlatform.h:28,
from /home/pi/xbmc-rbp/xbmc/windowing/egl/WinSystemGLES.h:29,
from /home/pi/xbmc-rbp/xbmc/windowing/WindowingFactory.h:40,
from DVDPlayerVideo.cpp:24:
/usr/include/interface/vmcs_host/vcgencmd.h:33:27: fatal error: vchost_config.h: File o directory non esistente
compilation terminated.
make[1]: *** [DVDPlayerVideo.o] Error 1
make: *** [xbmc/cores/dvdplayer/DVDPlayer.a] Error 2
I had removed libegl1-mesa-dev libgl1-mesa-dev libgles2-mesa-dev
and I make a swapfile
But it show the same error..
who's can help to me?
Thanks.
Regards.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5105
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: building Xbmc problems

Mon Mar 18, 2013 11:23 am

cybershot wrote: I had removed libegl1-mesa-dev libgl1-mesa-dev libgles2-mesa-dev
and I make a swapfile
But it show the same error..
who's can help to me?
Thanks.
Regards.
Those instructions are very old. They describe building a version of xbmc from a tree that hasn't been updated for 8 months.
xbmc is pretty hard to build. I'd recommend using a pre-built distribution (OpenELEC/Raspbmc) which tend to run better than trying to run inside raspbian.

If you really want to run it under raspbian you can install a deb file:
http://elinux.org/RPi_XBMC#Installing_from_a_.deb

If you must build from source, you can try here:
http://www.raspbmc.com/wiki/technical/building-xbmc/

cybershot
Posts: 2
Joined: Sun Mar 17, 2013 7:22 pm

Re: building Xbmc problems

Wed Mar 20, 2013 10:04 pm

yes,yes,yesss!!
I follow your first tip and I'm made it!! I'm very glad :D :D
Tank you very much dom.

Return to “Media centres”

Who is online

Users browsing this forum: No registered users and 6 guests