hakna
Posts: 3
Joined: Mon May 23, 2016 8:06 am

Wifi rtl8812AU_8821AU AC1200

Mon May 23, 2016 8:18 am

Hello,

I have difficulties to install the module of my wifi adapter. You can get it
from: https://github.com/abperiasamy/rtl8812AU_8821AU_linux
or: http://www.tp-link.com/en/download/Arch ... tml#Driver

As advised, I've installed
linux-image-rpi-rpfv linux-headers-rpi-rpfv dkms build-essential bc
updated /boot/config.txt to

Code: Select all

ernel=vmlinuz-3.10-3-rpi
initramfs initrd.img-3.10-3-rpi followkernel
And updated the make file

I get the following error:

Code: Select all

root@raspberrypi:/home/pi/rtl8812AU_8821AU_linux-master# make
make ARCH=arm CROSS_COMPILE= -C /lib/modules/4.4.9+/build M=/home/pi/rtl8812AU_8821AU_linux-master  modules
make[1]: *** /lib/modules/4.4.9+/build: No such file or directory.  Stop.
Makefile:1049: recipe for target 'modules' failed
make: *** [modules] Error 2
I'm using the last version of raspbian which is:
May 2016 2016-05-10 Kernel version:4.4 RASPBIAN JESSIE LITE
I've tested to use rpi-source to get the right kernel headers without success.
I've also tested to install kernel headers
from: https://www.niksula.hut.fi/~mhiienka/Rp ... aders-rpi/
Also without success.
linux-headers-4.4.9+_4.4.9+-2_armhf.deb
linux-headers-4.4.9-v7+_4.4.9-v7+-2_armhf.deb

What else can I do? What I'm doing wrong?

hakna
Posts: 3
Joined: Mon May 23, 2016 8:06 am

Re: Wifi rtl8812AU_8821AU AC1200

Tue May 24, 2016 7:58 am

I tried to install a module compiled by MrEngman with no success.

MrEngman
Posts: 4060
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Wifi rtl8812AU_8821AU AC1200

Tue May 24, 2016 11:07 pm

hakna wrote:I tried to install a module compiled by MrEngman with no success.
What file did you download?

Looking at the info in your first post it looks like you need the driver for kernel 4.4.9+ #88x but it would help if you can post the output of command uname -a to identify the exact kernel version you are using.

You could try

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8812au-4.4.9-884.tar.gz
tar xzf 8812au-4.4.9-884.tar.gz
./install.sh
Using the command ./install.sh will install the driver.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

hakna
Posts: 3
Joined: Mon May 23, 2016 8:06 am

Re: Wifi rtl8812AU_8821AU AC1200

Wed May 25, 2016 11:13 am

Hello MrEngman,

This compiled module is working for my kernel.
Thank you very much for this.

As I will have to compile this module for other platform/kernel version I want to understand what I did wrong.

Here is the ouput when I try to cross-compile the module.
Everything seems to work file but I don't get any .ko file.

Code: Select all

[root@endpoint1 rtl8812AU_8821AU_linux]# make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- -C ../linux/
make: Entering directory `/root/src/linux'
  CHK     include/config/kernel.release
  CHK     include/generated/uapi/linux/version.h
  CHK     include/generated/utsrelease.h
make[1]: `include/generated/mach-types.h' is up to date.
  CHK     include/generated/bounds.h
  CHK     include/generated/timeconst.h
  CHK     include/generated/asm-offsets.h
  CALL    scripts/checksyscalls.sh
  CHK     include/generated/compile.h
  CHK     kernel/config_data.h
  Kernel: arch/arm/boot/Image is ready
  Kernel: arch/arm/boot/Image is ready
  Kernel: arch/arm/boot/zImage is ready
  Building modules, stage 2.
  MODPOST 1508 modules
make: Leaving directory `/root/src/linux'
[root@endpoint1 rtl8812AU_8821AU_linux]# ls
clean CONTRIBUTORS.md contributors.sh core dkms.conf fetch.sh hal ifcfg-wlan0 include Kconfig LICENSE Makefile os_dep README.md runwpa wlan0dhcp

deepblue
Posts: 2
Joined: Wed Sep 21, 2016 3:51 pm

Re: Wifi rtl8812AU_8821AU AC1200

Wed Sep 21, 2016 3:59 pm

i was unable to compile with the same error as above.

what i noticed was that the Makefile path ($KVER)/build was wrong in RPI section and changed it to ($KVER)/build/linux

after that i could run the make.

Return to “Beginners”