Raymond_S
Posts: 6
Joined: Wed Jul 03, 2013 9:49 pm

[RPi 3] Bluetooth not working

Tue Mar 15, 2016 7:26 pm

Hi,

If have a problem with my Raspberry Pi 3, I have installed a clean Raspbian Jessie from 2016-02-26-raspbian-jessie.zip.

Wifi is working, but I can't get bluetooth working.

When I run hciconfig (with or without root) I get nothing.

My Pi has a PiCoolFan (https://www.pi-supply.com/product/picoo ... 6834e7a283) on it's GPIO headers (pins 1 - 6) and on pins 7 & 8 a Pi-Supply is connected.
A KVM-Switch is connected trough a powered USB-hub, the power for Pi itself comes from a 2,5 A powersupply.

I have installed Bleuz and Blueman and both don't see an Bluetooth device.

But when i connect a USB-Bluetooth-dongle to the powered USB-hub, that dongle is working, but the onboard Bluetooth, I can't seem to get it working.

So can someone please help me out?

User avatar
MarkHaysHarris777
Posts: 1820
Joined: Mon Mar 23, 2015 7:39 am
Location: Rochester, MN
Contact: Website

Re: [RPi 3] Bluetooth not working

Tue Mar 15, 2016 7:36 pm

Read through this post and see if its helpful:

viewtopic.php?f=28&t=138145

... but, don't take the first poster's advice... read through the whole thing.


:geek:
marcus
:ugeek:

User avatar
Douglas6
Posts: 4902
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: [RPi 3] Bluetooth not working

Tue Mar 15, 2016 7:50 pm

A fresh install of Raspbian 2016-02-26 will include BlueZ and it should start at boot. What are the results of

Code: Select all

hciconfig -a
and

Code: Select all

systemctl status bluetooth

Raymond_S
Posts: 6
Joined: Wed Jul 03, 2013 9:49 pm

Re: [RPi 3] Bluetooth not working

Tue Mar 15, 2016 8:08 pm

Douglas6 wrote:A fresh install of Raspbian 2016-02-26 will include BlueZ and it should start at boot. What are the results of

Code: Select all

hciconfig -a
and

Code: Select all

systemctl status bluetooth
I have a fresh install of Rasbian.
Output of

Code: Select all

hciconfig -a
is nothing ( fot comparision i als o did run it with the USB-Dongle and then i get info about the dongle, but nothing about the onboard version

output of

Code: Select all

systemctl status bluetooth
is:

Code: Select all

● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
   Active: active (running) since di 2016-03-15 20:47:25 CET; 13min ago
     Docs: man:bluetoothd(8)
 Main PID: 1010 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─1010 /usr/lib/bluetooth/bluetoothd
(This is without the USB-Dongle).

User avatar
Douglas6
Posts: 4902
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: [RPi 3] Bluetooth not working

Tue Mar 15, 2016 8:40 pm

The onboard Bluetooth should be recognized out-of-the-box. Bad part, maybe? I would re-install the latest Raspbian, and check with hciconfig before installing anything.

Raymond_S
Posts: 6
Joined: Wed Jul 03, 2013 9:49 pm

Re: [RPi 3] Bluetooth not working

Tue Mar 15, 2016 8:50 pm

Okay,

I found my problem, I prepared a new microsd card, but to test it, I had to open the case my Pi is build into, and I removed the PiCoolFan so fan was not hanging on its wires.

The onboard Bluetooth worked right away.
The I attached the PiCoolFan again, and no Bluetooth device was detected :?
The I removed the PiCoolFan again, and yes Bluetooth was working again.
Now I have inserted the first card, and guess what, Bluetooth is working (without the PiCoolFan)

So if people have trouble with the onboard Bluetooth, fist thing to try is to remove equipment attached to the GPIO-header.
PiCoolFan uses the first 6 pins, so i don know what the problem is yet, but without it, Bluetooth works.

Raymond_S
Posts: 6
Joined: Wed Jul 03, 2013 9:49 pm

Re: [RPi 3] Bluetooth not working

Tue Mar 15, 2016 8:52 pm

Douglas6 wrote:The onboard Bluetooth should be recognized out-of-the-box. Bad part, maybe? I would re-install the latest Raspbian, and check with hciconfig before installing anything.
As you posted this, i was also posting a reply, to bad the PiCoolFan is the problem.

User avatar
Douglas6
Posts: 4902
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: [RPi 3] Bluetooth not working

Tue Mar 15, 2016 9:10 pm

Glad you found the 'problem'. I'm not clear how the GPIOs could affect detection of the on-board Bluetooth (you should have enough power). Interesting.

User avatar
DougieLawson
Posts: 39562
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: [RPi 3] Bluetooth not working

Thu Mar 17, 2016 7:24 am

Start with sudo apt-get update && sudo apt-get upgrade && sudo reboot there's a replacement raspberrypi-bootloader package which includes new firmware for the RPi3B.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All fake doctors are on my foes list.

Return to “Troubleshooting”