cptwillem
Posts: 1
Joined: Sat Mar 12, 2016 11:33 am

Setting up Razberry on a Pi model 3B

Sun Mar 13, 2016 10:26 am

I had problems getting the Razberry Z-wave board to work with the new Raspberry model 3 B. After some major browsing I found a way to make it work. I thought I share;)

Hardware: Raspberry PI model 3 B and Razberry card on GPIO

Apparently the new BT port is blocking TTY communications on the PI3B. The temporary workaround is:

Update Raspbian to the latest:

sudo apt-get update
sudo apt-get upgrade


Update RPI3B firmware to the latest:

sudo apt-get install rpi-update
sudo rpi-update


After this: REBOOT

Disable BT on RPI3B:

Open the /boot/config.txt

sudo nano /boot/config.txt

At the end add the line:

dtoverlay=pi3-disable-bt

exit with ctrl-X, select Yes

After this: REBOOT

set the correct baudrate:

stty -F /dev/ttyAMA0 9600

Now you can restart or install your domotica package. I've tested this with latest releases of z-wave and domoticz

Hope this helps someone with the same problem!

Willem

briantilburgs
Posts: 1
Joined: Mon Mar 14, 2016 7:58 pm

Re: Setting up Razberry on a Pi model 3B

Tue Mar 15, 2016 8:35 am

THANKS!! Working for me! :D

Return to “HATs and other add-ons”