stisi
Posts: 2
Joined: Tue Jul 31, 2012 10:35 am

UVC UVCcapture Colour problems Logitech Pro9000

Thu Aug 02, 2012 8:31 pm

Hi,

I´m running the raspbian wheezy and have problems with my Logitech Pro9000 webcam.

when i take a picture with uvccapture (uvccapture -x960 -y720 -o../pics/test.jpg)
i get a very coloured blurry picture :
Image

I had the same problems with the logitech c270 before and thought it is the cam, so i changed to pro9000.

The strange is, after installing motion i had the normal good qualitiy pictures from my pro 9000,
but after a try with uvccapture it changed back to the bad colour.
Now, also motion has this bad colours, also a restart changed nothing.

It looks like uvccapture sets some bad parameters for my cam.


Has anybody a idea, or the same issue?

Thanks!

User avatar
pingu512
Posts: 64
Joined: Sun Apr 01, 2012 2:39 pm
Location: Chester
Contact: Website

Re: UVC UVCcapture Colour problems Logitech Pro9000

Sat Aug 11, 2012 1:49 pm

I'm using a Logitech C270 with the same issues, Everything works fine with motion, but uvccapture gives a very dark image
using uvccapture -v you can see that it defaults the camera to 255 for all the settings
I have tried uvccapture -B120 -C130 -S50 -G50 -v
Using these settings, sometimes I get a good image, others very dark.
I think this is a timing issue and the camera has not time to react to the settings, and it needs some futher investigation.
Motion worked fine for me on its own, but when added to a pi running my weather station software it pause the usb port, so I need a simpler capture like uvccapture

http://www.weather.dragontail.co.uk Running live from a Raspberry pi

User avatar
pingu512
Posts: 64
Joined: Sun Apr 01, 2012 2:39 pm
Location: Chester
Contact: Website

Re: UVC UVCcapture Colour problems Logitech Pro9000

Sun Aug 12, 2012 12:56 pm

The problem appear to be that the web cam does to sleep then does not react fast enough to new settings. To get round this I created a script that takes 2 pictures with a 5 second delay, the second overwriting the first

#!/bin/sh
cd /home/pi/uvccapture/output
uvccapture -v -S45 -B190 -C35 -G50 -x640 -y480 -osnap.jpg
sleep 5
uvccapture -v -S45 -B190 -C35 -G50 -x640 -y480 -osnap.jpg

This appears to work
h[url]ttp://www.weather.dragontail.co.uk/index.php?page=webcam[/url]

rogerdahl
Posts: 11
Joined: Thu Sep 06, 2012 10:19 pm

Re: UVC UVCcapture Colour problems Logitech Pro9000

Thu Oct 04, 2012 9:29 pm

Thank you -- this worked for me as well. Very helpful, and a good indicator for someone on where to start working on a real fix.

ccrome
Posts: 1
Joined: Thu Mar 31, 2016 6:16 pm

Re: UVC UVCcapture Colour problems Logitech Pro9000

Thu Mar 31, 2016 6:16 pm

Hey, that's works for my logitech C270 too! Thanks!

-Caleb

Return to “Troubleshooting”