svrsig
Posts: 134
Joined: Thu Nov 03, 2011 9:45 am
Contact: Website

PiZero clock speed on RISC OS

Wed Jan 06, 2016 11:21 am

The cpu speed appears to be stuck at 700MHz on RC14, even with Nov 2015 firmware and a 30-Dec-2015 RISC OS ROM image. What changes do I need to make please to config.txt to force the correct 1000MHz speed for the cpu please? Speed switching (SYS "Portable_Speed") is not implemented in the RISC OS kernel on the Pi.

fruitoftheloom
Posts: 16731
Joined: Tue Mar 25, 2014 12:40 pm

Re: PiZero clock speed on RISC OS

Wed Jan 06, 2016 1:47 pm

svrsig wrote:The cpu speed appears to be stuck at 700MHz on RC14, even with Nov 2015 firmware and a 30-Dec-2015 RISC OS ROM image. What changes do I need to make please to config.txt to force the correct 1000MHz speed for the cpu please? Speed switching (SYS "Portable_Speed") is not implemented in the RISC OS kernel on the Pi.
This thread discusses the Pi Zero config.txt settings for CPU etcetera

viewtopic.php?f=63&t=131297
Adieu

svrsig
Posts: 134
Joined: Thu Nov 03, 2011 9:45 am
Contact: Website

Re: PiZero clock speed on RISC OS

Wed Jan 06, 2016 9:10 pm

Many thanks for the help. I have adjusted the config.txt to:

Code: Select all

# bootcode.bin commit id 4a66b501473024c143c8c34fb670e009b6a8b8ff
# fixup.dat    commit id 47bd0f0f46bc053d8e21655e3a69c4a73ae19b41
# start.elf    commit id 47bd0f0f46bc053d8e21655e3a69c4a73ae19b41
fake_vsync_isr=1
framebuffer_swap=0
gpu_mem=48
init_emmc_clock=100000000
arm_freq=1000
gpu_freq=300
core_freq=400
sdram_freq=450
force_turbo=1
kernel=RISCOS.IMG
and all is well. It starts up in the RISC OS desktop, with fully functioning networking (or, if no internet is available in the same time but with no internet connection) in eleven seconds from power on and is running at 1000MHz. Excellent!

Return to “RISCOS”

Who is online

Users browsing this forum: No registered users and 1 guest