mikerr
Posts: 2826
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Chromecast ethernet PSU + pizero working !

Mon Jan 04, 2016 11:13 pm

Google sell a combined PSU and ethernet adaptor for the chromecast which works over a single micro usb....
https://store.google.com/product/ethern ... chromecast

Image

Raspbian recognises it and it all works out of the box.

Code: Select all

pi@pizero3:~ $ lsusb
Bus 001 Device 002: ID 0bda:8152 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@pizero3:~ $ lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=r8152, 480M
One cable to power and provide networking !

OK, so its a little expensive at £15....
https://store.google.com/product/ethern ... chromecast

Speed ? Pretty good too:

Code: Select all

pi@pizero3:~ $ iperf -c 192.168.0.62
------------------------------------------------------------
Client connecting to 192.168.0.62, TCP port 5001
TCP window size: 43.8 KByte (default)
------------------------------------------------------------
[  3] local 192.168.0.60 port 48478 connected with 192.168.0.62 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec   112 MBytes  94.2 Mbits/sec
Android app - Raspi Card Imager - download and image SD cards - No PC required !

User avatar
DougieLawson
Posts: 40167
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Chromecast ethernet PSU + pizero working !

Mon Jan 04, 2016 11:22 pm

This is easily the coolest thing I've seen all day. At £15 it's within a reasonable price range. My official WiFi dongle and the USB shim cost over £10.

Can it do IPv6? (Which is TWENTY years old today.)
Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All fake doctors are on my foes list.

Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

mikerr
Posts: 2826
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: Chromecast ethernet PSU + pizero working !

Mon Jan 04, 2016 11:29 pm

DougieLawson wrote:Can it do IPv6? (Which is TWENTY years old today.)
think so ?

Code: Select all

pi@pizero3:~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:e0:4c:36:26:26
          inet addr:192.168.0.60  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::7511:34ce:7acf:5ea9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:86485 errors:0 dropped:3 overruns:0 frame:0
          TX packets:18544 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5802972 (5.5 MiB)  TX bytes:237195938 (226.2 MiB)
Android app - Raspi Card Imager - download and image SD cards - No PC required !

mosespi
Posts: 508
Joined: Mon May 12, 2014 3:35 pm
Location: 34,-118
Contact: Website

Re: Chromecast ethernet PSU + pizero working !

Mon Jan 04, 2016 11:53 pm

That is neat! I'm surprised no one tried it before. I would glue the zero to the adapter and have me a ready to go IOT device!

If only if.. if only.. it had a 4 port USB hub, a full size HDMI, a CSI port, a DSI port, and one of those funky 4 pin audio/video jack thingies. I would gladly pay $35 for such a beast.. oh wait.. :lol:
Power problems? MoPower UPS for the Pi
http://www.allspectrum.com/mopower/

User avatar
DougieLawson
Posts: 40167
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Chromecast ethernet PSU + pizero working !

Mon Jan 04, 2016 11:54 pm

Now the question is can I sneak £15 past SWMBO without her noticing it.
Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All fake doctors are on my foes list.

Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

fruitoftheloom
Posts: 24473
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Chromecast ethernet PSU + pizero working !

Tue Jan 05, 2016 12:33 am

mikerr wrote:
Speed ? Pretty good too:

Code: Select all

pi@pizero3:~ $ iperf -c 192.168.0.62
------------------------------------------------------------
Client connecting to 192.168.0.62, TCP port 5001
TCP window size: 43.8 KByte (default)
------------------------------------------------------------
[  3] local 192.168.0.60 port 48478 connected with 192.168.0.62 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec   112 MBytes  94.2 Mbits/sec
This is very different to other results achieved using alternative 'Ethernet over USB'
Thinking outside the box is better than burying your head in the sand...

mikerr
Posts: 2826
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: Chromecast ethernet PSU + pizero working !

Tue Jan 05, 2016 12:41 am

fruitoftheloom wrote:
This is very different to other results achieved using alternative 'Ethernet over USB'
I know - it seems on a par or better than my b+ ethernet.
Android app - Raspi Card Imager - download and image SD cards - No PC required !

BMS Doug
Posts: 3898
Joined: Thu Mar 27, 2014 2:42 pm
Location: London, UK

Re: Chromecast ethernet PSU + pizero working !

Tue Jan 05, 2016 8:17 am

This £10 3 port USB Hub with Ethernet works on a Pi0, I haven't tried powering the Hub yet (It didn't come with a power adapter).
Image

It's about the same size as a Pi0 (maybe slightly larger), I'll take a photo of it tonight.
Doug.
Building Management Systems Engineer.

fruitoftheloom
Posts: 24473
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Chromecast ethernet PSU + pizero working !

Tue Jan 05, 2016 8:23 am

BMS Doug wrote:This £10 3 port USB Hub with Ethernet works on a Pi0, I haven't tried powering the Hub yet (It didn't come with a power adapter).

It's about the same size as a Pi0 (maybe slightly larger), I'll take a photo of it tonight.
Yes but not the same idea of what was being discussed by "mikerr" which is a combined power (back powering) /internet input, there are many USB/Ethernet Hubs being mentioned in other posts
Thinking outside the box is better than burying your head in the sand...

User avatar
karrika
Posts: 1255
Joined: Mon Oct 19, 2015 6:21 am
Location: Finland

Re: Chromecast ethernet PSU + pizero working !

Tue Jan 05, 2016 8:39 am

The HUB has the ASIX AX88772 chipset which fails for me if I do "ifdown / ifup". But it works perfectly for the first 30 minutes. After that some kind of power save that I have not spotted yet sends an "ifup" that kills the net after the next transmission.

mikerr
Posts: 2826
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: Chromecast ethernet PSU + pizero working !

Tue Jan 05, 2016 10:53 am

Speed as a server:

Code: Select all

pi@pizero3:~ $ iperf -s
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
[  4] local 192.168.0.60 port 5001 connected with 192.168.0.92 port 57760
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.0 sec  69.0 MBytes  57.8 Mbits/sec
[  5] local 192.168.0.60 port 5001 connected with 192.168.0.62 port 56367
[  5]  0.0-10.0 sec   102 MBytes  85.2 Mbits/sec
First one (57.8 Mbps) is a B+ so zero to B+ is 94/58
2nd a PC (85 Mbps) - zero to PC 94/85
Android app - Raspi Card Imager - download and image SD cards - No PC required !

Pithagoros
Posts: 578
Joined: Wed Nov 12, 2014 8:16 pm

Re: Chromecast ethernet PSU + pizero working !

Tue Jan 05, 2016 11:13 am

Thank you!

That solves the problem of what to do with £20 google play credit I've had lying around for months. One of these is on its way.

bjoertel
Posts: 1
Joined: Thu Jan 14, 2016 5:06 am

Re: Chromecast ethernet PSU + pizero working !

Thu Jan 14, 2016 5:14 am

My Chromecast ethernet adapter just arrived and I've been trying to get it up connected but I'm not having luck. I baked a Raspbian Jessie Lite card and set it up on my Pi B to have a static IP but when I transferred the card over to the Zero and boot it up connected to the Chromecast adapter and try to SSH into it I can't connect. How did you all set up your IPs?

drible79
Posts: 2
Joined: Wed Jan 20, 2016 4:24 pm

Re: Chromecast ethernet PSU + pizero working !

Wed Jan 20, 2016 4:27 pm

Hi,

I am having the same problem, I have loaded a fresh install of both Raspbian and Raspbian Lite and it is not recognised in either, it is also not recognised with lsusb. I have even tried to install all of the Realtek drivers using install realtek-nonfree but it tells me that package is the latest.

Any thoughts?

Thanks

fruitoftheloom
Posts: 24473
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Chromecast ethernet PSU + pizero working !

Wed Jan 20, 2016 5:51 pm

drible79 wrote:Hi,

I am having the same problem, I have loaded a fresh install of both Raspbian and Raspbian Lite and it is not recognised in either, it is also not recognised with lsusb. I have even tried to install all of the Realtek drivers using install realtek-nonfree but it tells me that package is the latest.

Any thoughts?

Thanks
Silly question but are you plugging the Chromcast USB Cable into the Data USB Port ?

The Ethernet Connection on the plug should be attached to a Device which is a DHCP Server AFAIAA, therefore the Plug is a DHCP Client !!

mikerr hopefully will respond ;)
Thinking outside the box is better than burying your head in the sand...

drible79
Posts: 2
Joined: Wed Jan 20, 2016 4:24 pm

Re: Chromecast ethernet PSU + pizero working !

Wed Jan 20, 2016 6:36 pm

Ah I had it plugged into the power port not the data port. Plugged it into the data port and it seems to have worked. Unfortunately that means I don't think it will do what I wanted as I want to plug an external hard drive into the data port.

fruitoftheloom
Posts: 24473
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Chromecast ethernet PSU + pizero working !

Wed Jan 20, 2016 6:45 pm

drible79 wrote:Ah I had it plugged into the power port not the data port. Plugged it into the data port and it seems to have worked. Unfortunately that means I don't think it will do what I wanted as I want to plug an external hard drive into the data port.
Yes clearly states one DATA Port: http://www.element14.com/community/docs ... ry-pi-zero

Ethernet NAS Drive may be an option :?:
Thinking outside the box is better than burying your head in the sand...

Return to “General discussion”