apjoshi
Posts: 4
Joined: Thu Jan 22, 2015 12:16 pm

Enable OpenGL on Raspbian Jessie for OpenCV

Wed Dec 09, 2015 9:15 am

Thanks to "moslemk" for solving this error...
GdkGLExt-WARNING **: Window system doesn't support OpenGL.

OpenGL is not enabled on Raspbian Jessie 8.0 by default.

In order to enable OpenGL you need to instal "libgl1-mesa-dri"

Code: Select all

sudo apt-get install libgl1-mesa-dri
OpenCV work perfect after installing the above mentioned library.

I cannot believe Devs at RaspberryPi missed such an important library in Raspbian Jessie that have caused so many hours of trouble] to its users...

here is original link for solution
viewtopic.php?t=121892&p826990
go to page-4

il_diavolo
Posts: 112
Joined: Mon Dec 02, 2013 7:56 pm

Re: Enable OpenGL on Raspbian Jessie for OpenCV

Fri Dec 11, 2015 10:11 pm

Yes, I found that installing libgl1-mesa-dri did work when using a connected monitor and "startx". However it would not work headless (on my set-up) with TightVNC with its virtual desktops. My solution to running Opencv headless (necessary with my robot) is to use x11vnc which mirrors the "true" desktop.
If anyone has resolved this using TightVNC I would be interested to hear.
il.diavolo

Return to “Beginners”

Who is online

Users browsing this forum: No registered users and 33 guests