djalden
Posts: 5
Joined: Wed Nov 14, 2012 2:29 pm

4K mostly working - portrait mode broken

Thu Sep 17, 2015 3:14 am

Hi,
Thanks to viewtopic.php?f=38&t=79330 - I've successfully setup a Raspberry Pi 2 display to a Dell P2715Q in 3840x2160. My /boot/config.txt looks like:

Code: Select all

disable_overscan=1
hdmi_ignore_edid=0xa5000080
hdmi_group=2
hdmi_mode=87
hdmi_timings=3840 1 48 32 80 2160 1 3 5 54 0 0 0 28 0 248140000 3
framebuffer_width=3840
framebuffer_height=2160
framebuffer_depth=24
max_framebuffer_width=3840
max_framebuffer_height=2160
gpu_mem=256
hdmi_pixel_freq_limit=400000000
If I add "display_rotate=1", it no longer boots (the green LED blinks a couple of times, but nothing is displayed on the monitor and I'm unable to connect to it over the network). I've tried upping the gpu_mem to 640, but I have the same problem.

I don't need the console rotated, just rotating X would work too. However, I wasn't successful with xrandr either.

Any suggestions (or ideas as to why it won't boot with display_rotate=1)?

...thnx,
...dave

User avatar
AndyD
Posts: 2334
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
Contact: Website

Re: 4K mostly working - portrait mode broken

Thu Sep 17, 2015 3:43 am

You may be able to rotate X11 by adding a rotate option to /usr/share/X11/xorg.conf.d/99-fbturbo.conf

Have a look at man fbturbo

Code: Select all

 Option "Rotate" "string"
        Enable rotation of the display. The supported  values  are  "CW" (clockwise,  90  degrees),  "UD"  (upside down, 180 degrees) and 
        "CCW" (counter clockwise,  270  degrees).  Implies  use  of  the shadow framebuffer layer.   Default: off.
I haven't tried it myself.

djalden
Posts: 5
Joined: Wed Nov 14, 2012 2:29 pm

Re: 4K mostly working - portrait mode broken

Thu Sep 17, 2015 2:24 pm

I'm unable to find fbturbo as a package. I believe I'm running the latest Raspian (i've run 'apt-get update' and 'apt-get upgrade' without any errors).

I started to follow the instructions at https://github.com/ssvb/xf86-video-fbtu ... stallation - but I immediately ran in to an error when trying to install xorg-dev:

xorg-dev : Depends: xserver-xorg-dev but it is not going to be installed

I tried installing xserver-xorg-dev, but that threw another error. I really don't want to go down this rabbit hole if I can avoid it (especially when I'm not 99% sure it's going to fix my issue). :)

Any other thoughts?

djalden
Posts: 5
Joined: Wed Nov 14, 2012 2:29 pm

Re: 4K mostly working - portrait mode broken (SOLVED!)

Thu Sep 17, 2015 8:25 pm

Thank you AndyD. I decided to reinstall Raspbian and this time I saw the fbturbo driver. Turns out the Screenly distro (really nice digital signage software) must not be using Raspbian as its base image (I thought it was). I've now got my raspberry pi driving a 4K LCD panel. :)

In case someone else is trying to do it:

1) Install the latest Raspbian.
2) Replace /boot/config.txt with:

Code: Select all

disable_overscan=1
hdmi_ignore_edid=0xa5000080
hdmi_group=2
hdmi_mode=87
hdmi_timings=3840 1 48 32 80 2160 1 3 5 54 0 0 0 28 0 248140000 3
framebuffer_width=3840
framebuffer_height=2160
framebuffer_depth=32
framebuffer_ignore_alpha=1
max_framebuffer_width=3840
max_framebuffer_height=2160
gpu_mem=256
hdmi_pixel_freq_limit=400000000
3) Add the following inside the "Device" section of /usr/share/X11/xorg.conf.d/99-fbturbo.conf (note that you can use either "CW" or "CCW" - just depends on which way you rotated the screen):

Code: Select all

Option "Rotate" "CCW"

cookiem6
Posts: 2
Joined: Sat Jun 09, 2018 1:22 pm

Re: 4K mostly working - portrait mode broken

Sat Jun 09, 2018 1:35 pm

Hello,
could anyone make this work on a Raspberry Pi 3 as well?
I am running Raspbian Sketch on it and it seems that the fbturbo is not installed there. Does it make any sense to install the fbturbo drivers on the Raspberry 3 to apply this trick?

Thanks,
Kevin

Return to “Graphics, sound and multimedia”