alastair_m
Posts: 6
Joined: Sat Sep 12, 2015 1:51 pm

RPi interfering with router?

Sat Sep 12, 2015 2:05 pm

My (new) RPi appears to be interfering with my router somehow. I'd appreciate some advice on how to diagnose and fix the problem.

I did the initial set-up of the RPi downstairs, using the TV as a monitor. That included giving it a static IP address.

I then moved it upstairs to where I'll be doing most of the work on it. It's sitting under my computer desk, on top of my main computer tower and about 18" from my router, which sits on top of the desk. Both my main computer and the RPi are connected to the router by Ethernet cables, and I'm using PuTTY to run the RPi "headless" from my main computer.

When the RPi is powered up in this configuration my Internet connection pretty much seizes up. I can't check emails or access web pages on my main computer, and when I downloaded the RPi's operating system updates it took over an hour to download a few tens of kB (!)

Unplugging the RPI's Ethernet cable from the router (but leaving the RPi powered up) restores normal Internet access.

It shouldn't be a wireless issue as the router's wifi is switched off. (I use a separate wireless access point in a different room.)

Help, please. Can anyone suggest what's causing the problem and how to fix it?

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 6066
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: RPi interfering with router?

Sat Sep 12, 2015 3:53 pm

alastair_m wrote: ...
I did the initial set-up of the RPi downstairs, using the TV as a monitor. That included giving it a static IP address.
...
Unplugging the RPI's Ethernet cable from the router (but leaving the RPi powered up) restores normal Internet access.
...
I suspect that giving the Pi a static ip address may be (part of) the problem. You may have chosen one which clashes with those given out via the DHCP server on the router (assuming is set up to do that - most are). Try allowing the Pi to get it's IP address from the router via DHCP and report back. Personally I rarely use static IP addresses but arrange for the router to assign a fixed ("pseudo-static") IP address associated with the MAC address of the Pi (or other networked device) - this is sometimes called "DHCP reservation".** What make/model of router BTW?
Trev.
** Some examples for "piggy-backed" (old) routers here:
http://www.cpmspectrepi.webspace.virgin ... uters.html
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, and a A+) but Buster on the P4B's & P400. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

alastair_m
Posts: 6
Joined: Sat Sep 12, 2015 1:51 pm

Re: RPi interfering with router?

Sat Sep 12, 2015 4:11 pm

Thanks for the quick reply.

It's not an IP address clash. The router --- which is a Netgear DG834g v2 --- is set up to allocate IP addresses in the range 192.168.0.2 to 192.168.0.15, and the RPi's static IP address is 192.168.0.21.

I maintain a list of the static and reserved IP addresses on my LAN to avoid clashes, and this is the first time I've used 21.

I've also checked the router's "connected devices" list, and there's no other device using 21.

My main suspects are (i) the RPI's Ethernet port or (ii) the RPI itself. I may have to return it to Amazon ........... which would be a bit of a pain, as I've been looking forward to playing with it.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 6066
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: RPi interfering with router?

Sat Sep 12, 2015 4:19 pm

alastair_m wrote:Thanks for the quick reply.
It's not an IP address clash. The router --- which is a Netgear DG834g v2 --- is set up to allocate IP addresses in the range 192.168.0.2 to 192.168.0.15, and the RPi's static IP address is 192.168.0.21.
I maintain a list of the static and reserved IP addresses on my LAN to avoid clashes, and this is the first time I've used 21.
I've also checked the router's "connected devices" list, and there's no other device using 21.
My main suspects are (i) the RPI's Ethernet port or (ii) the RPI itself. I may have to return it to Amazon ........... which would be a bit of a pain, as I've been looking forward to playing with it.
Hmmm ... strange one, the only other thing that comes to mind is, could there be an odd problem with the Pi's ethernet cable?
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, and a A+) but Buster on the P4B's & P400. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

alastair_m
Posts: 6
Joined: Sat Sep 12, 2015 1:51 pm

Re: RPi interfering with router?

Sat Sep 12, 2015 4:35 pm

Sorry. I should have mentioned that I've tried changing the Ethernet cable. No difference. The Internet connection still seizes up when the cable is plugged in and returns to normal when it's unplugged (at either end.)

drgeoff
Posts: 11559
Joined: Wed Jan 25, 2012 6:39 pm

Re: RPi interfering with router?

Sat Sep 12, 2015 4:45 pm

Humour us and configure the RPi to get an IP address by DHCP.

Even better, get another SD card, install Raspbian, don't touch the default network configuration, plug it into your network and see if you still have the interfering problem.
Quis custodiet ipsos custodes?

alastair_m
Posts: 6
Joined: Sat Sep 12, 2015 1:51 pm

Re: RPi interfering with router?

Sat Sep 12, 2015 5:07 pm

Again, I've already tried reverting to getting the RPi to get its IP address via DHCP ........ but I've just done it again, and there's no difference. The Internet connection seizes up when the Ethernet cable is connected and returns to normal when it's disconnected.

Please trust me to be able to edit the interfaces configuration file, particularly when all I'm doing is deleting some lines and replacing "static" with "dhcp"!

The RPi now has an IP address of 192.168.0.13, which is what I would have expected.

alastair_m
Posts: 6
Joined: Sat Sep 12, 2015 1:51 pm

Re: RPi interfering with router?

Sat Sep 12, 2015 5:10 pm

I can even observe this happening "on the fly". I connect the Ethernet cable and ask my main computer's browser to fetch a new web page. I get the "spinning disc" buffering icon, but nothing else. I then disconnect the Ethernet cable and, hey presto, the requested web page appears.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 6066
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: RPi interfering with router?

Sat Sep 12, 2015 5:35 pm

alastair_m wrote:Again, I've already tried reverting to getting the RPi to get its IP address via DHCP ........ but I've just done it again, and there's no difference. The Internet connection seizes up when the Ethernet cable is connected and returns to normal when it's disconnected.
Please trust me to be able to edit the interfaces configuration file, particularly when all I'm doing is deleting some lines and replacing "static" with "dhcp"!
The RPi now has an IP address of 192.168.0.13, which is what I would have expected.
...
I can even observe this happening "on the fly". I connect the Ethernet cable and ask my main computer's browser to fetch a new web page. I get the "spinning disc" buffering icon, but nothing else. I then disconnect the Ethernet cable and, hey presto, the requested web page appears.
OOC (it may give someone a clue) when the ethernet cable is connected can the Pi "see" the internet?
Can you ping the main computer from the Pi and vice versa?
I guess also the output of ifconfig on the Pi and the equivalent for the other computer (what OS?) may be useful.
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, and a A+) but Buster on the P4B's & P400. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

alastair_m
Posts: 6
Joined: Sat Sep 12, 2015 1:51 pm

Re: RPi interfering with router?

Sat Sep 12, 2015 6:45 pm

I managed to download the operating system updates for the RPi this morning (although it took a very, very long time), so it would seem that it's able to see the Internet. How should I go about confirming this? (I can't use the GUI via PuTTY.)

My desktop computer --- which is running Windows 8 --- can ping the RPi, and the RPi can ping the desktop computer.

The output from rfconfig confirms the IP address (which is now 192.168.0.3), etc. It also reports:-
RX packets:1354 errors:0 dropped:0 overruns:0 frame:0
TX packets:443 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000

This time the Internet connection didn't return to normal when I unplugged the Ethernet cable, and I had to re-boot the router.

beta-tester
Posts: 1412
Joined: Fri Jan 04, 2013 1:57 pm
Location: de_DE

Re: RPi interfering with router?

Sat Sep 12, 2015 7:07 pm

alastair_m wrote:(..)When the RPi is powered up in this configuration my Internet connection pretty much seizes up. I can't check emails or access web pages on my main computer, and when I downloaded the RPi's operating system updates it took over an hour to download a few tens of kB (!)
(..)Help, please. Can anyone suggest what's causing the problem and how to fix it?
is some strange traffic visible on the routers network port status LEDs, as soon you connect the RPi?
(constantly blinking on all ports)

or is only your windows desktop pc affected from that issue?
in some conditions i observed a situation where windows stopped wroking its internet network connectivity as long IPv6 and IPv4 are both enabled at network adapter settings.
disableing IPv6 solved that kind of issue i observed, but if it is, i have no explanation why disabling IPv6 and keep IPv4 enabled make such difference...
an not on all networks i observed that kind of issue.

maybe you can try that out on your Windows PC.
{ I only give negative feedback }
RPi B (256MB), B (512MB), B+, ZeroW; 2B; 3B, 3B+; 4B (4GB)

User avatar
DougieLawson
Posts: 40833
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: RPi interfering with router?

Sun Sep 13, 2015 7:20 pm

Install ethtool and take a look at what settings your eth0 interface is running with. You may find your RPi is running slow or with half duplex (or both).
Any language using left-hand whitespace for syntax is ridiculous

Any DMs sent on Twitter will be answered next month.
Fake doctors - are all on my foes list.

Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Return to “Troubleshooting”