stockton
Posts: 99
Joined: Mon Aug 24, 2015 6:06 am
Location: South Africa

bluetooth issue on RPiBv2

Mon Aug 24, 2015 6:14 am

I am attempting to get a Bluetooth dongle working with my Raspberry Pi Bv2 but failing.
The following appears in my logs:
[1364927.103431] Bluetooth: Core ver 2.19
[1364927.103570] NET: Registered protocol family 31
[1364927.103586] Bluetooth: HCI device and connection manager initialized
[1364927.103627] Bluetooth: HCI socket layer initialized
[1364927.103650] Bluetooth: L2CAP socket layer initialized
[1364927.103704] Bluetooth: SCO socket layer initialized
[1364927.111893] usbcore: registered new interface driver btusb
[1365349.662694] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[1365349.662727] Bluetooth: BNEP filters: protocol multicast
[1365349.662771] Bluetooth: BNEP socket layer initialized
[1365349.664452] Bluetooth: RFCOMM TTY layer initialized
[1365349.664523] Bluetooth: RFCOMM socket layer initialized
[1365349.664581] Bluetooth: RFCOMM ver 1.11
[1365793.623589] usb 1-1.3: USB disconnect, device number 5
[1365796.419469] usb 1-1.4: new full-speed USB device number 6 using dwc_otg
[1365796.524945] usb 1-1.4: New USB device found, idVendor=0c10,
idProduct=0000
[1365796.524974] usb 1-1.4: New USB device strings: Mfr=1, Product=2,
SerialNumber=3
[1365796.524992] usb 1-1.4: Product: SiW
[1365796.525008] usb 1-1.4: Manufacturer: SiW
[1365796.525025] usb 1-1.4: SerialNumber: 2600B0720200
[1366151.303297] usb 1-1.4: USB disconnect, device number 6
[1511194.617796] usb 1-1.3: new full-speed USB device number 7 using dwc_otg
[1511194.723225] usb 1-1.3: New USB device found, idVendor=0c10,
idProduct=0000
[1511194.723250] usb 1-1.3: New USB device strings: Mfr=1, Product=2,
SerialNumber=3
[1511194.723267] usb 1-1.3: Product: SiW
[1511194.723283] usb 1-1.3: Manufacturer: SiW
[1511194.723300] usb 1-1.3: SerialNumber: 2600B0720200
[email protected] ~ $ hcitool scan
Device is not available: No such device
[email protected] ~ $ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 18a5:0245 Verbatim, Ltd
Bus 001 Device 007: ID 0c10:0000

Please tell me what I have missed?

User avatar
Douglas6
Posts: 4674
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: bluetooth issue on RPiBv2

Mon Aug 24, 2015 1:19 pm

What make/model Bluetooth dongle? What does 'hciconfig -a' show?

stockton
Posts: 99
Joined: Mon Aug 24, 2015 6:06 am
Location: South Africa

Re: bluetooth issue on RPiBv2

Mon Aug 24, 2015 2:53 pm

The dongle is an Esquire bluetooth 60M
and hciconfig -a gives me
hci0: Type: BR/EDR Bus: USB
BD Address: 00:02:72:B0:00:26 ACL MTU: 120:20 SCO MTU: 0:0
DOWN
RX bytes:764 acl:0 sco:0 events:30 errors:0
TX bytes:96 acl:0 sco:0 commands:30 errors:0
Features: 0xff 0xff 0x05 0x38 0x18 0x18 0x00 0x00
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy:
Link mode: SLAVE ACCEPT

User avatar
Douglas6
Posts: 4674
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: bluetooth issue on RPiBv2

Mon Aug 24, 2015 3:03 pm

OK, try an 'hciconfig hci0 up'. You have installed BlueZ? What did you want to use Bluetooth for?

stockton
Posts: 99
Joined: Mon Aug 24, 2015 6:06 am
Location: South Africa

Re: bluetooth issue on RPiBv2

Tue Aug 25, 2015 5:16 am

I want to learn about Bluetooth communications. I already have garage door control via WiFi and now want to do the same with Bluetooth. I would also like to get a socket scenario developed using Bluetooth as I also have that using WiFi.
So basically it is a learning thing.
The command you suggested gives :-
[email protected] ~ $ hciconfig hci0 up
Can't init device hci0: Operation not permitted (1)
[email protected] ~ $ sudo hciconfig hci0 up
Can't init device hci0: Invalid request code (56)
[email protected] ~ $

stockton
Posts: 99
Joined: Mon Aug 24, 2015 6:06 am
Location: South Africa

Re: bluetooth issue on RPiBv2

Tue Aug 25, 2015 5:24 am

To answer your other question I have bluez installed. I did an install based on a suggestion I found on raspberrypi-spy.org.
sudo apt-get install --no-install-recommends bluetooth
If I attempt a reinstall I get:-
[email protected] ~ $ sudo apt-get install bluez
Reading package lists... Done
Building dependency tree
Reading state information... Done
bluez is already the newest version.
bluez set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
[email protected] ~ $

User avatar
Douglas6
Posts: 4674
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: bluetooth issue on RPiBv2

Tue Aug 25, 2015 12:31 pm

stockton wrote:[email protected] ~ $ sudo hciconfig hci0 up
Can't init device hci0: Invalid request code (56)
[email protected] ~ $
That's not good. I'm guessing your dongle is not supported. You might try Googling that error.

fruitoftheloom
Posts: 19816
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: bluetooth issue on RPiBv2

Tue Aug 25, 2015 12:42 pm

Douglas6 wrote:
stockton wrote:[email protected] ~ $ sudo hciconfig hci0 up
Can't init device hci0: Invalid request code (56)
[email protected] ~ $
That's not good. I'm guessing your dongle is not supported. You might try Googling that error.
Bus 001 Device 007: ID 0c10:0000

That is the BT Dongle and has no manufacturer listed, Googling seems to throw up many non detecting / working issues ;)

May be time to spend £5 on another Dongle :?:
adieu

My other Computer is an Asus CS10 ChromeBit running Chrome Operating System.
HP Envy 4500 Wireless Printer supported by HPLIP software in Raspbian Buster.
Raspberry Pi Model 2B v1.1

Return to “Troubleshooting”